SmartThings Community

[RELEASE] Aeon WallMote Dual & Quad - 2 & 4 Button

dth_remotes

(Mark) #81

@grepper did you manage to update the f/w please? Had the same issues you experience since picking one up when they were initially released.


(Eric M) #82

I have had strange behavior with mine and thought it was because they were early units. Mine will constantly freeze and can only be reset by plugging them into usb. I just uploaded a new handler that restricts the sending of the “Color” parameter to 3 times after changing the preferences. I feel like updating preferences on this device may contribute to it freezing, but I can’t tell for sure. Of course, I have to blindly send the update for the “Color” preference, because there is a bug in the firmware that makes it so the device never confirms that the config has been updated.

At this point, I really can’t recommend this device. It has too many bugs. This is a shame as it is a great looking button device.


(Mark) #83

Thanks Eric!

Just updated and will see how it goes, the color updated successfully in a test. I see the same issues as yourself but there is just no consistency as to when it goes haywire, from what I have seen anyway.

There is a f/w fix for this and the battery drain issue but I do not have their stick and no idea if it can be carried out via the ST hub but assume not looking at the instructions. May have to get hold of one but is would be good to know if it actually fixes the issues before I pay out the money. I was hoping that someone who owned one may have already tried it.

https://aeotec.freshdesk.com/support/solutions/articles/6000170550-wallmote-quad-firmware-update-4-18-2017-


(Eric M) #84

Both of my WallMotes are ZW130-A which may be a prototype model number. Maybe not though. What does yours say on the back?


(Mark) #85

Mine says ZW130-C (868.42MHz), If you look at the link I posted it states that the letter is the Region code, A=US, B=AUS, C=EU.

I was one of the first to get one in the UK. I doubt they are prototype models. I am going to get hold of a stick, will be here tomorrow and will do the f/w update. However as there is no consistency in the issue happening it may be a while to be sure if it worked of course. My bet is though as they have actually acknowledged the issue and issued a f/w update then I would think it is, it may even fix other issues and even give us the ability to use the swipe on separate buttons correctly, ok, ok, probably getting a little carried away but you never know :grinning:


(Eric M) #86

Oh yeah, I should have kept reading. I will upgrade mine and see what kind of difference it makes.


#87

I have been having the same problem; will also try and report back. Thank you both and fingers crossed!


(Eric M) #88

I updated the firmware on mine yesterday and they seem to be behaving better. I’ll post again if I notice otherwise.


(Mark) #89

Did mine also Eric and it seems fine although it only went haywire every several days or so. Looks promising though. I have not had time to look but do you think there may be a chance with the latest f/w to grab the swipe gestures from the switch, would be great if you were able to find a way to enable dimming that way.


(Tim) #90

Can Smart Home Monitor be used with thIs to ARM (AWAY) / ARM (STAY) / DISARM?

Can this also be done with some of the supported and/or ones with device handlers for key fobs or other remotes? Not necessarily for lights etc but for arm/disarm.

Thank you!


(Mark) #91

This can easily be done with an App. I use both Button Controller Plus and Advanced Button Controller. You can very easily assign any of actions you mention to any button to a Pushed or Held action etc.

The DH is simply an interface between the controller and ST it is the app that you use to define what happens when each button is pressed, held, double tapped etc.

The same applies to KeyFobs etc.the above 2 apps I mention should pretty much cover everything you mention although there are some specific apps and or DH’s for some of the newer fobs like the newest Fibaro one.

Hope this helps.


(Tim) #92

thank you so much chippie! I will check it out.

I just got the Aeon WallMote Quad. Not sure which firmware it is but hoping 1.7 or newer or whatever is supposed to work. I guess I have to also get a Z stick to see which firmware and to update it. Guess I cannot use the usb cable to a PC route? prob for power only?

Update: I think I figured the problem out below.

I got the device handler loaded, but it doesn’t seem to do anything and set up a easy light on switch smartapp with it but no go. I will have to keep messing with it etc to see why. I get no battery feedback, just 3 boxes below the main remote large icon. the 2 left small boxes are just (2) dashes each “–”. The far right says Configure and always has a red dot.

I will remove from system and start over again, first without this custom device handler.

This one seems trickier than other devices. All the others work right off the bat. I am doing something wrong here.

btw, what is Fibaro one? I cannot find anything on it?

Ok I see:


(Mark) #93

After hitting the configure button press the little button on the back on the Wallmote. Think you figured this.

You will defo need to update the f/w if not on the latest version or you will get crazy things going on with the onboard lights etc. occasionally and it will stop responding until you plug it in to charge. It also greatly improves the battery life, I have not charged mine since updating. Go to the IDE, My Devices, click on the Wallmote and under ‘Raw Description’ you should be able to see the f/w version. Mine is 1.07 but not sure if there is a newer one, not checked.

Not sure what stage you are at but drop a note if you need any more help.

:slight_smile:


(Tim) #94

Thank you!!! ; )

Says I have v1.08 which is funny as their website still has 1.07?
https://aeotec.freshdesk.com/support/solutions/articles/6000170550-wallmote-quad-firmware-update-4-18-2017-

Got this week from Amazon. Thanks for the help…really liking this SmartThings as I figure things out.


(Mark Povolo) #95

What are you all doing to remember what the 4/8 possible button clicks do?


(Mark) #96

Nothing, I just forget lol

Seriously though, I never seem to have forgotten unless I do not use it for quite a while after which it soon comes back after a few presses. Nothing stopping you sticking a label to the back of it with the details of that you have set them to of course.


(Tim) #97

May have to print out some small decals of the “routines” icons. Or if u live in a dump, just scribble something on it with a Sharpie. : /


(Mark Povolo) #98

Thanks. I like the sharpie idea lol


(Tim) #99

VL124_lg

$T2eC16F,!zUE9s38-N6TBQ-w)4s1ew--60_1


(Tony) #100

Yeahh… At last…
I received an email today from Aeotec telling me that the Wallmote is now globally available and no longer an US only thing !!! Hourray !
I ordered my Quad just now and will receive it on Friday…
Something to play with for the weekend…
I have a large room with 4 light zones to control ! (currently done via the 4 bottom buttons on an Harmony Elite remote).
Perfect…