[RELEASE] Aeon WallMote Dual & Quad - 2 & 4 Button

OK, got the device handler installed and device paired.

But I’m a little confused about the config process. In the ST app I go to the settings and enter in values and save them. But when I go back to the page, there is still a red dot over the config and pressing it does nothing.

I’m not sure what the “Replace” button does at the bottom. It seems to go to a page where it is trying to check the health of the device. I did wake up the device when in that state and it says “Ready to Replace”

OK, I think I got it replaced. Had to save it. But the config button on the main page still doesn’t appear to do anything?

I kind of was expecting somehow that I would end up with two buttons? When I try to have some automation trigger when a button is pressed, I only see the entire device as a button…

Is there a good walk through on how to setup use this device?

The config “button” in the settings page is really a box, not a button and doesn’t do anything except indicate when an update is pending to be pushed to the device. When there is a pending change, you will see a red dot in that configure box. When the device updates, the dot will go away. You can’t press the box in the app and get it to update. It updates once a day, I think, automatically, or when you press the button on the back of the device.

You will know when the device is updating automatically when the crosshairs start flashing for about 5 seconds.

Gotcha. I think I got it to update then.

What app are you using to set the automation?

If you are using Smart Lighting, for example, once you select Button for the trigger and then Aon Wallmote for the Button, you should see a selection for “Button Number”. One should be the top and Two should be the bottom.

I was associating it with an automation routine (wanted to provide a quick/easy arm/disarm for SHM).

…and you’re right, it does give me option to select which button once I select it. Hadn’t bothered to get that far.

Works great!

So I think I have finally resolved my issue with presses not working properly by coding around ST’s shortcomings. Posting this here in case anyone else is experiencing the same issues.

I have two WallMotes on 2 hubs in two different locations all performing the same. The buttons were coded via Smart Lights to turn a smart bulb on and off. I found that the automation did not always reliably work on the first button press. (I tried both toggle and using two buttons for on/off). The smart bulbs being controlled were also controlled by Smart Lights to turn on and off at a particular time.

The DH seemed to be working ok, as all button presses were logged, but the lights did not turn on or off nonetheless.

My presumption is that despite indications to the contrary, ST is not properly keeping track of the bulb’s on/off status and in some cases not sending the command to the bulb. I got around this by coding the buttons in webCore, using an IF statement looking for both a button press AND the status of the bulb.

The WallMote has functioned without an issue since making that change.


Have you thought of adding the slider option? Thank you.

The slider option is really meant for direct device association. Z-wave to z-wave device. My device handler has a way to use it as an extra type of button press but that is all that can really be done with it outside of an association.

Anyone know why my wallmote sometimes doesn’t work but blinks blue, blue then red instead? I have the latest version of the remote (triangle at the bottom) using it with smart lighting. I can’t find what that colour sequence means anywhere online…

I just purchased and setup a WallMote Quad using the instructions from Aeotec

These use the DH from erocm1231 and the Z-wave tweaker from codesaur. I’ve been able to setup four different light sets. 1: is three lights in a living room fixture, 2,3, and 4 are all single lights. All four sets are dimming lights but I can’t get dimming to work using the WallMote for any of them. I’m also confused about how the button #5 works. I saw the post that it is for swiping but that doesn’t help make it any more clear.

Any help would be appreciated, I’d like to be able to dim all four sets with the WallMote using their individual buttons.

If you swipe on the pad either up or down on any of the quadrants it produces another button event with this device handler. Swipe up on any of the quadrants and it sends a button 5 pushed event. Slide down and it sends a button 5 held event.


A lot of people seem to want to use the slide feature to dim another device up / down. To do this you need to directly associate the dimmable Z-wave device with the WallMote.

I believe association group 3, 5, 7, & 9 are for this purpose.

Having another issue using it with smart lighting, seems like all buttons always need to be pressed twice if the wallmote has been dormant for a while, does anyone else experience this?

Edit, I’ve just read that @Bry was having the same issue. Would you be able to share the webcore piston you used to get around this issue?

Many thanks.

Here you go. I went the verbose way and accounted for both the off and on conditions instead of using Toggle. I think what is more important is to disable command optimization which insures that the command gets sent regardless of what ST thinks the state is.

You’ll probably experience a very small but tolerable lag.


Thanks @Bry this is really useful. Just one thing when you say ‘disable command optimisation’ where can I do this? Many thanks again.


In the top right corner make sure Show Piston Settings is checked. That will add a Settings block to your code.

Click on Settings in the code to bring up the Piston Settings dialog.

Click on the Show/Hide Advanced Options gear, lower right.

Set Command Optimizations to “Disabled” and Save.

That will add this block to your code:

disable command optimization;
end settings;

Let us know how if this solves your issue!


Thanks! Will do!

I have just started working with ST and webCore. I got a WallMote quad. It is connected to the ST hub and is seen in the ST Android app, smartthings.com, and webCore. The device driver is the one from this page (with update timestamp 2017-06-19).

A piston I wrote reliably detects and reports any of the 4 button presses. The holds are sometimes reported correctly and sometimes reported as button 5 press or button 5 hold. The swipe gestures are also reported as button 5 press or button 5 hold.

I don’t know what I don’t know yet. I suspect a defective end user (me), but I’m not sure where I should be looking. I would appreciate any suggestions or hand-holding.

Hi everyone,I’m confused
I bought 2 wallmotes with the intention to control 4 sets of lights in our new kitchen with the ability to dim all 4 sets of lights as aeotecs websites says.
Now after reading all of this thread post to post this doesn’t seem to be the case🤔
Does aeotec do a hub to control all my lighting because I can’t see one.
Please advise because I can’t see that this switch is fit for purpose at the moment unless I’m missing something.
Many thanks Kev

Hi, thank you for this device handler. I recently got this and used this device handler and it’s working pretty well. The only thing I was wondering about is that it seems to me that the remote seems to go to sleep or something because whenever I press one of the button there is a pretty long delay before it performs the action. Whenever it has performed the action I can again press any button and it perform the action(s) swiftly.

I was wondering if anyone else experienced this, and if any tips on how to resolve this?

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.