SmartThings Community

[RELEASE] Aeon WallMote Dual & Quad - 2 & 4 Button

dth_remotes

(Ron) #183

No ideas left for me. My 2 Quad Wallmotes work fine in terms of quick tap (press) or long press(hold). Not sure why your’s behave differently.


#184

So how can I use the swipe feature for the wallmote quad and which smartapps can I use?


(Joel W) #186

I have the latest DTH but yet my battery when charged shows 29%. This unit has been charged maybe three times. Any ideas? I did press the button on the back to send a refresh. Unless It needed to be held longer.


(Eric M) #187

The device handler will request a battery report if it hasn’t received one in over 24 hours. So if the device isn’t sending the report on its own, it will take a day or so for one to be requested.


(Ron) #188

@joelw135 the 24 hr check is in the Wake report so if you have the wake feature turned off you may need to activate the device to issue the wake report request.

You could modify your configure command to issue a battery get so you could force a battery update. I do this in a lot of my device handlers.
You can just add cmds << zwave.batteryV1.batteryGet()
like you see in this code block
Then wake the wallmote and issue configure.

def configure() {
	state.enableDebugging = settings.enableDebugging
    logging("Configuring Device For SmartThings Use")
    def cmds = []
    cmds = update_needed_settings()
    cmds << zwave.batteryV1.batteryGet()
    sendEvent(name: "numberOfButtons", value: settings.buttons ? (settings."3" == "1" ? settings.buttons.toInteger() + 1 : settings.buttons) : (settings."3" ? 4 + 1 : 4), displayed: true)
    if (cmds != []) commands(cmds)
}

(Joel W) #189

Thanks Ron, I will try that.


(George) #190

anyone have this working? applies the DH from eric site but nothing. I see something very different then most screenshots. I see 4 button when i click on the “thing” but i get an error when i click a button. I ideas?


(Ron) #191

Yes it works fine. Sounds like you didn’t apply the DH correctly or some other fault. But without the steps you took nobody can really help you.

Look for FAQ on using custom device handlers there are plenty of instructions on this forum on how to install these. You have to install in the ide, publish, change your device to use the newly published dh and then follow any dh setup steps.


(George) #192

I got it to work. I needed to remove the device an re-add it after apply the DH. Good to go!


(Bryan) #193

I’m using two WallMote Quads on two separate hubs in two separate locations and I’m having the same issue with both.

When the WallMote hasn’t been used for a while, like overnight, it seems like it goes to sleep and takes more than one press to get a bulb to turn on. (I’m using SmartLighting with Cree and GE bulbs.)(I’ve also tried webCore but get the same results, so I don’t think it’s the app.)

Interestingly, when I make a single press and the bulb doesn’t react, I still see the press in the recent history on the app. (Using Classic).

Does anyone else get this? Is there a fix?

Thanks!


(Ron) #194

@Bry They should work on single press. Some of the older models and Firmwares can be flaky. What firmware do you have on yours? you can see it in IDE->My Devices->{Wallmote name}->Data section
image

If you have older than 1.8 you might want to upgrade.
If you have 2.0 then you have the latest model.

Contact Aeotec support, the guy that answers over there is very good and can help you get your devices working correctly.


(Bryan) #195

Thanks! Didn’t even consider the firmware. I’m at 1.8, so I’ll try upgrading and see how that goes.


(Ron) #196

1.8 is the latest so unfortunately you are fine. They had a 1.9 but they pulled it.
2.0 is only for newer model. You can tell the difference. Newer model has a little triangle at the bottom.
Looks like this.
image

I had two older models. One works perfect. One lost battery every 5 days. I got that one replaced with the new model. So far it works perfect as well.

I have the older model running on SmartThings. I have the newer model running on Home Assistant. So I can’t really compare them easily.


(Jared) #197

I’m pretty sure this is a bug with smartlighting in smartthings. My understanding is smartlighting thinks the bulb is already on so it issues another off command instead of the one you want. Then, the second time you hit the button it issues the on command because it now “knows” the light is in off state. It’s very annoying but we have just worked around the bug by hitting the buttons twice every time. No use waiting for samsung to fix it.


(Bryan) #198

I considered that, but I turned off “toggle” in SmartLighting and then mapped separate buttons to on and off so there should be not confusion as to which signal to send. I also coded on’s and off’s with webCore and got the same result.

Given this, I’m not convinced the issue is with SmartLighting.


(Ron) #199

This would be easy to test by looking at the state of the light in your SmartThings app before you issue the command. SmartLighting is going to get the state from the device. If your Device handler is able to get out of sync with the actual state then this is in fact an issue. However most devices I am aware of for actual zwave physical devices will correctly maintain state. Virtual devices can be tricky, custom device handlers that issue ir commands, or other hacks will also be an issue. For a standard Zwave or Hue light I would expect state to be correct.

Have you watched the IDE logs as you test?
Do you get feedback from the Wallmote when you press the button? Beep, Vibrate etc.
Do you see the Wallmote event in the logs?

To debug something like this I tend to use a custom smart app and add logging code to determine what part of the process is dropping the ball.

If you are not getting feedback from the wallmote when you press, until you press the second time and you don’t get event on first press then you can be pretty sure the hardware is the problem. If you do get feedback and an event then you have a software rule issue.

The way I make sure the device works is as follows.

  1. turn on vibrate feedback
  2. press and hold the button until you feel the vibrate, then immediately let off the button. This will be the same as a button press. For hold, wait for the vibrate and hold for about a 2 second count.

Using this method I always get my correct signal on 1st press with my 2 wallmotes.


(Bryan) #200

Thanks Ron. I have looked at the state and it is correct when I can recreate through testing. The WallMote is providing feedback as well and since I’m having the same issue with 2 WallMotes on two separate hubs, I’m reasonably sure the issue is related to the WallMote hardware itself.

The presses are reflected in the IDE logs. Whenever I have a press that doesn’t do anything, I can go into the log and see that the button was pressed.

The problem is intermittent, usually after the switch hasn’t been used for a while, which makes testing more difficult.


(Ron) #201

This proves it is NOT a hardware issue.
You state

  1. the state is correct in the ide and app
  2. the feedback is issued on first press
  3. presses are reflected in the IDE (this is the kicker, the ide has received the event so the hardware’s job is done)

Your issue is in your rule setup. What type of lights are your controlling?
What is their state before press?
What rules do you have configured?
What is their state after the press?

Try a more simple rule. Configure a notification when button is pressed. Since that should always fire it proves the event was received.
Use the “Notify Me When” smart app
Safety and Security->Notify Me When->Button Pushed…


(Brent Shipe) #202

So, I have a similar issue as you Bryan. We have a wallmote next to our bed, and only use it for 4 basic button presses. Two are direct toggles to two diff smart outlets (used for our lamps), then one for both on, one for both off. Recently, only 1 of the 4 toggles has been acting up. The one that doesn’t seem to respond is to a basic smartthings outlet. When I look in the log on smartthings it registers all three presses AND the wallmote vibrates on the presses so I know its registering them.

I’m interested in following your progress to troubleshoot. Sorry I don’t have any help.


(Bryan) #203

I’m continuing to troubleshoot this. Given the fact that several have noted the same issue, I don’t think the issue is specific to me.

I have installed the Notify Me app and I have confirmed, both through the app and through a review of the logs that the keypresses are being recorded.

@Ron suggested that rules may be the issue. I’m not thinking that is the case but I am going to test nonetheless. I’m going to remove all rules for the bulb being switched, except for the one that turns it off or on, and see what happens. This will either confirm or exclude rules as an issue.

If the issue wasn’t intermittant, this would be easier to track down.