SmartThings Community

[RELEASE] Aeon WallMote Dual & Quad - 2 & 4 Button

dth_remotes

(Jeremy Keen) #34

Edit the device by logging into the IDE -> Click My Devices -> Click the Wallmote device -> Scroll down and click Edit -> Set the ‘type’ to Aeon Wallmote. Then refresh in the app.


#35

just to make sure Im doing this correctly, I should only copy the code from line 19?

Screen Shot 2017-01-29 at 1.10.33 PM


#36

Ok. I got the code uploaded and device associated…


#37

Eric and Jeremy thank you SO much !! I got it working…!! its so nice. I have configured two button and like you said ST allows you to control all devices…


(Rob) #38

Thanks for creating this device handler. I’ve added the latest device handler to my published device handlers and ensured that the wallmote’s type is correct. My issues are:

  1. I can’t seem to get the wallmote device to stop reporting that it is “SYNCING”. Because of this, configuration changes I’ve made aren’t applied to the device. I tried pushing the button on the back of the device until it flashes yellow and stops but the device still reports “SYNCING”. Also it seems to drain the battery within a day. Any suggestions on this?

  2. SmartApp compatibiity seems limited. The Smart Lights smart app doesn’t recognize the wallmote device as having the appropriate capability. The only smart app I’ve gotten to work is the Button Controller. I’ve read the posts in this thread and can’t find the suggested smart apps

Thanks.


#39

If it works with button controller, it should work with smartlights for “button pressed.” Both are using the same “capability.button”

For CORE, see

For other smart apps that can work with button controllers, see the quick browse list for “remotes and buttons” in the community – created wiki

http://thingsthataresmart.wiki/index.php?title=How_to_Quick_Browse_the_Community-Created_SmartApps_Forum_Section


(Jeremy Keen) #40

It appears from the manual that each of the 4 buttons has a slide function. You say there is 1 additional button for the slide (#5 for the quad) but should there instead be 4 additional buttons. When I swipe on any of the buttons I the below in my logs. 0 indicates and up swipe and 1 a down swipe.

a5be044d-0639-45d3-b0aa-c31a6f45da42 11:52:07 AM: debug Unhandled zwaveEvent: SwitchMultilevelStopLevelChange()
a5be044d-0639-45d3-b0aa-c31a6f45da42 11:52:06 AM: debug upDown: 1
a5be044d-0639-45d3-b0aa-c31a6f45da42 11:52:05 AM: debug Unhandled zwaveEvent: SwitchMultilevelStopLevelChange()
a5be044d-0639-45d3-b0aa-c31a6f45da42 11:52:04 AM: debug upDown: 0


(Rob) #41

Thanks for the quick reply. The problem I’m seeing with the “Smart Lighting” smart app is that my wallmote device isn’t available in the list of devices to automate. I never get to the screen you’re showing.

Also, any thoughts on the “SYNCING” issue (#1 in my post)?

Thanks!

Rob


#42

The smartlighting official feature works the other way around, first you select the end device that you want to control, such as a lightbulb or another light switch, then you say you want to control it by using a button, and then you would get the list of button controllers.

I just mention that, because you should be able to see the two screens that I showed even if you don’t have a button controller at all. The list of available button controllers would be the next screen in the sequence after the two that I showed above. So first you select the light to be controlled, then you select the trigger which in this case is button press, then you say which button and you should see the list of button controllers on your account

And then after you select a specific button controller, you would get the list of its buttons.

As far as the syncing issue, I’m sorry, I don’t know, hopefully someone who has this device can comment.


(Rob) #43

I’m a dope. DUH! Sorry for wasting your time. The smart app works just fine.


#44

A lot of people get confused on SmartLighting. Like many features of SmartThings, it’s powerful and flexible, but it’s not intuitive. :wink:


(Rob) #45

Ok I figured out the syncing issue. The device handler will not set the need update to no if only the color is changed. If the color is changed along with at least one other configuration the device handler syncs properly. Of course you need to hold down the action button for two seconds after clicking done. The color is never changed btw.


(Eric M) #46

Alright, then you tell me how to distinguish an up slide from button 1 and one from button 2. Like I mentioned before, if there is a direct association between this device and a light bulb in group 1, a second light bulb in group 2, etc. (direct association), then you can have 4 button slide actions. The controller has no idea which button it is coming from so I have done the best I can by creating an extra button.


(Jeremy Keen) #47

Got it. I did not understand that there was no way to differentiate which button the slide comes from. So I will test using button 5 pushed and held options. Thanks for all of your work on this!


(Rick) #48

@RobLaJolla thanks for the info… I wasnt able to configure properly the wallmote… Where did you get the information regarding the push of action button after pressing “done” in the configuration? That was my problem… The wallmote was always “syncing” and I didn’t have the battery level. After pressing the action button, it seems to enter a program mode or something… Also, good catch on changing a value other than the color… It should be writting somewhere in the faq/readme of the DH.

@erocm1231 good job on the DH!


(Rob) #49

Rick,

I read about the action button behavior in that mini micro small as hell print owners manual. The rest was trial and error.


(Rick) #50

Well, I looked at the manual and there it is :

“In order to send your WallMote Quad new configuration commands from your Z-Wave controller or gateway, it will need to be woken up. […] press and hold the Action Button for 3 seconds(the buzzer chirp once and the orange LED will be ON) on the back of the WallMote Quad unit and then release it. This will trigger and send a wake up notification command to your controller/gateway, then your WallMote Quad iwll wake up for 10 minutes and the orange LED will fast blink while it is awake.”

So good catch!

So, everybody who wants to configure the WallMote with @erocm1231 DH, you have to “awake” the WallMote first then while it’s blinking, you press the “Done” button on the configuration page. It should send the modification to the unit and remove the “Need update” in the “Current State” of the device.

Cheers,

Rick


(Eric M) #51

I’ll explain a little bit about what you are noticing. There are two (actually three but I’ll keep it simple) types of Z-wave devices. Mains powered devices that act as repeaters and battery powered devices that do not. Mains powered devices are always awake and ready to receive configuration changes, respond to get commands, or apply association updates. These are devices such as switches, outlets, some sirens, etc. Battery devices are mostly asleep and do not respond to anything. They do this to conserve battery and it works very well. I have “sleepy” Z-Wave devices that have lasted over 4 years and are still going. These devices are Motion sensors, contact sensors, remotes, etc.

Because these devices will sometimes need to receive updates from the Z-Wave controller, they “wake up” and send the controller a “wake up” report. This wake up report is only sent to a single controller and the interval in which it wakes up is configurable. I don’t remember what the default is for this device, but the manufacturer has asked that it be set to 24 hrs. The shorter this interval, the more of an effect it has on battery life.

So this device, like all of my other Z-Wave handlers, tries to handle configuration how the Z-Wave developers intended it. It waits for a wake up report, sends the configuration changes, and then sends a wakeUpNoMoreInformation to tell the device to go back to sleep. If there are no changes to be made to the device, it immediately tells it to go back to sleep. This is optimal for battery life.

With this device you can either a) wait for the device changes to sync when the device wakes up on its own. It might not be optimal as the wake up interval is 24 hours. (although this is often optimal for motion or contact sensors that you have a lot of and might be in hard to reach places). Or b) you can manually “wake” the device up. Every Z-Wave sleepy device should have a way to do this. This one, if you hold the button down for a few seconds, will wake up (as I and others have mentioned above).

During this process you do not have to hit done on the preferences page or the sync button or do anything. The Wallmote will send a wake report to the controller and it will send the configuration changes. If you want to see what it is doing, you can watch in the logs with debug enabled.

I will make note of this in the first post and put it in the handler. It is something that has been in my handlers for so long I guess I just forget that everyone doesn’t know how it works.


(Rob) #52

Great explanation! That helps a lot. Is there any reason why the color change doesn’t work?

Rob


(Eric M) #53

Maybe the config parameter isn’t taking? Take the remote close to the hub and then hold down the button on the back. Also, check the logs when you do it.

I am able to change color: