[RELEASE] Aeon Multisensor 6 (Advanced)

dth_sensors

(Michael Langkilde) #141

I got sick of buying the batteries so I finally added USB power. Saves me having to buy the batteries every 6 months give or take a month.


#142

I also have a problem with this too. Brand new. Not sure if it is a hardware issue or a software issue. Not able to anything on the motion side. It is not reporting any movement in the samsung smartthings app. However the green light does come on when I step in front of it. Also the configured triggers (lights on) not working.
I wonder how to diagnose the problem.
Thanks.


(Eric M) #143

You have probably already checked, but I’ve got to make sure. Change the motion sensitivity to 5 in the preferences and make sure they update. If the sensitivity is 0 then motion detection is off. Also, you can enable debug logging and watch the logs when the light flashes from motion to see if any reports come in.


#144

It is set to 5. Everything else is being reported under “recently” - illuminance, humidty, temperature.
The motion sensor worked like 2 times. Then it doesn’t work anymore.
I am not sure what I need to do to reset the whole thing.


#145

Hi, I have a problem that my sensors just stopped updating illuminance, the motion part works perfect, but a few days ago it started that it wont update illuminance / lux sensor.
Any idea what todo? Tried taking the batteries out then in. But Im not sure If I need to wait a while before adding the batteries again, a little worried it should reset the entire sensor si I need to readd and setup all my rules again.
Thanks, this device handler is amazing for battery usage compared to other device handlers ive tried, Thanks…


(Eric M) #146

You can reset the sensor by holding down the button on it for 20+ seconds. You might want to try that and then re-include it.

@Fredrik I haven’t seen this on my sensors. If you want to reset the sensor without having to set up all of your rules you can either 1) reset the MultiSensor 6 out of range of the hub. If you do it within range of the hub, it will actually send a report to the hub telling it that it has been reset and the device will be removed from your account (messing up your rules). 2) use another Z-Wave controller and just do a general device exclusion on it.

Then, go to the device in the SmartThings app and do a “Replace”. Before the replace, you may want to hit refresh and configure a few times and wait a few minutes. This can help the Z-Wave controller inside of the SmartThings hub see that the device is failed. During the “Replace” process you just include the sensor like it is new. It will pair with the hub with the same Z-Wave node number and all of your automations will stay in place.


#147

Actually i think the sensor is constantly seeing that there is motion. As I looked at your screen at the top of this thread. So essentially the blue icon is always on. So it triggers the rule one time.
I tried to set the sensitivity to 1 and also 0. But it has no effect.
Might consider returning this.


(Shumps) #148

I was experiencing similar symptoms to Fredrik and cedrictang while setting up two new sensors. Mine are running firmware 1.07, usb powered, PIR set to 10 and sensitivity to 5 to try and rule out conflicts. Specifically my motion detector stays in the state it was in upon first adding it to the system.

Hey @erocm1231, I believe I was able to capture a potentially related error to setting up one of the sensors as a secure device.

error groovy.lang.MissingMethodException: No signature of method: static physicalgraph.zwave.ZwaveUtils.uint24FromBytes() is applicable for argument types: (java.util.ArrayList$SubList, java.lang.Integer) values: [[0, 0, 240, 1, 2], 0]
Possible solutions: uint24FromBytes(java.util.ArrayList, int) @ line 191

I wasn’t able to duplicate the error while setting up normally however it still didn’t update the motion state. I have tried resetting the device and adding in secure and non-secure ways.

Let me know if you have other ideas or things to try.

Additional error when editing settings

error java.lang.IndexOutOfBoundsException: toIndex = 6 @ line 191


(Shumps) #149

Worked with Aeotec support with this issue and they determined it was a bad unit, Got the new one today and everything is working great. Thanks for this great device type!


(Simon) #150

I have had a strange experience the past couple of weeks.

I have these sensors in several rooms in my house, and have me working fine 99% of the time.
But the last couple of weeks I have tried walking in a room, and the light didn’t turn on as normal.
Then I would go into the next room and watch the sensor to see if the LED turns green = it senses motion. And no, nothing.

1 week ago I had a sensor not doing anything for 50 minutes. I tried coming back to the room watching the sensor for the green LED, and nothing. And then after 50 minutes after first incident, then it just works normal again.

So this behaviour I have seen several times now over the past 2-3 weeks on almost all sensors.
I feel the sensors take turns on “napping”.
I’m getting a bit paranoid :wink: because now I watch for the sensor every time I walk into a room, just to see if the LED turns green or not.

Anyone have experienced anything like this?


(Eric) #151

What does everyone suggest using to properly calibrate the Multi 6? I’d love to find an accurate device to true up temps, lux, humidity, etc.


#152

For humidity use the same method I use for my cigars-get an adjustable digital hygrometer-they’re cheap. Take a small cap from a prescription vial or similar and fill it with salt. Moisten the salt until damp, but not watery. Place the hygrometer and cap in an airtight baggy for 8 hours. This will achieve humidity of 75%. Adjust the hygrometer as needed and your set.


(Nigel Williams) #153

Eric

Thanks for this great code.
Right now I am using this excellent device to measure the illuminance level.
Is there a way to change the default viewed attribute from temperature to illuminance?
Is this something that could be configurable moving forward?


(Eric M) #154

Do you mean on the main tile? You can probably accomplish this by editing the code, but there isn’t a way to have it be an option. Right now device handler layouts are not dynamic. SmartThings used to let you choose which measurement was displayed in the main device list, but that was in their version 1 app.


(Sean Hennessy) #155

Hi all. Great code and great effort by Eric and community. My LuX levels don’t reach above 12 in a well lit room. Is this normal or should I be editing thresholds etc?


(Daniel Ionescu) #156

@sahennessy
the SI unit of illuminance, equal to one lumen per square meter. So it depends of sensor size.
Measurement also depends of orientation. What do you get when you aim sensor to the light?


(Eric M) #157

Also, make sure your reporting interval is set so that you aren’t checking for an update before the interval is met. Oh, and if you have thresholds enabled, make sure those are set optimally as well.


(Uriel A Colon) #158

Hello erocm123,
First much thanks for the work you put into this device type for the Aeon Multisensor 6.

If i may …I would like to ask if there is another setting/command available for the LED.

I know the parameter 81 (1 byte) 0/1 value sets the led off for motion.
Ive checked the parameter 81 and have set it manually in IDE as well

What i am experiencing is that the LED will light up randomly throughout the night.

Any thoughts ideas on this appreciated


(Eric M) #159

It has been a while that I have done some tests, but are you saying that the light does not turn on for motion, but still randomly turns on for some reason? I think I found this as well.


(Uriel A Colon) #160

Hello Eric.

Yes. This is exactly the case.