SmartThings Community

[RELEASE] Aeon Multisensor 6 (Advanced)

dth_sensors
(RT) #384

Hi Eric and all,

I’m having a problem with the Aeon Multisensor 6 where it is taking one hour to report changes like humidity and temperature, even though I have it set to 300 seconds (5 minutes). This is a new sensor I recently bought that has firmware v1.12. My region is the US. It has DTH 7/20/18 running: EDIT - Not sure this is the latest - see note at bottom.

When I look at the “Recently” events it shows updated temp and humidity at 1:59 AM today, 2:59 AM, 3:59, and every hour x:59. It had been working fine until I decided to change the reporting interval to 1800 (which is still every half-hour, not every hour) as a test. But then after changing it back it stays at every hour.

This is creating a big problem for me, since I need much more frequent reporting intervals (every 5 minutes) to properly control a dehumidifier (I use this sensor as my humidistat).

Here are my settings:

Battery
Selective Reporting: NO
Temp thres: 20
Humidity thres: 10
Lumin thres: 100
Battery thres: 10
Ultrav thres: 2
PIR reset time: 256
PIR motion sensitivity: 0
Reporting interval: 300
Temp offset: 0
Humidity offset: -1
Lum offset: [not set]
Command set: Basic Set
LED Options: Fully Disabled
Stay Awake Time: 30
Region Override: Off
Enable Debug Logging: ON

Here are the Preferences settings inside the Device data within the SmartThings IDE:

Name Type Value
paragraph
101 enum 241
111 number 300
201 decimal 0
202 number -1
203 number
204 number
3 number 256
4 number 0
40 enum 0
41 number 20
42 number 10
43 number 100
44 number 10
45 number 2
5 enum 1
8 number 30
81 enum 2
enableDebugging boolean true
regionOverride enum 0

From what I understand, since I have Selective Reporting off, and Reporting Interval at 300, this should reporting at least the latest humidity and temperature every 300 seconds, yes?

Is it possible that despite these settings, the sensor itself has not seen these settings/configuration and is using something else? First I tried making the changes in the SmartThings app to the device using the Gear icon, changing the values to the above, and then pressing Save. Then I tried doing things like pressing the “rewind” arrow on the device’s “tile” (that the DTH displays) in the app. Then I also tried pushing the Config tile in the app. Then I also tried pushing the button (press down for a single click and let go, light turns green for a little bit) on the back of the sensor to wake it up, then make the changes and hit save. I also tried pushing the “rewind” and Config options on the tile after I woke it up.

What’s the proper approach here to force the sensor to reload it’s config. Should any/all/some of the above already have forced it to reload it’s config? Maybe I’m not doing something right here. Is there something else I should try? There is the Stay Awake time which looks like it can be helpful, but the help for this parameter says it only works with firmware v1.08, unless this should say v1.08 and higher?

It’s been 8 hours (or maybe as much as 12 or 16 hours, can’t recall what time yesterday I made the changes) and it still has not taken affect. The docs here say if you want the change to take affect immediately just press the button on the back of the sensor, but as you can see from my notes above, I did try that. After I press the button it did send/update the latest time/temp, but then it still waits a hour before sending the next updates each time. Before I changed the settings yesterday from 300 to 1800 it was working just fine. Now I can’t get it back to that state.

How can I troubleshoot this further and what else can I try please?

EDIT: After reading through all these posts I see you said you published a few updates a few months ago. However the Github shows: 2018-07-20 5:26 PM. So I’m confused what version I actually have as the source does not have version numbers in it. Which is the latest?

EDIT 2: I then though I came across an update from 2018-08-20 somewhere but get all sorts of errors when I hit Save. I use Raw from the github. Copy/paste it into the DTH code window replacing everything that was there. When I hit save I get a red background in the code window and dozes of errors like these:
org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed:
script_dth_metadata_41995063_86e6_4552_a60d_4572374ec8b1: 209: unable to resolve class hubitat.zwave.commands.securityv1.SecurityMessageEncapsulation
@ line 209, column 16.
def zwaveEvent(hubitat.zwave.commands.securityv1.SecurityMessageEncapsulation cmd) {
^

script_dth_metadata_41995063_86e6_4552_a60d_4572374ec8b1: 220: unable to resolve class hubitat.zwave.commands.securityv1.SecurityCommandsSupportedReport 
@ line 220, column 16.
def zwaveEvent(hubitat.zwave.commands.securityv1.SecurityCommandsSupportedReport cmd) {
^

script_dth_metadata_41995063_86e6_4552_a60d_4572374ec8b1: 224: unable to resolve class hubitat.zwave.commands.configurationv2.ConfigurationReport 
@ line 224, column 16.
def zwaveEvent(hubitat.zwave.commands.configurationv2.ConfigurationReport cmd) {

With hindsight I think this 2018-08-20 code may have been from someone besides Eric so I am disregarding it for now and assuming 2018-07-20 is the latest.

Edit 3: In looking at the first post in this thread, my tiles look a little different than pictured there. Maybe that pic is outdated or my version is outdated. MY bottom middle tile says “Configure” and shows a wrench/screwdriver icon. Whereas in your picture it shows SYNCED. Although as mentioned in detail above, I’ve tried everything imaginable to get it to sync so I am not sure if it really is not sycned or it is but the tile does show as such.

Edit 4: Just as a test I switched the Aeon Multisensor 6 over to USB powered and even with it set to update once every 30 seconds it still is only updating once per hour. Is this DTH tested with firmware 1.12? I’m not sure how new it is and whether that is the issue?

Edit 5: I have an older Aeon Multisensor 6 here that I was trying to replace with this new one (my older one has a bad battery terminal so I can only use one battery). I just re-added the older one back into ST and its updating every 5 minutes, no problem. The main difference I can think of is that this older one is running firmware 1.10. In an earlier post I think Eric said something about how the reporting times sometimes require a change in the DTH after a firmware update so maybe that is the root cause here? I think I’m (finally) out of things to try!

Edit 7: Another indication that somehow the settings are not “sticking” or getting to the sensor is that I also have PIR Motion Sensitivity at 0 to disable it, but it keeps reporting motion every time I walk by it. Whereas my older sensor (with the 1.10 fw) with this same setting does not report any motion at all, as expected.

Edit 8: I excluded the new sensor from ST, did a factory reset on it, set it up all over again and still have the same exact issue. Documentation says I can configure it with USB power easier, so I tried that. It seems to accept the 300 reporting interval but still only sends the temp and humidity once an hour:

[3d9f915a-def5-409f-xx](https://graph.api.smartthings.com/ide/logs#3d9f915a-def5-409f-xx) 9:24:37 PM: debug No commands to send

[3d9f915a-def5-409f-xx](https://graph.api.smartthings.com/ide/logs#3d9f915a-def5-409f-xx) 9:24:37 PM: debug Device Aeon MultiSensor 6 New2 woke up

[3d9f915a-def5-409f-xx](https://graph.api.smartthings.com/ide/logs#3d9f915a-def5-409f-xx) 9:20:07 PM: debug NotificationReport: NotificationReport(eventParametersLength: 0, eventParameter: [], zensorNetSourceNodeId: 0, v1AlarmType: 0, reserved61: 0, notificationStatus: 255, sequence: false, event: 0, notificationType: 7, v1AlarmLevel: 0)

[3d9f915a-def5-409f-xx](https://graph.api.smartthings.com/ide/logs#3d9f915a-def5-409f-xx) 9:20:07 PM: debug BasicSet: BasicSet(value: 0)

[3d9f915a-def5-409f-xx](https://graph.api.smartthings.com/ide/logs#3d9f915a-def5-409f-xx) 9:19:37 PM: debug No commands to send

[3d9f915a-def5-409f-xx](https://graph.api.smartthings.com/ide/logs#3d9f915a-def5-409f-xx) 9:19:37 PM: debug Device Aeon MultiSensor 6 New2 woke up

[3d9f915a-def5-409f-xx](https://graph.api.smartthings.com/ide/logs#3d9f915a-def5-409f-xx) 9:14:39 PM: debug WakeUpIntervalReport WakeUpIntervalReport(seconds: 300, nodeid: 1)

[3d9f915a-def5-409f-xx](https://graph.api.smartthings.com/ide/logs#3d9f915a-def5-409f-xx) 9:14:37 PM: debug VersionReport(applicationVersion: 1, zWaveLibraryType: 3, applicationSubVersion: 12, zWaveProtocolSubVersion: 54, zWaveProtocolVersion: 4)

[3d9f915a-def5-409f-xx](https://graph.api.smartthings.com/ide/logs#3d9f915a-def5-409f-xx) 9:14:36 PM: debug Setting Wake Interval to 300

So is IS waking up every 5 minutes, however it is not reporting the latest temperature and humidity, which most certainly is changing, at least by a fraction. And as a reminder, Selective Reporting is set to Disabled so I am expecting these updates.

Thank you!!

0 Likes

(Daniel Ionescu) #385

Are you sure it’s 1.12? Website only mentions 1.10 for US and 1.11 for EU.
If you have a z-stick you can flash the sensor with firmware 1.10.
Alternative would be to return it and purchase a new one.

0 Likes

(RT) #386

Yep. 100% certain it is firmware 1.12. Since it sounds like it is brand new, I’m now starting to think it may require an update to the DTH to handle that properly? As mentioned in my crazy-long post, I think I saw Eric note at one point that with newer firmware sometimes the reporting interval code needs updating.

This is a cut/paste from the SmartThings IDE under this device in the Data section: firmware: 1.12

Also in the bottom right corner tile in the ST app when viewing the device it says “Firmware 1.12…”

Lastly, as noted in my initial report, the PIR Sensitivity of 0 is still reporting Motion events, unlike my older sensor on fw 1.10.

I just received this new sensor from Amazon a couple days ago. If I return it and get another it’s likely to be the same. Could it be that an update to the DTH is needed?

BTW I am seeing “Device Aeon MultiSensor 6 New2 woke up” events every 5 minutes. So it is waking up as it should, but its not sending the temp, humidity, or any other readings when it does wake up (either that or it is sending them and the DTH is not processing/receiving them).

Thanks guys!!

0 Likes

#387

At least one post on the Vera forums mentions Aeotec sending a customer 1.12 firmware…back in December. However, @NomadTech is right. The Aeotec firmware webpage still lists 1.10/1.11 as the latest.

0 Likes

(RT) #388

Well maybe their web page hasn’t been updated yet to post/list this new firmware, because the SmartThings IDE and this DTH clearly are reporting this firmware version as 1.12. And for clarity, this is not something Aeotec sent me on their own. Rather this is the firmware that came on a sensor I just bought from Amazon last week which arrived a couple days ago.

At any rate, does it sound like the issue could be specific to this firmware? Is Eric still readily maintaining this DTH and I wonder what type of fixes it requires. Thanks!

image

0 Likes

(Alwas) #389

Does it not work with the official DTH either?

0 Likes

(RT) #390

Great question. Of course the default is so limited I’d want to use Eric’s, but that would be a good test. Which DTH is the default one for the device? I can’t tell and when I add the device it automatically selects this DTH (Eric’s).

0 Likes

(Alwas) #391

It’s at the top of the drop down list under Aeon… Give it a try. Then you’ll see “Local” displayed.

0 Likes

(Daniel Ionescu) #392

Go IDE and edit properties of the device. There is a drop down selection box (alphabetically sorted) for DTH. You’ll see Aeon Multisensor 6 listed twice. At the top is default one, at the bottom of the list is Eric’s with all other custom DTHs.
Change it to default and see what happens. Then you can change back. Same procedure.
As I said, with a z-wave stick you can flash the 1.10 firmware. I have 3 of these sensors (not happy with them) and I did it for all.

0 Likes

(Daniel Ionescu) #393

Tagging @erocm1231

0 Likes

(RT) #394
  1. I switched to the default DTH (and indeed it now says local) and now the new sensor with firmware 1.12 is working perfectly! So this apparently is an issue with Eric’s DTH.

  2. I love the idea of running this locally, so I’m glad you brought this up. One time I was out of town and my home internet went out and my humidity control system implemented using this sense, ST and webCore got majorly messed up and damaged equipment. So it would be great to run this locally. But since my custom humidity control system relies on webCore to run the dehumidifier switch on and off, would I still be stuck with the cloud. Or could webCore control that switch for an all-local solution? If so I may ditch the custom DTH and run locally. Big benefit there in this case. The default DTH only allows for 8 minutes as the shortest interval. But I assume I can easily edit the default DTH to change that to 5 minutes.

  3. Recall that I reported that setting PIR Motion Sensitivity to 0 with Eric’s DTH and this new sensor still results in motion events every time there is motion. But Eric’s DTH along with my old sensor (fw 1.10) does disable motion, and same with the default DTH and firmware 1.12. So the issue with Eric’s DTH and fw 1.12 seems to be more than just the reporting, but also affecting the ability to stop the motion events.

  4. I understand I can probably downgrade the fm and flash to fw 1.10. But I’d rather not do that without knowing what 1.12 does/improves, and figure Eric’s DTH will get updated to fix this anyway. Also once I downgrade I may not be able to get the 1.12 software should I need to reflash. So right now I am limping by wit my old sensor that only has one working battery terminate for the time being until hopefully this gets corrected. Happy to test whatever changes Eric can make.

Thanks guys. Looking forward to your feedback on where to go from here.

0 Likes

(Eric M) #395

Something may have changed with the newer firmware. I don’t have any 1.12 devices and haven’t heard anything about the differences. I’ll see if I can find out any information.

0 Likes

(RT) #396

Great thanks!

0 Likes

(RT) #397
  1. In the meantime guys I’m using the new sensor along with the default Aeon Multisensor 6 DTH, which has 8 minutes as the shortest reporting time. I tried to modify that default DTH to support 5 minutes, however it still only reports every 8 minutes. I changed this:

     input "reportInterval", "enum", title: "Sensors Report Interval",
     	options: ["5 minutes", "8 minutes", "15 minutes", "30 minutes", "1 hour", "6 hours", "12 hours", "18 hours", "24 hours"]
    

By just adding the 5 minutes option in there. So I get 5 Minutes as a choice in the ST app configuration which I set there and saved the settings, and woke up the Multisensor, but its been a couple of days and it’s still only reporting every 8 minutes. Is there something else I need to do that I missed?

  1. Also I am trying to adjust the humidity offset because it’s off by 3%. The default DTH does not have an option to set an offset, so I changed parameter 202 to -3. However the humidity % still shows without the adjustment. Any ideas here?

  2. How would I go about adjusting the temperature offset by -1? I don’t see a way to add the “201” setting/field, and don’t understand the docs about high/low byte.

Thanks!

0 Likes

(Daniel Ionescu) #398

Did you try in IDE?

0 Likes

(RT) #399

Yes. But the IDE does not have any parameter listed for 201. Only 202 and others. So I have no way to add this parameter in the first place. Also I don’t think it would work anyway - see where I reported above that setting 202 to -3 made no difference in the humidity reading (another mystery) so I don’t see how setting 201 to -1 (even if I can figure out how!) would help…

0 Likes

(Alwas) #400

@erocm1231 Something indeed has changed with v1.12. I hope you can get your hands on one or someone will send you one. Using your DTH I can’t change any of the parameters, everything stays as default/factory settings. i.e. motion timeout is 240 seconds. I just changed the DTH to Z-wave Tweaker and was able to change the motion timeout to 30 seconds, changing parameter 3 to 30, that sticks. Now I’ll have to do all the parameters manually with Z-Wave Tweaker.

0 Likes

(RT) #401

I’m trying to use a similar process to get mine with fw 1.12 to report every 5 minutes. I set the DTH to ZWave Tweaker, then used the gear icon and entered parameter 111 as 300. Then hit Save. Then woke up the sensor and hit sync title on Zwave Tweaker and then it turned Green and said Synced. Then switched back to the default Aeon Multisensor but it is still only reporting every 8 minutes instead of every 5 minutes, and switching back to Eric’s DTH it still only updates once per hour. Likewise I used ZWave Tweaker to set 202 to -5 to adjust the humidity offset but it has no affect and acts like it is set to 0. Is there something else/different I need to do?

0 Likes

(Alwas) #402

I’m having issues after changing to the official handler, ST I think have placed their own version over the top of Aeons parameters. I’ve had all sensor values changing immediately with the official ST one, then change something and lose previous settings!
If you google the official manual, at the bottom, there’s a pdf for advanced parameters, I’m using a manual for v1.08 maybe that’s the issue.
Edit, I appear to have got mine the way I want finally with the local DTH.
@HDGuy it needs to be plugged into USB for Z-Wave Tweaker to work. Then you’ll see the sync button turn green when it transfers the parameter.

0 Likes

(RT) #403

I thought you can also press the button on the Multisensor when on USB battery for it to accept the changes and sync? As noted above, at first after my changes Tweaker showed Yellow on the sync tile but after I pressed the button on the Multisensor it changed to Synced and was green with a check mark. Is that still not sufficient?

0 Likes