[RELEASE] Aeon Multisensor 6 (Advanced)

dth_sensors

(Eric M) #181

Should look like this:

@HDGuy I think that is a different handler than this one, but if it is similar you can try removing the icon in the main tile and that will make the text bigger. SmartThings doesn’t offer any control over font size, style, etc. You would need to remove , icon:“st.motion.motion.inactive” out of the main tile:

multiAttributeTile(name:"main", type:"generic", width:6, height:4) {
			tileAttribute("device.temperature", key: "PRIMARY_CONTROL") {
            	attributeState "temperature",label:'${currentValue}°', icon:"st.motion.motion.inactive", backgroundColors:[
                	[value: 31, color: "#153591"],
                    [value: 44, color: "#1e9cbb"],
                    [value: 59, color: "#90d2a7"],
					[value: 74, color: "#44b621"],
					[value: 84, color: "#f1d801"],
					[value: 95, color: "#d04e00"],
					[value: 96, color: "#bc2323"]
				]
            }

(Norm) #182

That worked. Thank you


(RT) #183

Thank you. However the DT I’m using already does not have an icon defined. Here’s the code block:

tiles (scale: 2) {
	multiAttributeTile(name:"main", type:"generic", width:6, height:4) {
		tileAttribute("device.temperature", key: "PRIMARY_CONTROL") {
        	attributeState "temperature",label:'${currentValue}°',backgroundColors:[
            	[value: 32, color: "#153591"],
                [value: 44, color: "#1e9cbb"],
                [value: 59, color: "#90d2a7"],
				[value: 74, color: "#44b621"],
				[value: 84, color: "#f1d801"],
				[value: 92, color: "#d04e00"],
				[value: 98, color: "#bc2323"]
			]       
        }
        tileAttribute("device.humidity", key: "SECONDARY_CONTROL") {
            attributeState "humidity",label:'RH ${currentValue}%',icon:" "
        }
	}
    standardTile("motion","device.motion", width: 2, height: 2) {
        	state "active",label:'motion',icon:"st.motion.motion.active",backgroundColor:"#53a7c0"
            state "inactive",label:'no motion',icon:"st.motion.motion.inactive",backgroundColor:"#ffffff"
		}
	valueTile("humidity","device.humidity", width: 2, height: 2) {
       	state "humidity",label:'RH ${currentValue}%',unit:"${unit}"
		}
	valueTile("illuminance","device.illuminance", width: 2, height: 2) {
        	state "luminosity",label:'${currentValue}', unit:"${unit}", backgroundColors:[
            	[value: 0, color: "#000000"],
                [value: 1, color: "#060053"],
                [value: 3, color: "#3E3900"],
                [value: 12, color: "#8E8400"],
				[value: 24, color: "#C5C08B"],
				[value: 36, color: "#DAD7B6"],
				[value: 128, color: "#F3F2E9"],
                [value: 1000, color: "#FFFFFF"]
			]
		}
	valueTile("ultravioletIndex","device.ultravioletIndex", width: 2, height: 2) {
			state "ultravioletIndex",label:'${currentValue} UV INDEX',unit:""
		}
	standardTile("acceleration", "device.acceleration", width: 2, height: 2) {
		state("active", label:'tamper', icon:"st.motion.acceleration.active", backgroundColor:"#ff0000")
		state("inactive", label:'clear', icon:"st.motion.acceleration.inactive", backgroundColor:"#00ff00")
	}
	valueTile("battery", "device.battery", decoration: "flat", width: 2, height: 2) {
		state "battery", label:'${currentValue}% battery', unit:""
	}
	standardTile("configure","device.configure", decoration: "flat", width: 2, height: 2) {
		state "configure", label:'config', action:"configure", icon:"st.secondary.tools"
	}
	main(["main"])
	details(["main","humidity","illuminance","ultravioletIndex","motion","acceleration","battery","configure"])
}
  1. Is there any tweak you can suggest to make the font of the temperature larger? Please see attached screen pic - that’s how it looks. It looks larger here but on an iPhone it’s pretty small.

  2. While we’re on the subject, is there any way to make the relative humidity text larger as well?

  3. I am thinking of trying this advanced DT instead of the RV2.2 I’m using. However it’s important to me to have updates at least once every 5 minutes, possibly sooner. Will this advanced DT still enable that or is it less frequent updates to conserve battery? Assuming the update frequency is short enough, I suppose I can always just add this DT and change the device to use it, and then simply change the device back to the old one if it doesn’t work as I need? IOW I’m not risking being able to easily go backward?

Thank you!


(Eric M) #184

If that didn’t work, then I don’t know what to tell you. Like I said, SmartThings currently does not have any way of adjusting font sizes in their platform. They will need to change the app back to the way it was or provide a way to do that.

My device handler lets you set the reporting interval to the 4 min minimum. If you are happy with the other one though except for the font size, then there is no need to change (since the font size will be the same on mine).


(RT) #185

Thanks Eric. If I need it to report temp and humidity every 5 minutes, and don’t want it to report (aka don’t care about) any of the other readings such as lux and motion, will your DT help save my battery? How do I make it not report that.
Would this also suppress the green motion light? I have an older firmware where disabling the light is not an option and I have no way of updating to the latest firmware since I don’t own their “stick”. To bad they don’t support that over USB… Currently it is reporting motion regularly in an active area. I really should disable that - perhaps that will help save the battery? I’ve been going through a CR123 about once every 4 months.


(RT) #186

I briefly tried your Advance DT and rolled back for the moment until I understand a few things better. In your Preferences you ask if the unit is battery or USB powered. How does your DT behavior differently and or use that information? For instance is it auto adjusting the temperature based on this, since it is known (I think) that the readings are a bit off when battery powered vs USB etc.

Also when I go to your Preferences, at the end of the list I also see these:

MotionReset number 1800
PIRsensitivity number 0
ReportingInterval number 300
debugOutput boolean false
humidityoffset number -5
luminanceoffset number 0
motionDelayTime 1800
motionSensitivity 1
reportInterval 241
tempoffset number 2
ultravioletoffset number 0

I think those are from the device itself or something, and these are also used by (or from?) my prior RV2.2 device type? When I switch to your DT would it use these as well and ignore yours or vice-versa? Should I do something to delete or reset these?

Thanks!


(RT) #187

Thanks. I switched to your DT and removed the icon. However removing the icon (two arrows) did not result in the temperature display being any larger. I understand this is out of your/our control. What’s the best way for me to report this to ST developers so they can look into improvements in this area?


(RT) #188

On your main tile I am trying to remove the " - LUX x - UV x" from the bottom of the tile, since I don’t care about those values at all and am a proponent of “less is more”. I made the following change to my local copy of your DT, saved it, and then published it (said Success). However when I refreshed and display the tile, it still shows those just like I didn’t make any changes. Confused.

  // ADDED
if(device.currentValue('humidity') != null)
    statusText = "RH ${device.currentValue('humidity')}%"

/*  REMOVED
if(device.currentValue('humidity') != null)
    statusText = "RH ${device.currentValue('humidity')}% - "
if(device.currentValue('illuminance') != null)
    statusText = statusText + "LUX ${device.currentValue('illuminance')} - "
if(device.currentValue('ultravioletIndex') != null)
    statusText = statusText + "UV ${device.currentValue('ultravioletIndex')} - "
*/


(Eric M) #189

Even with firmware 1.8, the LED occasionally blinks so it doesn’t completely take care of that issue. It isn’t when it detects motion though, perhaps it is at its wake-up period? I think Aeon is working on that for a later firmware release. The battery preference is just to determine whether to request battery reports from the device.

The variables that are left at the bottom of the preferences page are from the other device handler. you can get rid of them by deleting the values in the text fields and then hitting done.

Your code changes look fine except you either need to add back the " - " at the end or remove the line of code that trims that out (statusText = statusText.substring(0, statusText.length() - 2)). The method that updates the text you are concerned with runs at specific points in the code. Let some reports come in to see if it updates it.


(RT) #190

Thanks Eric. I corrected the issue with the statusMessage - it just needed some time to refresh like you said. I cleaned up the other device handler properties as well. Things are working great.

Too bad there is not a way to update the firmware without buying another device to do so.

I have PIR reset set to 256, which from the text description I think means 4.26 hours. I have PIR motion sensitivity set to 0, and its been that way (and not orange “dot” on the Config tile) for over 4 hours. Yet it shows there is Motion. Any idea why that would be? I would think that with it disabled it would not show motion under any circumstances?

I have reporting interval at 300 seconds and Enable Selective Reporting at “No” because I want to get every fractional change in temperature reported, and each single digit change in humidity reported. I do not care at all about UV or Lumanince. Would it still make sense in my scenario to use Enable Selective Reporting at Yes to help save battery or it wouldn’t matter if I’m getting every fractional change every 5 minutes on the temperature?

If you thought it would help a lot with battery life I could settle on temp changes with each single degree (instead of fraction of degree) and each single digit of humidity changed. Would that make a difference? It seems the temp or humidity is going to fluctuate at least one unit each every 5 minutes so probably wouldn’t save me much.

Just an idea - have you thought of keeping and exposing a counter that shows how many updates (since last “reset”) the device has reported? That could be real useful for evaluating whether certain config changes with intervals were worthwhile, like the scenario I mentioned above.

Also I recall reading there is a “last battery change date” setting somewhere, but don’t see it in the tile or app or device type preferences?

Thanks!


(Eric M) #191

Is it just stuck on motion because motion was disabled and it didn’t ever send an “inactive” event. Seems like the likely cause. As far as the threshold settings, it really depends on the environment. The fewer reports that get sent, the less battery is used. If you think using the thresholds will result in fewer reports, then you will likely save some battery life. I doubt it will make much of a difference as it probably won’t prevent that many reports.

The extra battery info is in the bottom right corner tile. It shows fine on Android, but is truncated on iOS it seems.


(Daniel Ionescu) #192

Indeed, “inactive” is not sent. Also, “Configure” button has no effect anymore. It happened to me yesterday and today. Reverting to ST standard device handler restores functionality. Reinstalling your DH after that maintains functionality.
I have 3 of them but this only happens if powered by battery.
I think it’s the firmware that’s screwed up as my battery started at 80% 2 weeks ago and now is 100%. UV also stays at 0. Sensor is outside but not under direct sunlight.


(Daniel Ionescu) #193

Is your sensor battery powered?
This has been happening to me on the only one that is battery powered of the 3 I have.


(Eric M) #194

I’ve pushed an update that allows you to push the tamper tile (the one in the middle) to clear the motion activity.


(www.smartukhome.co.uk) #195

I currently have 5 working sensors with your DH a for nearly a year and have purchased two more.

For the last 48 hours I havent been able to get either of the new ones to clear motion or tamper by themselves.
The only thing that’s different compared to the working ones is the new log parameter 9 is 2 bytes and is 246 or 256 I can’t remember.

I have removed them from ST for the moment ready to go back to Amazon if no one has any ideas on how to fix


(Eric M) #196

What firmware are they on?


(www.smartukhome.co.uk) #198

They were on 1.07 I sent them back to amazon and got two new ones which turned up yesterday and they came with 1.08 :open_mouth:. Didn’t think 1.08 was officially released. I have report internal set to 15 minutes so I shouldn’t have any problems, correct?


(Eric M) #199

1.08 has been a little buggy for me on some sensors and some have worked fine. I don’t think I had any problems when they were battery powered, but it has been so long since I looked into it. The LED will occasionally light up even when it is disabled with 1.08, but I heard they are working on that.

So I take it the other problem you were having has been fixed?


(www.smartukhome.co.uk) #200

The two I had problems with were used from amazon warehouse trying to save some money never again. Sent them back got two new ones which worked fine


(MH) #201

I’d like to just confirm how the battery reporting works. I have settings: battery and selective reporting enabled.
Does the battery reporting work in a similar way to Temp?
That being a drop of the threshold figure within the report time?

I have battery threshold set to 5%. For a report to be sent, does the battery have to loose more then 5% within the report time ( an hour in this case)?
Or will it report at 100, 95, 90, 85, ect …

MH