[RELEASE] Aeon Multisensor 6 (Advanced)

Thanks Eric I thought I had the right Handler but I guess I don’t I’m not really sure how I understand how to read the Raw description maybe you could tell me what the model is?

zw:S type:2001 mfr:014F prod:2002 model:0203 ver:4.84 zwv:3.67 lib:06 cc:71,85,80,72,30,86,31,70,84

Isn’t there manufacturer information on the device itself? Maybe a model number on a label or something?

Looking at picking up one of these units to use specifically for motion and lux detection. I’ll be buying it new from Amazon so can’t predict the firmware version yet. This device type looks great! Just a couple questions.

I see in the first post this note: “Note: 1.08 currently has a bug in the firmware that makes it so you can’t get sensor reports in intervals smaller than 30 minutes WHEN USB POWERED”
^^ Is this still an issue or have we found a way to get shorter intervals while using USB power? (Don’t want to use battery power)

If the problem still exists, is there a way to downgrade the firmware back to 1.06/1.07?

The problem is there in 1.08, but it is kind of random on which device has the problem. I have seen some work and some that haven’t. Since Amazon has a decent return policy it wouldn’t hurt to try.

Yes, you can downgrade the firmware via OTA if you use the Aeon Z-Stick.

I just received 2 of these sensors from Amazon UK. They came with firmware v1.08, and for some reason, I am unable to update the parameters. Whichever parameters that I changed, the log only responded with the following:

491faa2f-3604-4a08-9f73-6a27303e1aa8 3:08:08 PM: debug Aeon Multisensor 6 (Advanced) parameter ‘9’ with a byte size of ‘2’ is set to '257’
491faa2f-3604-4a08-9f73-6a27303e1aa8 3:07:59 PM: debug Aeon Multisensor 6 (Advanced) parameter ‘9’ with a byte size of ‘2’ is set to ‘256’

Saw an earlier post about this parameter 9 but did not find any solution. Is my only option to return and have these 2 sensors replaced? Or there is a way to get the parameters updated to what I want? All I really want is to have the parameter 3 updated to a shorter interval to clear the motion. It is now stuck with 4 minutes. Any advice?

Thanks in advance.

Try using a tool called zwave tweaker .
You create a device gandler with it then assigne to the decice.

I haven’t tried this before. Will give this a try and see. Hopefully I can save the hassle of returning those sensors. Thanks. :slightly_smiling_face:

Hope it works for you.
I have had good out come manipulating other zwave devices with this tool.

You shouldn’t have to use Z-Wave tweaker with this handler unless you are trying to edit a parameter that isn’t one that I included. This handler works extremely well and is designed for you to be able to customize the device exactly how you want it…

Change the “PIR reset time” option in the preferences, hit done, and then press the button on the back of the sensor. Watch the logs after you press the button.

I did that many times. It worked on my first Multisensor 6, but not for my 2 new Multisensor 6. All I got on the log after doing that (updating the parameter in the preference and clicked “done” followed by a press on the button on the sensor to keep it awake) is the following two log entries:

The parameter was somehow not updated. That’s when I wonder if the 2 new sensors are defective.

I tried the tweaker yesterday, and I managed to update the parameters. The sensors seem to be working as desired now.

Thanks @erocm1231 and @uacolon for the advice.

I bought 3 OOMI Multisensors that appeared to be relabled Aeon Multisensor 6’s. In testing, I’m finding that they sort of work out of the box with this handler. Some big gaps like only updating if the refresh button is pressed. I tried to update one to f/w v1.08 with my Z-Stick but I get an error that this is an “invalid combination”. I have a message into OOMI support to see if I can get documentation on the command set to see what’s different. Would anybody be interested in helping me troubleshoot the handler to add support this device?

Interesting, let me know if you get the documentation. The command classes are probably the same, but maybe the config parameters have been changed.

1 Like

OOMI Multisensor documentation is available at http://tinyurl.com/y8mnr5ce . When compared to v1.07 f/w, parameters 8, 9, 48-64, 100, & 110 are omitted.

Ok, so they are mostly the same. From the docs it looks like it should work. I wonder if association group 1 didn’t get set when it was included. Can you try to exclude it and include it again?

Edit: Also, is selective reporting disabled and what is your reporting interval set to?

Selective reporting is disabled. Interval is set to 30 seconds. I usually power my multisensors by USB so I like a short interval.

I have excluded and included a number of times with the same result.

The OOMI support guy said parameter setting 252 [1 byte size] = 0 is set to 1 which disables the ability to edit internal settings. From the doc, it looks like the Multisensor 6 has the same default setting.

2 Questions Eric. I just bought a new Multi 6 which is on 1.08 and for the life of me I can’t edit the settings, I’m stuck with the defaults, the new parameter settings won’t take, I don’t see the little red dot. I’ve reset the device 3 times by holding down the button for 20 seconds and re-included it, but nothing gives, I’ve tried on batteries and USB. Any suggestions? My older fw multi’s are fine.
Also, on a side note, on the things screen, my 3 Multi 6’s have a blank tile, how can I change that?

It seems like you may just have a defective sensor. If possible, try replacing it and see if that makes a difference.

@BartschLabs I don’t know then. The symptoms make it seem like the association group isn’t set. In the update method of the handler we can try explicitly setting the association group, but that shouldn’t be necessary.

Alwas’ problem sounds reminiscent of my problem with the OOMI Multisensors. OOMI Support helped me fix it. We couldn’t figure out where in your DH to insert this line:

	//Disable Parameter setting Lock
	zwave.configurationV1.configurationSet(parameterNumber: 0xFC, size: 1, scaledConfigurationValue: 0),

so we inserted it into the Vandervoort DH, applied it to the device and now I can use your DH or the stock SmartThings Aeotec Multisensor 6 DH to control the OOMI Multisensor. If you could add that line into your code or suggest to me where to insert it, I could test it with an unconfigured OOMI Multisensor. Once successful, you could boast additional device functionality for your DH.

1 Like

@erocm1231 great DTH! Is there a way to have different reporting interval for the different parameters (temperature, humidity,etc). I’m using the temperature element as a remote sensor for my AC, and need the fast update (30s) but could use a different interval for the other element so not too jam the log. Thx.

Thank you for the work on this! I started out on the ‘official’ one, but the reporting want working for me, so after poking around and discovering yours, It’s Is working for me on V1.08. Motion didn’t work at first but I suspects it had to time out of the old period before the new setting would take effect.

Truth be told though, I’m a bit saddened that its taking Aeon almost a year to finalize v1.09…