[RELEASE] Aeon Multisensor 6 (Advanced)

Hey, Thanks for the reply.

I actually walked away from the kit and left it in an unoccupied room for 30 mins. When I went back in I got a motion alert. No idea exactly what the issue was but I am able to repeat this 3 times now so I am gonna go ahead and test some more. If I get an issue I will follow your advice.

Thanks Again.

I need some help on this. I have two of these sensors using this DTH. One I have had for a while and is using USB power and it is working just fine. The other I recently purchased and it is using batteries. I set it up, but it is only reporting motion. The other parameters never update. And it has bee more than 24 hours. Also, the “Configure” icon has the red dot, which means the parameters are not loading. What are the optimum setup that I can use?

any idea when V1.9 or what ever is out really want to disable the LED but 1.8 has too many other problems/bugs to make it worth it

Hi,

I’ve got about 8 of these aeon multisensors using this DH for sometime now. But recently 2 of these appear to have stopped updating in terms of the lux?
I ended up removing them from ST, removed the batteries, did a reset on the device by holding the button for 20 sec etc. Then re-registered them back into ST.

It took a good time for it to pickup all the sensors. The motion sensors work as before, but the other sensors don’t appear to update regularly? It’s been a whole night and the lux, humidity etc have unchanged?
It’s configured for selective reporting, normally expect changes to occur every 20mins.
I checked the ST IDE and nothing has updated, and the NeedUpdate flag is stuck on YES?

On the mobile app, I’ve tried hitting sync and refresh. Also tried pressing the sensor button to force the update. Never seems to work?

Any ideas what’s up with these 2 sensors???

I had exactly the same issue with a new Multisensor 6. I then used Robert Vandervoort’s DTH, then switched back to this DTH and it initialized and is working fine. It seems like something is not getting initialized properly using this DTH with a brand new Multisensor.

@hyeung @damohabir There is a platform issue that has been ongoing for a few days. It has broken many device handlers. SmartThings staff has acknowledged the issue, but no word on when a fix is incoming.

Hi Eric,

The remaining 6 aeon sensors I have are working fine from what can gather. History shows they are all updating fine?
So can’t quite understand? Wouldn’t these also start to fail?

The bug is making it so configuration changes won’t ever make it to the device (which is why “needUpdate” is not changing to NO). I’d at least wait until we can make sure that your configuration changes make it to the device before looking further.

@tmleafs I have heard that the engineers had put the Multisensor on the back burner while working on other products but within the last few weeks have started working on a newer firmware for it. I have no ETA though.

@hyeung SmartThings has fixed the response bug. Can you see if your device configuration got updated and see if reports are coming now? You should be able to tell if the orange dot is off of the config tile.

Hi Eric,

Yes the sensors are now updating as expected. Think I noticed things working again over the last few days now.

Thanks,
Hung

1 Like

Has anyone has issues with what seems like config settings not syncing? I set the until to send PIR changes for motion to 30 seconds and it still takes 3 minutes for it to post motion clear. Any ideas? Thanks.

Hi @erocm1231 first of all, what a device handler :slight_smile:
I have two of these, and one of them is very slow on reporting back inactive.
Both har exact same settings, and only difference i find is this.
zw:S type:2101 mfr:0086 prod:0002 model:0064 ver:1.07 zwv:4.05 lib:03 cc:5E,86,72,59,85,73,71,84,80,30,31,70,7A,5A role:06 ff:8C07 ui:8C07
zw:L type:2101 mfr:0086 prod:0002 model:0064 ver:1.07 zwv:4.05 lib:03 cc:5E,86,72,59,85,73,71,84,80,30,31,70,7A,5A role:06 ff:8C07 ui:8C07
zw:s battery and zw:l Listening
Both was paired with usb power, and both are set to USB.
The first on mentioned have a average of reporting back inactive at 742 seconds, and the second one 66 seconds
Even if it is registered as battery, it should not delay a report on inactive?

Does this device type work for the Aeon Multisensor Gen5 below?

The delayed sensor is joined securely and the other is not. It shouldn’t make a difference, but is just an observation. You can try to do a regular inclusion just to see if it makes a difference. Also, try changing the PIR time to something different to see if it changes the behavior. Change it to 60 seconds instead of 30.

With the variance in the delay it almost seems like the device is still detecting motion (as strange as that sounds).

@sapstar It does not support that sensor.

Hi guys - I have been using the device type “Aeon Multisensor 6 - RV 2.2” and its been good. However after the latest iOS app update to SmartThings the temperature displayed in the large tile for the app is in tiny font, whereas it used to be much larger. Is there a way to make it bigger?

Having trouble setting GitHub repository. What settings should I use for:
Owner:
Name:
Branch:

Thanes.

Should look like this:

@HDGuy I think that is a different handler than this one, but if it is similar you can try removing the icon in the main tile and that will make the text bigger. SmartThings doesn’t offer any control over font size, style, etc. You would need to remove , icon:“st.motion.motion.inactive” out of the main tile:

multiAttributeTile(name:"main", type:"generic", width:6, height:4) {
			tileAttribute("device.temperature", key: "PRIMARY_CONTROL") {
            	attributeState "temperature",label:'${currentValue}°', icon:"st.motion.motion.inactive", backgroundColors:[
                	[value: 31, color: "#153591"],
                    [value: 44, color: "#1e9cbb"],
                    [value: 59, color: "#90d2a7"],
					[value: 74, color: "#44b621"],
					[value: 84, color: "#f1d801"],
					[value: 95, color: "#d04e00"],
					[value: 96, color: "#bc2323"]
				]
            }

That worked. Thank you

Thank you. However the DT I’m using already does not have an icon defined. Here’s the code block:

tiles (scale: 2) {
	multiAttributeTile(name:"main", type:"generic", width:6, height:4) {
		tileAttribute("device.temperature", key: "PRIMARY_CONTROL") {
        	attributeState "temperature",label:'${currentValue}°',backgroundColors:[
            	[value: 32, color: "#153591"],
                [value: 44, color: "#1e9cbb"],
                [value: 59, color: "#90d2a7"],
				[value: 74, color: "#44b621"],
				[value: 84, color: "#f1d801"],
				[value: 92, color: "#d04e00"],
				[value: 98, color: "#bc2323"]
			]       
        }
        tileAttribute("device.humidity", key: "SECONDARY_CONTROL") {
            attributeState "humidity",label:'RH ${currentValue}%',icon:" "
        }
	}
    standardTile("motion","device.motion", width: 2, height: 2) {
        	state "active",label:'motion',icon:"st.motion.motion.active",backgroundColor:"#53a7c0"
            state "inactive",label:'no motion',icon:"st.motion.motion.inactive",backgroundColor:"#ffffff"
		}
	valueTile("humidity","device.humidity", width: 2, height: 2) {
       	state "humidity",label:'RH ${currentValue}%',unit:"${unit}"
		}
	valueTile("illuminance","device.illuminance", width: 2, height: 2) {
        	state "luminosity",label:'${currentValue}', unit:"${unit}", backgroundColors:[
            	[value: 0, color: "#000000"],
                [value: 1, color: "#060053"],
                [value: 3, color: "#3E3900"],
                [value: 12, color: "#8E8400"],
				[value: 24, color: "#C5C08B"],
				[value: 36, color: "#DAD7B6"],
				[value: 128, color: "#F3F2E9"],
                [value: 1000, color: "#FFFFFF"]
			]
		}
	valueTile("ultravioletIndex","device.ultravioletIndex", width: 2, height: 2) {
			state "ultravioletIndex",label:'${currentValue} UV INDEX',unit:""
		}
	standardTile("acceleration", "device.acceleration", width: 2, height: 2) {
		state("active", label:'tamper', icon:"st.motion.acceleration.active", backgroundColor:"#ff0000")
		state("inactive", label:'clear', icon:"st.motion.acceleration.inactive", backgroundColor:"#00ff00")
	}
	valueTile("battery", "device.battery", decoration: "flat", width: 2, height: 2) {
		state "battery", label:'${currentValue}% battery', unit:""
	}
	standardTile("configure","device.configure", decoration: "flat", width: 2, height: 2) {
		state "configure", label:'config', action:"configure", icon:"st.secondary.tools"
	}
	main(["main"])
	details(["main","humidity","illuminance","ultravioletIndex","motion","acceleration","battery","configure"])
}
  1. Is there any tweak you can suggest to make the font of the temperature larger? Please see attached screen pic - that’s how it looks. It looks larger here but on an iPhone it’s pretty small.

  2. While we’re on the subject, is there any way to make the relative humidity text larger as well?

  3. I am thinking of trying this advanced DT instead of the RV2.2 I’m using. However it’s important to me to have updates at least once every 5 minutes, possibly sooner. Will this advanced DT still enable that or is it less frequent updates to conserve battery? Assuming the update frequency is short enough, I suppose I can always just add this DT and change the device to use it, and then simply change the device back to the old one if it doesn’t work as I need? IOW I’m not risking being able to easily go backward?

Thank you!

If that didn’t work, then I don’t know what to tell you. Like I said, SmartThings currently does not have any way of adjusting font sizes in their platform. They will need to change the app back to the way it was or provide a way to do that.

My device handler lets you set the reporting interval to the 4 min minimum. If you are happy with the other one though except for the font size, then there is no need to change (since the font size will be the same on mine).