[RELEASE] Aeon Labs Multifunction Siren

Ran into a problem, if the alarm is off and I open the door the beeping starts. This shouldn’t happen in off position. checked all settings so it must have something to do with SA.

Nope, this is your Rule Machine rule.

Assuming that arming Smart Alarm either changes the mode or or the Smart Home Monitor state, you can add a condition to your Rule Machine so that it only starts beeping if the system is armed and the door is opened.

I will see what I can come up with.

Got it working with the hall light coming on when the system goes into alarm also.

Aeon Labs Multifunction Siren

The custom command feature no longer works with SHM or Speaker Notify with Sound because they broke the custom message functionality in those SmartApps.

You can still use the device as an alarm or switch in those SmartApps, but if you want to be able to use features like beep, you will need to use a community developed SmartApp like either Rule Machine or CoRE.

The developer of Rule Machine doesn’t allow new installs so unless you already had it installed, you will have to use CoRE instead.

Figures :disappointed:

But as you mentioned, should be doable in CoRE …

It looks like SmartThings fixed the TTS problem so you should be able to use the audio device, custom message feature in SHM and notify with sound to play mp3s by track number again.

Any one running more than on of these in their homes? Curious to see if there were any issues or difficulties with having more than a single unit.


I got three :neutral_face: No problems in operation finally, but they were a pita to get working correctly when I first paired them to my v2 hub. After a little experimentation, I found that for my setup, they had to be the last devices to be included in the mesh, after I did a z-wave network repair. So, if I need to add a new device, I have to first exclude them from the mesh, include the new device, do a z-wave repair, THEN include the sirens back into the network. That way they didn’t act as z-wave repeaters — which caused a ton of problems with my z-wave network, including the sirens not firing, firing hours later, etc.

They work fine with Kevin’s DTH, otherwise :grin:

Thnx for the heads-up.

Got the sirens working with CoRE for now, and they work just as well with CoRE as with the “Speaker Notify with Sound”.

I haven’t heard anyone else mention those types of problems, but I’m not sure how many people have more than one of them either.

Did you originally try it with the default Aeon Siren DTH? If so, did you have the same problems?

I tried every DTH I could find — same problem(s).

I forgot to mention I also have two sirens at another house, and they behaved the same way. I made sure they were the last devices added, and haven’t had a problem since.

I’m glad to hear it’s not a bug with my DTH and that you were able to find a workaround.

I don’t recall having problems with the other DTHs, but yours had all the bells and whistles that I needed (wanted) :grin:

If that’s the case, what did you mean when you said:

I had “problems” with all the DTHs initially, but it wasn’t the DTHs, it was really where/how the sirens were included in the z-wave mesh.

After I found a solution that works for including the sirens (without having all the siren misfires), I retried the other DTHs; they worked, but I wanted more options that your DTH offered :slight_smile:

I was able to add the device handler properly. My iOS app recognized the siren and allows me program it. Only problem, there is no sound coming from the siren. It works fine when I use the standard device handler for the siren but not this custom one.

Any tips on how I can troubleshoot? I am able to include the device in the Security app and it triggers correctly when I set off the motion sensor BUT there is no sound.

That’s the first time I’ve heard anyone say that it works using the original device handler, but doesn’t work with this one.

Open Live Logging through the IDE so you can see if it’s displaying any warnings.

When you switched back to this device handler after trying the default one, did you open the device settings through the IDE and save? If not, try that, but make sure you have live logging open when you do it because that’s most like when it would display the most useful messages for troubleshooting.

Yes. I did. Here is a screenshot.

That’s a screenshot of the My Device Handlers page…

Did you open Live Logging and see what gets logged when you open and save the settings from the Mobile App?