[RELEASE] Aeon Labs Multifunction Siren

Smart Alarm Beeping Entry/Exit

The example below uses Rule Machine to start beeping when the contact is opened, but you could do the same thing using Speaker Notify with Sound or a Custom Monitor in SHM.

Setup entry beep start in Rule Machine:

Define a Rule that uses your entry/exit contact sensor as the Condition.

For the Action, use “Send or speak a message” with the “Custom message to send” set to “3, 29, 3,1,1,0,100” (without the quotes), “Speak this message?” set to True, and “On this music device” set to your siren.

The Rule should look something like:


Setup everything else in Smart Alarm:

In the “Notification Options” section, use the settings shown below for the “Audio Notifications”:

1 Like

What is the 3, 29, 3,1,1,0,100" are they the settings in the device type?

You can find a description of all the custom commands this device handler supports in this post, but entering 7 numbers executes thee startCustomBeep command with the following parameters: beepEverySeconds, stopAfterSeconds, sound, volume, repeat, repeatDelayMilliseconds, beepLengthMillisecond.

The example above runs every 3 seconds for 29 seconds and uses sound 3 at volume 1 to beep once without a delay and the beep should be 100 milliseconds long.

Thanks, I will try that and see how it works out.

I’ve found using Speaker Notify with Sound to start the beeping when the contact is opened is a lot more reliable than Rule Machine, but that could just be because I ended up on a flaky version of RM.

The example I used performs 1 beep every 3 seconds, but you could also do something like 3 short beeps every 3 seconds like:

3, 29, 3, 1, 3, 20, 50

It didn’t work please check my settings.

The information I posted allows you to execute those commands without having to configure them in the device settings, but entering them into the settings like you did, will allow you to easily test the beep functionality.

What happens when you press the start beep button?

First here is my Rule using contact sensors. It beeps as it should but not when I open the door. The " before the numbers I changed to ’ as it put double quote. Still no beep on door opening.

The numbers should be entered without any quotes, but if you’re OK with configuring the beeping sound and frequency from the Device Preferences, you can use startBeep instead of entering the individual parameters that way I did in the screenshot.

That’s probably the way I should have originally suggested setting it up so when you configure Smart Alarm you should also use startBeep instead of those numbers.

OK but would you please look at the Aeon setup posted three post above and see if I have it correct? I was a little confused on that.

Also how would it be phrased ‘startBeep’ speak’ [Aeon Siren]

I originally checked and it looked OK and then I thought you said that when you press the start beep button in the mobile app, it beeps for 30 seconds like it’s supposed to so I thought you were all set with that part.

The original screen capture displayed the entire rule so it automatically displayed it as a full sentence. All you should be entering into the custom message field is startBeep so the “send or speak a message” action screen in Rule Machine should look like:

(The “At this volume” field is ignored so there’s no need to change it from it’s default value)

What about the text in Smart Alarm does that still get the numbers ‘3, 29, 3, 1, 3, 20, 50’ start’ Or is it just in the rule?

OK I left the numbers in Smart Alarm and on entry it worked. The light flashes and the alarm beeps. Now to figure out a way to have it beep on exit, Using the IRIS keypad. I am not sure if there is something in Rule Machine that can handle a keypad. As a device.

You might as well use startBeep, just like you did in Rule Machine.

If you followed the previous instructions, Rule Machine is causing it to beep on entry. The beeping on exit is what you’re configuring in Smart Alarm so make sure you’re filling in the Audio Notification section in Smart Alarm exactly as shown in the screenshot below. (Except instead of the numbers shown, use startBeep).

It works on entry but not on exit below is my Smart Alarm setup, when I use the keypad to start the 30 second countdown there is no beeps.
.

I think I figured it out I am testing now. I will let you know. OK I had to add startBeep to the Armed Stay Phrase also. Thanks for the help it works great now.

  1. On exit or stay it beeps then arms after 30 seconds and beep stops.
  2. On entry the siren beeps and my hall light flashes until I disarm from keypad or if not it goes into alarm mode and siren and strobe go off.

Now I have everything I need for my alarm to work like a real alarm, delays and warnings. Now if ST would add delays to SHM it would be a huge step forward.

The last field, “Disarmed Phrase” should also have the word off, but that wouldn’t prevent it from beeping during exit.

I’ve been basing my responses on the assumption that you were already using the keypad to set Smart Alarm to Away, Stay and Disarm.

If that assumption was correct, once everything is configured, it should work like this:

Exiting:

  • You change the status of Smart Alarm to Away.

  • That status change causes Smart Alarm to send the startBeep command to the siren.

  • It starts beeping and you have 30 seconds to leave without setting the alarm off. It stops beeping 30 seconds later.

Entering:

  • The door opens and your Rule Machine rule sends the startBeep command to the siren.

  • You have 30 seconds to change the status of Smart Alarm to disarmed or stay and it will beep during that time.

  • When the status changes, Smart Alarm sends the off command to the siren which stops the beeping.

  • If you don’t change the status of Smart Alarm within those 30 seconds, the both command gets sent to the siren which causes it to sound.

Exactly, but I also have my hall light flashing during entry to warn me and anyone breaking in that there is an alarm present. I guess I can remove the light flashing, but I will see how stable the rule machine is. Yes the Disarm phrase is off.Thanks again.

Out of curiosity if I add another Aeon Siren will it also work in the same manner as long as I use your device type? It would be great if ST accepts this device type so it will run locally as the original device type.

If you don’t want it to beep when Smart Alarm is set to Armed stay, change that phrase back to off instead of startBeep.

If you like it the way it is, just be aware that when the system is set to Armed Away and you enter, if you change it to Armed Stay instead of Disarmed, it will most likely beep for an additional 30 seconds.

It looks like Smart Alarm supports selecting multiple sirens so in theory, all you’d have to do is configure the device preferences the same as your current siren, select it from the “Which audio player?” field in Smart Alarm and include it in your existing Rule Machine action.

I also have a similar DH for the GoControl/Linear siren that supports using the strobe and siren independently. I haven’t added the beep scheduling functionality yet, but you could make the red strobe stay on for 30 seconds during entry/exit.

It beeps most of the time, but sometimes the alarm sounds for about 3 seconds instead of beeping which is why I haven’t added the beep scheduling feature yet. It’s a battery only device that has poor response times and no volume control so I’m not sure if I can make it any more reliable.