[RELEASE] Aeon Labs Multifunction Siren

So after my wife accidently triggered a stay alarm this morning, without the siren going off, I started testing it several times. The siren wouldnt trigger via smart alarm so I removed it from all smartapps and deleted it from the IDE. I started live logging and confirmed a secure pairing. In addition to the beep type, and number of beeps, volume is controlled now, but the beep length and time between still will not work. At least the siren went off when I triggered the alarm again. I’m bummed… I picked up a v2 hub while it was on sale. I guess I could bite the bullet and finally move all my devices over and see how it behaves. With my luck the siren isn’t a locally processed event on the v2 hub…

Sorry to hear that. I’ve only tested it on version 2 so I’m not sure if that could be causing the problems you’re seeing.

Just to clarify, those settings only affect the main beep button, they have no effect on buttons beep1 - beep6.

I believe the Aeon Siren will run locally if you’re using the SmartThings DTH with SHM, but no community Developed DTHs or SmartApps run locally…

Yes, to be honest beeps 1-6 really don’t sound different, maybe the number of beeps, otherwise they’re the same for me. Everything is like a 2 sec beep.

Unfortunately the Aeon Siren doesn’t support any type of beep feature.

All my device handler does is send the on and off commands and if the beep length is greater than 0, it uses that as the delay between them.

SmarThings can be a little flaky when it comes to millisecond delays which is why the beeps aren’t perfect, but if it’s staying on for 2 seconds while the beep length is set to 0 then there’s definitely something else going on.

I’m keeping my fingers crossed that updating to hub v2 will solve the problem, but if it doesn’t, I don’t think there’s anything else that can be done.

Just want to say thank you for this device handler. We have an old ADT setup that chimed when a door was opened. It was convenient except for the times my SIL was leaving for work at Zero Dark Thirty. I was able to get rid of the ADT stuff and, with CoRE’s help, set an exception for when my SIL usually leaves for work. I’m very happy with the functionality so far.

I will say that the lowest volume is still very loud and the family complained (compared to the ADT soft tones). So much that we’ve had to tuck it into a closet. Wish there was greater control of the volume, but we were able to figure out a solution.

Thanks again.

1 Like

If you’re looking for a solution with softer tones or chimes, take a look at this alternative option using an Android device and Bigtalker smart app.

I just ordered the Dome ZWave Siren which seems to have all the chime and siren related features built-in so they should be completely reliable. It’s arriving late this week so I’m hoping to have a device handler completed by Monday.

The only disadvantage I’m aware of so far is that it’s battery powered so it’s not a repeater. It’s also not a secure device, but based on everyone’s experience with the Aeon products, that’s not necessarily a bad thing.

This might be a viable alternative if you’re still looking for something for chimes and a siren.

I’m running the smart alarm smart app with an iris keypad and a thirty second delay. Is the only way to delay the siren with rule machine? Or there a delay option in the device config?

The device doesn’t have anything like that built in, but the device handler has a feature that allows you to do that.

Set the “Stop Scheduled Beep After” setting to however long you want the delay to be and then enable the “Play Beep Schedule Before Sounding Alarm” option.

If you don’t want it to beep during that delay, set the “Scheduled Beep Every” field to a few seconds less than the “Stop Scheduled Beep After” field.

FYI: Rule Machine’s no longer supported by the developer so you should really switch to CoRE.

So I had issues with the siren working out of the box and resolved with a remove/reset. I used your code and got the GUI/features in the app but no sound. I went back to square one but now cannot get the device handler installed again. Can you give me a simple step by step. I hate to make this request as I am pretty good at figuring stuff out but looks like I am stuck on this one. Thanks in advance :wink:

You shouldn’t have to install the device handler again unless you deleted it through the IDE. If you did, you can go to the page with the code, click the raw button, and then copy everything on that page. Then go into the “My Device Types” section of the IDE, create a new device type handler by pasting the code into the From Code tab, and then publish it.

If you already have the device type handler installed, then try to get the device within a few feet of the hub and press the action button at least twice during the pairing process.

Opening Live Logging in the IDE before trying to pair it might generate some log messages that will shed some light on why it’s not working.

If you haven’t removed this DTH, you could try removing it to see if it pairs and functions with the default DTH. If it works you should be able to switch it back to my DTH, open and save the settings screen in the Mobile App and see if it continues to work.

If you were having problems from the start, it could be a faulty unit which seems to be happening to a lot of users lately.

If you don’t care about its secure command and repeating functionality, you might be better off returning it and getting the Dome Siren. The biggest drawback is that it only runs on batteries.

I’ve created a device handler for it, but I haven’t had a chance to build any of the repeating beep functionality yet.

Sorry for the delay in getting back. So I started over and have the siren paired and it’s working fine with the original code. I went into My Device Handlers and created a New Device Handler with your code. It shows the code but I am still only getting the options from the original code.

Thanks again for the great support Kevin!

Did you click the “publish” button?

You then need to go to “My Devices”, click the device name, click edit, and select the “Aeon Labs Multifunction Siren” from the Type field.

It’s not alphabetical, it will be near the bottom of the list

It’s working now…outstanding support on your contribution!

1 Like

I did that, but didn’t see “Aeon Labs Multifunction Siren” in the type field list and I also looked at the bottom. I did publish. The SmartApp shows up on my Note 5 in MyApps, but when I look at the actual Aeon device in Things it says no Smart Aps installed. Any suggestions would be appreciated.

You’re looking at the device details screen on the website, not the mobile app, right?

This is a Device Type so it shouldn’t be listed in “MyApps” or shown on the screen that you’re currently seeing “No SmartApps installed”.

I just tested to make sure, and you get an error if you try to install it in the My SmartApp section instead of the My Device Handlers section so I have no idea how it could possibly be shown in “MyApps”.

Got it fixed. Thanks for your comment, that was what I was missing.

1 Like

Hello,

I am a newbie and trying to make it so that the ST motion sensor at my front door causes my Aeotec Gen 5 siren to beep 24/7.

or

When armed and away for the siren to function as a true siren and sound for two min.

I have published the device handler and associated it with the siren.

So far I am just trying to get it to beep like a door chime.

Under Automation I created a routine called door chime.
under what do you want to happen:
turn on these lights or switches: Aeon Siren
Automatically perform door chime when>something turns on or off>any of these switches> “which” does not list my front door motion sensor even though it is in my devices

What am I doing wrong?

I don’t believe you’ll be able to do this with Routines, but you can do it by setting up a custom monitor in Smart Home Monitor or use the SmartApp Speaker Notify with Sound.

With both of those SmartApps you can select the device as an audio device and then use the “Custom Message” option and type in beep for the message.

This will play the same sound as the device’s beep tile.

1 Like

HA! that worked using the SHM and custom sound “beep”

Now I am intrigued, how do I get it to play the other items like bell 1 & 2 or “someone is approaching” or “dogs barking” among just a few of the other cool sounds?

In custom message is “beep” the only thing you can put in there?