[RELEASE] ActionTiles, the homepage for your SmartThings home!

thanks. will do.

1 Like

Just would like to share action tiles works on echo show gen 1 using firefox

6 Likes

How did you get firefox on the echo show gen 1?

Just say Alexa open Firefox, there was a recent firmware update, when you ask for YouTube echo show will ask you which browser as default
http://www.aftvnews.com/amazon-echo-show-software-update-adds-web-browser-smart-home-dashboard-nbc-hulu-and-more/

Anybody know how to get arlo still images into actiontiles? I used Arlo pilot to give me the link but when I check it in the Web browser the only word on the page is “false”

After the latest update BUT the web session times out after about 10 mins and returns you to your screensaver/home. Did you manage to get around that at all ?

I am sorry I did not use it for more than 10 mins not sure if you can get around it the last thing I want to see is a screen burnt caused by AT on my show

Actually it auto closing would be nice, ask it to show Firefox and have your panel as the home page then it goes away would work for me. I’ll have to try that.

2 Likes

Hi, need some help. I am using iPhone. And I tried to embed the mjpeg or still jpg image. All I could get is blank. Please see photo. But, if I use the Mac Safari browser, I could see both MJPEG video stream or jpg still image. Ho can I get iPhone to display correctly? TIA

Never mind. I solved it. In Mac, I pre-authenticated, so that’s why it was working. On my iPhone, I forgot to input user and password in the URL. Sorry about that.

1 Like

No problem, Roger!

Would you please share some information here about what type of Camera you are using, and give an example of the working URL?

It’s HKVISION NVR with 8 cameras. I am pulling the picture or the video stream directly from NVR with unique TCP port for each camera attached. For example:

Still image:
http://user:password@x.x.x.x:65001/Streaming/channels/2/picture

Video Sub-stream MJPEG [Channel 2]:
http://user:password@x.x.x.x:65001/Streaming/channels/2/Preview

For MJPEG video stream, I have to pre-configured the resolution, bit rate, compression, and frame rate for each camera in order to not to overheat my iphone. Streaming 8 videos simultaneously would be little too much for mobile devices, I might just project 4 screens.

3 Likes

Thanks Roger!

For others reading this, please note that Google Chrome (and Chomium Android Webview used by Fully),
hard block embedding of URLs of the form “user:password@address”. They offer no way to override this.

  • You either have to manually authenticate in a different tab
  • Use a different browser (Firefox?)
  • or Transcode using tinyCam Pro App for Android, which allows parameters instead: ?user=x&pwd=y

Hi,

I’m getting inconsistent display for all 4 video streams on my iPhone. 95%, there would be at least 2 streams are greyed out. The result is very random. Sometimes, 3 are missing. I rarely could get all 4 display at the same time. On Mac, I could display all 4 any time. Is this a bug? Please see below 2 photos.

Unfortunately, this situation is not uncommon and is not a bug. We have no control over how each browser handles MJPEG streams. It is not an efficient format, so browsers / tablets themselves are doing the best they can.

It can help to lower the frame rate and resolution, if those parameters are available for you to configure.

Tagging @625alex in case he has other suggestions or diagnostic requests. We haven’t found a consistent enough pattern to be able to offer … consistent ideas.

Yes, I just noticed this really depends on the browser and platform. Now, I changed all of them to still image and refresh them every 1 second. Although, it’s not perfect and not very smooth, now I can get a quick glimpse of all 4 cameras. Still not bad.

1 Like

Now, I am seeing another problem. I am monitoring 6 thermometers, all of them don’t get updated for over 2 hours. So are my 2 Nest thermostats. 1 hour ago, I manually changed from heat to cool and set lower temp. But the panel has not yet reflected my manual changes on the Nest thermostats. I am still waiting for new readings as I am writing this post. I double checked SmartThings Classic app, and all the temp readings and Nest update are up to date. How does ActionTiles get updated? Doesn’t pull my hub data directly from Smartthing site? I tried to reload the panel multiple times. It doesn’t work still.

Please contact Support@ActionTiles.com and include your Location ID; this sort of thing is usually easily fixed. Also mention what type of Thermometers they are!

Hi,

Can I add wunderground PWS station ID as an tile? If yes, can you show me how?

Thanks

Hi,

Can I add wunderground PWS station ID as an tile? If yes, can you show me how?

Thanks