[RELEASE] ActionTiles, the homepage for your SmartThings home!

i understand and it is a good point but you can always add a disclaimer that fixes that issue. Road maps show constant progress and direction from a customer stand point and shows that they are working on things in a prioritize fashion. Increases trust and innovation in the future for the product. Will also limit and prevent the same request from being submitted. if people see it on the road map they will not ask again about a feature therefore reducing the support noise and letting them focus more on progress rather than constantly responding to the same request. just my thoughts, i have always seen this as a good thing rather then buying a product and not knowing if they are working on things in the future or just stopped development.

I totally understand that, but being on both sides of this fence as a customer and also a developer in another field, my experience with these generic roadmaps is that they are seen by a majority of people as an expectation, a guaranteed delivery, or a promise. It’s a slippery slope from the company standpoint. Take Samsung for example and their televisions that they were working on delivering with hub functionality. How many customers purchased tvs with the expectation of this and are still screaming about it in the community, because Samsung took a different course from what they initially stated about all televisions in 2017 having this functionality.

If you goto the forum, it’s got everything that’s currently open for discussion, planned, started, being voted on with all comments and replies. Yes, it’s a bit messy but if you list everything that is planned or started you can see the roadmap of things they are working on. It’s not the consolidated list you are looking for, but it’s there.

1 Like

Thanks for the feedback, Raymond (and thanks to our Devil’s Advocate @WB70 :smiling_imp: too!).

You make great points, but it really comes down to this:

Customers love product roadmaps: but Vendors don’t.

While we and most companies are “customer focused”, this is one area where businesses are punished if they try to accommodate. Unfortunately, the risks to the business outweigh the benefits by far.

SmartThings themselves used to telegraph quite a lot about their upcoming expected features… But they stopped that completely just a few months after Hub V2 & App V2 was released. I’ll leave it up to the reader to research the various expectations that were set in 2015, and customer reactions to them … and discover that SmartThings customers, on average, are actually much happier now with less information!

You’ll also notice that one of the most successful gadgets in the world never has its future features published until delivered: the Apple iPhone.


We emphasize that each customer should purchase an ActionTiles license based only upon what they experience during their free trial period(s) — not with any expectations of future features or even specific bug fixes. We want to delight you… Not disappoint you. :smile:

2 Likes

That holds true so long as the Apple Engineer’s daughter doesn’t record video of the phone and it’s features and posts it on Youtube before it’s official release. That’s a roadmap that gets you fired :grin:

1 Like

Today I learned ActionTiles uses Firebase…which is currently down? :slight_smile:
image

1 Like

Yup… Firebase owned by Google. I guess even that giant can’t quite handle Cyber Monday madness!? :shopping_cart:

Seems to have been repaired pretty quickly. Only experienced this 2 times before in this full year…

More details in post below:

1 Like

Today I added a couple of new Philips Hue bulbs. I am trying to authorize them in SmartThings so I can view them in ActionTiles, but it always hangs after I click “Authorize”. Any suggestions?

image

Someone else had an issue with Authorization the other day as well.

Do me a favor and try this. Instead of performing from the ActionTiles website, go into your ST Mobile app. Goto Automation / SmartApps / ActionTiles and try adding the devices from there. See if you have any issues.

2 Likes

Did that and it worked like a charm. I did not know that was even an option.

1 Like

Good deal. There have been a lot of issues reported around the url from the web (SmartThings shard) on how/where they are being redirected to. It’s not isolated to ActionTiles. I personally think this has something to do with the SmartThings / Samsung account restructuring / consolidation that is going on with Samsung.

As for the ActionTiles SmartApp, when you first logged in and authorized your Location, I believe it backfills this into SmartThings creating the SmartApp. At least that’s how I think it happens. Those guys can give you a more detailed and technical explanation.

Anyhow, glad the backdoor worked for you.

@tgauchat - just FYI - another authorization issue from the web, but works fine from within ST.

2 Likes

Infinite thanks to you WB, again, for helping out @damohabir!


Unfortunately, Authorizing Things from inside the SmartThings App / Automation / SmartApps/ “ActionTiles V6 (Connect)” is not available until after at least a basic initial connection & authorization has been successful via the web - because this step installs the SmartApp. In the cases we’ve seen recently with Samsung/SmartThings login errors (or whatever), that’s a big hurdle that first needs to be crossed.

Once that is successful, then, indeed, we ought to communicate to Customers the possible benefits of using the SmartApp Pages for subsequent additional Thing selection(s).


In the above scenario or similar, one possibly valuable diagnostic is to view the SmartThings IDE Live Logging (at https://account.SmartThings.com) while replicating the error. This should be done on a separate PC/Mac or at least an incognito mode, as the IDE login session will interfere with the Authorization login.

1 Like

@tgauchat, I am sure I will be adding more things over the holidays (just surpassed 100) so I will try that the next time and capture the live logging.

1 Like

I have 4 Fire 7, 2 Fire 8 and 1 Fire 10 Tablet. I have loaded Action Tiles and Fully Kiosk on several of them but the Lock Screen ruins the experience for me. Is there anyway around the Lock Screen?

I think it was one of the options in the fully settings menu. Whatever I selected keeps the fire from locking unless the Fully isn’t the “front” tab. IE if I ask Alexa something and don’t close it out, the screen will lock out after a certain time. But if I leave Fully up it doesn’t ever lock out.

Try this thread Amazon Fire & Fully discussion.

I am implementing this on a Fire 10 right now to see how well it works.

1 Like

Go into settings then About then click on the serial number field like 7 - 9 times until it unlocks developers mode. Once that happens you’ll have a new option like “Keep screen on” or “Prevent screen from locking” that will do what you want.

1 Like

I am trying to get this working on the FireTV Stick. Is this possible and if so how do you do it?

I am not sure this will work on a Fire TV Stick. I do not have one, but maybe someone else will chime in.

What have you tried so far?

Do you have a browser App?

Have you tried side loading the Firefox Browser onto your Firestick? I did a quick search and others have successfully done this. Others have tried getting Dolphin and Chrome to no avail. Here’s a video to get Firefox: