[RELEASE] Absolute Simplest ESP8266 Smart Blinds, no mqtt, rest, bridge, or broker, just your board and your hub

dth_requiresserver
blinds
dth_windows
dth_misc

(Benji) #62

Interesting! My blinds are about 35" wide with two extra wide ones at 72", all are 2" slats though so I’m hoping the servo you listed will work on the 72" wide ones…

I’ve got a couple of rooms that have multiple window blinds next to each other, to keep costs down and be as simple as possible, for those I’ll try and run extra servos from one NodeMCU. I assume with some changes to the code I could send commands to multiple digital outputs on the NodeMCU, alternatively I wonder if it’s possible to just splice multiple servos together since I don’t need individual control over each of those grouped windows.

I’ll definitely be doing this but right now I’ve got a few projects on the go that really need attention first.


(Greg) #63

OK think I’m getting somewhere, however now getting errors:

 ets Jan  8 2013,rst cause:2, boot mode:(1,6)
 ets Jan  8 2013,rst cause:4, boot mode:(1,6)
wdt reset

This could be something to do with powering the servo given its in port D4 for comms and then 3V3 & GND @C_Hobbs I see you have some kind of hackery going on with the USB cable to power it.

Any tips?


(LJ) #64

I have bought everything except the coupler : http://amzn.to/29BHEB0

I have trouble buying them and shipping them to Canada for a decent price. For example, on amazon, it will cost 35US for the shipping only.

Anyone can help me in finding something on ebay, from china, or any site in Canada? I don’t really know what to look for in the description.

Huge thanks,

LJ


#65

I’m splicing the servo’s 5v power and ground into middle of the the USB cable


(Greg) #66

Thats one way to do it! I’ll find an old USB cable and take a knife to it tomorrow!


(Greg) #67

I cant’ get this working at all.

I’ve got the power spliced from the USB, however I run into:

ets Jan 8 2013,rst cause:2, boot mode:(1,6)
ets Jan 8 2013,rst cause:4, boot mode:(1,6)
wdt reset

When uploading the code, the servo is going but I can’t seem to get much further


#68

Did a little reading into your two errors and:

The first, cause:2, appears to be caused by the reset pin and could indicate a power supply issue of incorrect voltage (5v dc) or not enough Amperage on the power supply…

The second, cause:4, is referred to as a “watchdog reset” usually occurring from a code or code syntax error. Also can be cause from a bad flash/upload of the code, or flashing/uploading with a serial speed set too fast and thus causing code corruption…

Hope this helps…
Source:
http://www.esp8266.com/viewtopic.php?p=2096#p2112


#69

thanks for this. being a new smartthings owner, this is the first thing I wanted to tackle. you’ve just made it easy.


#70

I want to set this up however i’m not so sure that my esp is actually operable - don’t own smartthings yet as i want to convince myself i can get the wifi board to work first. i’ve figured out uploading the code via arduino and after resetting the board, it’s visible in device manager under a random com port. when i try to use the terminal in arduino to send commands i get no response which has convinced me that there’s no communication. additionally, i can’t identify the esp in my router list of connected devices (i set the code for this properly).

is there a snippet of code i can add to your sketch that will allow 2-way communication via the arduino terminal window for test purposes?


(JBrown) #71

You could test your esp8266 with this http://www.blynk.cc/ it is fairly easy to setup.


(Brad) #72

I just wanted to say thank you for this! I programmed, fitted, and installed in an afternoon. And I have absolutely no experience with ESP8266, Arduino or anything like that. I used a battery pack like was suggested here and it seems to be working very well. I will have to figure out a better way to hide it but still have it accessible for charging. I also have a little tweaking to do on the range of movement. But anyway, very pleased with this project! Thanks again!


(David Augustine) #73

I have a similar project working with ESP8266, but I’m having trouble connecting it to smart things. How did you add the device? I can’t detect it.


(David Augustine) #74

lol nm, I RTFM, working great!


(David Augustine) #75

Working really well, I’ve hooked a LiPo battery to it, as well as a small solar panel that I’ve mounted outward facing on the window…testing to see whether it can generate enough juice to keep the battery charged.

One question… my Alexa only responds to “On/Off”, not “Open/Close”. Did you do something special to get her to respond to the more natural command?


#76

Hey @shareaproject glad you got your issue from this morning figured out! And I’m eagerly waiting to hear how the battery/solar implementation works out, a few have said they’re gonna try it but I haven’t seen any real-world results yet…

As for Alexa and her Open/Close commands, amazon actually revoked them from SmartThings around the first of July and reserved them for starting and stopping her built-in “apps”. For example, users to say “Alexa, open Jeopardy.” or “Alexa, close Jeopardy”

First close stopped working, then later open stopped also. You can read more about it here: Alexa doesn't understand "Open" Command all of a sudden

And I know and agree that it’s awkward and un-intuitive to say “Alexa, turn off the living room blinds.” and I would MUCH rather have home automation commands take preference over the sometimes useless “apps”, but for now at least, we can only use the commands they allow us to… =\


(David Augustine) #77

All good, just wanted to make sure I wasn’t missing something obvious. “On/Off” is fine if that’s all we have.

I installed the solar charging rig this morning, and now I’m just letting it run. I first built the whole thing with an arduino uno and a smarthings shield. Even with the solar panel charging and a 4400mAh LiPo battery, it only lasted 1.5 days. I’m hoping the ESP8266 rig will use less power and the panel will keep up. If not I’ll try a slightly larger panel before giving up. Right now I’m trying a 2W panel, but I’ll go as high as 3.4 Watt before giving up. Any bigger than that will block the window and defeat the purpose lol. I’ll update with results tomorrow or the next day.

One more question. I had an extra parts, and just for fun I built a second set of blinds…didn’t work even after following all the same steps. Just to be sure I tried a different ESP8266 and I’m getting the same results. I changed the static IP but nothing else. Any thoughts?

error, over and over again…

load 0x4010f000, len 1264, room 16
tail 0
chksum 0x0f
csum 0x0f
~ld


(JBrown) #78

What version is your esp8266? I had lot of issues with my V2, I think it it might be a wifi connection issue try using if closer to your router, I’ve had better luck with my esp8266 V3.


#79

That’s a very general and vauge watchdog error that the cause maybe one of a few things which I’ll list in order of probability:

  • Insufficient Amperage: Your power supply isn’t putting out enough Amperage. (I use a 5volt 2Amp “wall-wart” connected to the micro USB)

  • Voltage Fluctuation: Your voltage, either 5v through Micro USB or 3.3v on the power pins, is dipping below the 5v/3.3v respectively. (if you’re using 3.3v LiPo on the power pin I’d check it with a meter to ensure smooth voltage through the servo rotation, and if it is infact voltage sagging I would recommend adding a capacitor as close as possible in the line to the 3.3v power supply pin)

  • Bad Flash: Personally I always set Tools>Upload Speed to 115200 and Flash Size to 4M(3M SPIFFS).

  • And if all that doesn’t fix it, personally I’d re-copy the code to flash “fresh”, because believe it or not even something as simple as a trailing space after your WiFi’s network name or password can cause this!!!

Lastly, as a hail-mary you can add this code to your sketch to disable watchdog resets entirely, but I don’t know that I would recommend it as it still won’t fix a problem of insufficient amperage/voltage, and in the case of over voltage may even allow harm to your chip…

ets_intr_lock(15); // all intruptt off
ets_wdt_disable(); // disable watchdog

Oh and anecdotally I use 3 of these in my house, one on my living room blinds, one on bedroom blinds, and one with slightly modified code to open and close my garage door through a simple relay on the push button circuit!


(David Augustine) #80

That’s great info, thanks. Knowing it was power related made it pretty easy to solve. Turns out the poor quality usb cable I was using to write to/power the board was the culprit. Once I switched to a better quality cable, everything works great.

Also, update FYI…so far 12 hours and battery is holding.


(David Augustine) #81

Battery didn’t make it through the night. Fully charging from the wall one time to verify with a second test, and if it fails I’ll try a larger panel. I’ll update with results.