[RELEASE] 5-2 Day Programmable Thermostat Scheduler (Weekday, Weekend) with Remote Temperature Sensor for each Schedule

Yes that’s is correct and it’s normal operation when using a remote sensor to control the thermostat. If you see the posts above it explains why it’s designed this way. Your thermostat is working fine. Check your remote sensor settings in the app.
You can define a remote sensor globally for all schedules or you can specify remote sensor for specific schedules only. In that case only a schedules where the remote sensor is used will it use 90/50 settings for all other non remote sensor schedules it will show the thermostat settings.

Thanks for the reply.
I have had this working on my other thermostat for some time now, its a zwave therm.

The question was based on the new thermostat HONeywell TH9320WF5003.(AKA HON wifi 9000) . I dont see the 90/50 settings displayed on the termosta display so i am unsure if it is working or not, or if it is supported

Thanks again

Can you check your manual and let me know what maximum and minimum temperature settings allowed by the device?

Hello Rboy,

From the Installation manual specifications

HEAT 40F to 90F
Cool 50F to 99F

Right then it should work, can you send me the screenshots of the settings in the SmartApp (all pages) through a private message (PM). Lets figure out what’s different about your new thermostat, althought I suspect it’s just a settings issue.

Thanks Rboy,
I just pm you the screen shots…

Thanks again
For looking into this

1 Like

@RBoy - Is it at all possible for this app to be updated to allow you to use 2 different temp sensors to control the thermostat? I would like for it to look at 2 different sensors and if 1 requires heating/cooling it turns on the a/c or furnace. I’m sure it would play havoc with the auto mode on the thermostat, but maybe if you only could do it if you were set to either heating or cooling mode?

I’m having temp balance issues between my upstairs and downstairs. I have keen vents that get me most of the way there, but doing this might help get me where I want to be. Thanks.

You can currently select multiple remote temperature sensors, however it
uses the average of the sensors to make decisions.

If you have set your vents to be partially open so as to even the airflow
between the rooms i.e. The room coo and heat at the same rate then the
multiple sensors selection should work well.

In future we will add a feature to allow vent control and temperature
sensors to be linked.

Wow, I was waaay out of date on the app (last update 9-2-16). I guess that speaks for the stability :slight_smile: I updated and will give it a shot.

1 Like


I just installed and setup the premium version of this app yesterday. I am using a CT30 thermostat. It is recognized and has all the proper buttons from your device handler. When I set a temporary temperature from the thermostat, the schedule will not override that temporary setting. Is this expected behavior? Is there a way to have the schedule override the manual setting once a new phase kicks in? Thank you!

Yes that’s expected behavior, when you set a temp override on the thermostat the app won’t override that settings ONLY for the duration of the current schedule. When the next schedule kicks in it will override the settings. This is a temporary “hold”’ setting feature.

If the thermostat temperature doesn’t change at the next schedule your thermostat is having trouble communicating with the hub. FYI, the CT-30 has this issue as reported by other users, some reason it doesn’t affect the other CT-XX models, just the CT-30 seems to have an issue with communication. Try to hit the reset button on the CT-30 (top row next to the wires) and that often helps reset the comms with the hub.

Button picture:

1 Like

Thank you VERY much for the prompt response. I will reset the Thermostat when i get home. This might explain why my google home has problems issuing voice commands to it, stating the thermostat is offline when the “Thing” controls" have no issue sending commands to it.

By “override ONLY when the next schedule kicks in”, do you mean 1 of the 4 phases of the day? If so, thats what I was trying to say. I want it to stay at the manual temperature until the 6pm scheduled portion of the day happens.

Do you have a preferred Thermostat? If this one continues to have issues, I will return it and upgrade. This felt like a steal @ $30 but I guess I got what I paid for.

1 Like

Try to reboot the ST hub and do a Z-Wave network repair also that often helps as well. It’s a steal for sure, but it can be a hit or miss with that particular model :slight_smile:

1 Like

Hello Rboy,
Here is a feature request… if i may.

Some kind of resume schedule button/tile or maybe a pause/resume of the app.
For those days that you f find yourself working remote.

I understand the request, the issue in what you just pointed out, SmartApps don’t have interactive interfaces, you can only open them, configure and close them. Only devices have interactive options (tiles). Hence the constraint. There is one button available for Smartapp but then again it’s like a push button so no way for users to know the current state of the SmartApp. It’s typically used to refresh the SmartApp or reinitialize it.

The better way to do this would be to use the Modes features, the Smartapp can be configured to work only in specific modes, so when you’re remote you can change the mode of the house and the SmartApp will automatically pause. Easy!

Much thanks
Rboy completely forgot about that setting.

1 Like

Just one more follow-up before I return the CT-30. I installed the Device code and the smart app. I linked the thermostat to smartthings without issue. When looking at my list of things, it displays the temp but it is not in green like it used to be before the updated device code. Do once in the “thing”, i can change the temp and see the current temp using the thing buttons. It however still reports as offline to Google Home. It has rights to manage it and can see the dame of the thermostat, but cannot make changes to it. Thermostat also does not follow the schedule I created. I assigned this thermostat to this schedule after I unlinked the ZWAVE and reset the device using the reset button.

Any ideas? Should I just go pick up and Ecobee? Thanks!

ST has changed the color scheme, the new DTH’s now match the ST recommended color scheme which is mostly Blue and Gray

Don’t know, you’ll have to contact Google Home for that. If it’s showing up as offline in ST then it could be the new Device Health feature. It has some issues still being looked into by the ST staff. Once a device goes offline the only way to being it back online is to exclude it and repair it again. If it’s offline also report it to ST so they can track it.[quote=“rock99rock, post:179, topic:6780”]
cannot make changes to i

Again don’t know about Google Home, but if it’s due to the device heath offline issue I would suggest exclude and re pair it with the hub.

If the thermostat is having trouble communicating with the hub the schedules won’t work (obviously). Again see above if the device health issue is at play here then it could be fixed, if it’s a thermostat issue you should probably replace it, it could be just a bad piece.

1 Like

Thank you. The device itself shows as online; it was only Google Home that saw it as offline. Taking Google Home out of the equation and seeing the screenshot above (online, checking in, healthy), where else would I look to see if the thermostat is having issues communicating with the hub? The device auto sets the time and date after initial linking, and I can set the temps from things. Just the schedule will not work. Is there an error log for the schedule?

Thank you!

If there is a communication issue you won’t see an error, infact the opposite your Live Logging will show that the SmartApp is sending the command to set the temperature to the device (your device logging should also show it receiving the command from the SmartApp and possibly sending it to the device) but the device won’t respond. That’s how you can diagnose the comms issue. Never hurts to exclude the device, reboot the hub and repair it and if not try to have it exchanged.

1 Like