SmartThings Community

[RELEASE] 5-2 Day Programmable Thermostat Scheduler (Weekday, Weekend) with Remote Temperature Sensor for each Schedule

thermostat
climatecontrol
temperature
smartapp_hvac
rboyapps
(Head of Support (rboyapps.com)) #263

Hey there, to answer your questions:

  1. It shouldn’t make any difference
  2. Yes and unfortunately yes, it’s best to start clean
  3. The temporary hold feature when enabled stops the app for overriding the user defined temperature for a duration of the current schedule. What you’re looking for as I understand is a permanent hold, i.e. hold until I say resume. Here is how you can do this, open the app, unselect the thermostat for which you want a permanent hold and tap Save. We didn’t add a separate button for permanent hold due to limited screen space. This way it’s very flexible, you can still have some thermostats running on schedule while others are on permanent hold.
0 Likes

[RELEASE] Ultimate Mode Based Thermostat - Control Multiple Thermostats Temperature / Remote Temperature Sensors when Changing Modes
[RELEASE] Enhanced Z-Wave Plus Thermostat (CT-30/CT-50/CT-80/CT-100/CT-101/CT-110/ZTS-110/ZTS-500/GoControl/Honeywell/Universal) Device Handler with Battery, Humidity, Lock Controls, Clock Set, Alarm, Swing/Temp, Deadband Configuration and Updated UI
(ilker Aktuna) #264

@maddie , @RBoy
do you have plans to release thermostat scheduler for Hubitat Elevation hub ?

0 Likes

(ilker Aktuna) #265

I was mistaken. mine is a CT100 plus.
So it should be similar to yours but I can only change “sound” option in the settings menu.
And when I disable it, keytones are disabled. The other information tone continues.
any ideas ?
maybe I should hard reset it.

0 Likes

#266

I think CT100+ should be pretty close to CT101. I think the major difference between the two is that + is a zwave plus as oppose to zwave and 7 day programmable as oppose to 5-2. I have no sound from system at all even when I enable the “note” which I am fine with. Give it a shot with the hard reset I would say. What do you have to lose other than re-entering some setting. Iyi sanslar.

1 Like

(ilker Aktuna) #267

tried the hard reset. it actually solved the issue.
the disturbing beep was gone for about 10-12 hours.
but then my ISP had a cutout and ST hub went offline.
after it came back, the beep started again.
now I have to hard reset again I guess. It’s not so easy. Especially when I have about 8 smart apps connected to the device. I have to delete the device from each and then re-add.

0 Likes

(www.rboyapps.com - Make your home your butler!) #268

Try using the reset button. It doesn’t do a hard reset and tapping the refresh tile will resend all the settings back to it.

1 Like

#269

Just to get it right, are you hard resetting the hub or the CT100+ thermostat? You shouldn’t need to reset anything other than the thermostat and when you get your Internet access back everything should function as they did before. Am I missing something…

2 Likes

(ilker Aktuna) #270

ok. got it.
I had thought that after resetting the device I have to delete and add it to ST.

0 Likes

(Rusty Knabe) #271

RBoy, what’s up with the smart app version v03.09.04?
There seems to no longer be a way to change the temp without the scheduled temp overriding it within a minute or so. I have tried using the lock function, but nothing seems to make the manual temp setting actually last more than a minute.
Can we get a config to turn off this new behavior?

0 Likes

(www.rboyapps.com - Make your home your butler!) #272

Open the app and enable the option for Allow temporary hold if you want to manually override the thermostat set points.

0 Likes

(Rusty Knabe) #273

Thanks, that did the trick. No sure how I missed that one.

0 Likes

(Warren) #274

@RBoy To add to my RFE request, would the team be interested in implementing a pairing for thermostats and door/window sensors. I just installed the new Sinope TH1300B Smart Floor Heating Thermostat and it’s working great alongside the other thermostat in a different room. While I could have multiple instances of the app it would be so much more cleaner to have the ability to pair a open/close sensor with each thermostat instead of just having a pool.

Also, not to press my luck, just wondering about the RFE for seasonal hold. :grin:

0 Likes

(Ed) #275

I just subscribed for rboy lifetime license. However, I am having issues with any @RBoy thermostat smartapp with a nexia thermostat (@edk208). Not sure if it is the rboy smartapp but there seems to be a bug in the rboy smartapp because if I use the embedded smartthings smartapp like the ‘Keep me Comfortable’ it works great. It sets the Nexia thermostat to the desired temperature. The rboy thermostat smartapp sets the desired temp but puts it back right away for whatever reason. I can see in the thermostat how the temp was changed by the rboy app but then the temp is put back to default within a second. As I looked into the events of nexia thermostat, it is indeed the case. Has anyone experienced this?

0 Likes

(Warren) #276

@RBoy, @maddie I’ve been having some odd behavior with the app. I’ve observed it on a couple of occurrences so it’s not just a today or this week thing AFAIK. Basically, I have the app controlling two thermostats. What has been happening is two things:

  1. Sometimes the temp changes way late according to the logs. For instance, I have a schedule of 5am @ 70F and in the logs I see the app sending the command at 5:00am to one thermostat but the log indicates that the other one was sent the command at like 5:46am.
  2. On some occasions, the logs never show the schedule change for one app. For instance, I have a schedule of 64F @ 8:00am and in the logs I see one thermostat being set but there is nothing for the other one at all so it stays at the previous setpoint.

To be clear, I am not looking at the live logging but rather the rather high-level events for the App in the IDE and the events for the thermostat in the ST mobile app.

0 Likes

(www.rboyapps.com - Make your home your butler!) #277

If it’s happening randomly then it’s an issue with the platform timers associated with your account. It means that that platform either missed the timer or it overloaded and it timed out. It’s rare but it’s known to happen.
The best way to verify is this to look at the app schedule execution history. You can find this in the IDE under My Location -> Click on SmartApps next to your location -> Click on your SmartApp name -> Scroll down to the bottom of the pop up screen and it’ll show the schedule and history of scheduled executions for that instance of the app. If you’re seeing that schedules are missed then report it to ST support to investigate why your account is missing schedules.

There are a few suggestions from the ST staff:

  1. Try to uninstall and reinstall the app
  2. Don’t use half hour or full hour schedules as most schedules tend to run at the time which overloads the servers. Try to use an offset, like 4:55 or 5:32 etc.

According to ST, if a schedule is missed it’ll try to run it at the “earliest” opportunity (which could explain why it ran 45 minutes later). Since ST runs on many different servers/shards, some servers which are facing heavy load/issues at specific times explains why it’s inconsistent.

0 Likes

(Warren) #278

Jut to be clear, I am using a single app instance to control two thermostats and not two separate app instances. I haven’t really looked through the code but is the app designed to have multiple executions when you have multiple thermostats? To me that didn’t seem to make sense given that you have one schedule for all thermostats

I do understand what your are saying about ST scheduling. I would agree if both thermostats were delayed or neither were changed but it’s one of the two that is missed. Meaning that the I’m seeing that the app runs at 5:00am as expected but the logs only show one thermostat being sent a command sometimes.

EDIT:
Here are some screenshots to give you an idea of what I am talking about.

At 8:00am, I see the app being called per the schedule:

But, if I look into the event history, I only see one of the two thermostats at 8:00am:

Weird, eh?

0 Likes

(www.rboyapps.com - Make your home your butler!) #279

Actually it explains what I pointed out above. If you see the numbers next to the schedules, that shows the delays and execution times. At 8 am it was delayed 20 times longer than other execution times and it took 10 times longer to run than other times. The platform limits execution time for an action to 20 seconds and this one seems to take 32+, so the platform is timing out because it’s overloaded and running too slowly and terminates the instruction before the second thermostat receives it (this is specific for the server assigned to your app/account)

And like you said it’s happens sometimes, so it’s something outside the app that’s causing it. You’re best bet is to try the above steps or contact ST support to investigate why the apps are timing out/running slowly at those times.

0 Likes

(db) #280

I’m getting the following errors when I try to change the device type on my CT100 to the 5-2 Day Programmable Thermostat device handler.


Anyone else have this issue or know how to fix it?
Thanks

0 Likes

(Warren) #281

There are two types of custom code here: apps and device type handlers. This is a thermostat app and not a thermostat device handler. I don’t have one of these CT-100 thermostats but you would need to first look for the 2GIG device type handler to get the thermostat working with SmartThings and then you can install this 5-2 Day Programmable Thermostat Scheduler app to control the 2GIG thermostat.

I think @RBoy has a thermostat DTH, probably what you were looking for:
http://smartthings.rboyapps.com/Devices/Z-Wave%20Customized%20Thermostat%20with%20Battery,%20Humidity,%20Clock%20set,%20Up-down%20tiles%20and%20icons.groovy.txt

0 Likes

(db) #282

@LLwarrenP Thanks for the help and devise handler link! Got it working, operator error was the issue.

0 Likes