SmartThings Community

[RELEASE] 3 Speed Ceiling Fan Thermostat

thermostat
smartapp_hvac

(Dale C) #78

And in case you missed it… @scottashell had a great way to control the fan for night sleeping vs awake during the day. So you could run one instance of the smartapp using the 10.0 for night and a different instance with a lower differential for daytime awake.


#79

Dalec,

I am fairly new to Smartthings, so hope my question isn’t foolish.

I have a ceiling fan that is controlled by a GE 12730 Multi Speed Controller. I installed the Chad CK Z-Wave Smart Fan Control Device Handler, and also installed your 3-Speed Ceiling Fan Thermostat Smart App.

When I open the fan in the Smartthings app, and select low speed, the fan runs at 72%, in medium 73% and high 74%.

I can see in the scripts that your app calls for 30,60,90, which I lowered to 23,45,70 before I installed your app. I believe I lowered the settings to the same values in Chad CK’s device handler script, before installing that. Perhaps I screwed something up there…

Might you shed some light on why my fan speeds are so high?

Thanks so much, JimG


(Dale C) #80

Your fan speeds are fixed at Low. Med, High and NOT those variable numbers. It seems you are confused by the level settings which is understandable. Go back and put them all at their default settings. You only need to make a change on the device handler threshold IF when you press one of the mobile app speed tiles and the fan doesn’t change to the proper speed. You should never have need to change those settings on my smartapp.

Remember the fan controller is only 3 set speeds Low, Med, High and NOT variable from 0-99. The manufacturer elected to use a method of a variable level of 0-99 to trigger those 3 discreet settings. So the 0-99 variable has nothing to do with actually setting the fan speed from 0-99 which would be cool but it is confusing. Each of the three discreet speeds is achieved within a range of that variable. So anytime the variable is set between 0-33 the output of the device is set to LOW, a binary value, like pushing a button that is labeled low and the fan should be running on LOW speed. And likewise between 34-67 the output should be setting the fan to MED speed, and 68-99 the fan speed should be running on HIGH speed. If your fan doesn’t respond to the proper speed when using the device handler you can tweek that threshold setting but 99% of us use the default settings so you probably don’t have to change a thing.


#81

Dale, thanks for the response. And…thanks for all the work you put into this Smart App! A lot of us have benefitted from your talents, and it is much appreciated.


(Emerson Vier) #82

Hi I cant see my fan when I click on “Fan Control Device”.

I have MR101Z.

I use DTH from https://community.smartthings.com/t/beta-zigbee-ceiling-fan-light-controller/85084


(Dale C) #83

Currently this app is only compatible using the device handler such as Z-Wave Smart Fan Control Custom Device Handler on a GE 12730 Z-Wave Smart Fan Control or Leviton VRF01-1LX designed specifically for motor control.

So it won’t work with your existing hardware but it will be rewritten to work with this new Zigbee fan controller and device handler. The Zigbee controller is still in Beta so I’m waiting to make sure any device handler changes during the alpha/beta stages won’t adversely affect this smartapp operation.


(Dale C) #84

Click here to get the Beta “4 Speed Ceiling Fan Thermostat - Zigbee” version of this smartapp that works with the new Zigbee MR101Z device. I am currently testing it on two ceiling fans and it is stable.

For the final release I am trying to get the smartapp to recognize whether you are using the Zwave OR the Zigbee device automatically so you don’t have to have choose which is the correct smartapp.


(Emerson Vier) #85

@dalec, perfect I just install… work very well.

My daughter bed room:

Fan with MR101Z
Xiaomi Temperature Humidity Sensor
Xiaomi Buttom to turn ON/OFF light
I will install Xiaomi motion sensor when arrived.

I want to pay a beer to you :clap::beer:

Thank you.


(Jimmy) #86

Is anybody else having a problem where this only works directly after saving the smartapp? I have one setup for our master bedroom fan while in Night Mode, and it only works if I go in and re-save the setup.


(Jason) #87

Is there a way to turn the fan off manually without it turning right back on?


(Dale C) #88

Yep, I see the mode selection isn’t functioning right. I’ll take a look when I get some time

In Configure Option Settings you can set NO for the Enable Ceiling Fan Thermostat. The default is Auto so when you don’t want the automatic control set this option to No.


(Jason) #89

I guess this is not going to work for me then. I want the option to have it auto and manual so I can turn it off and on when I want and auto.


(Dale C) #90

I am a little confused since that is what the setting provides, you have automatic control and turn it off for manual control. However if I understand you correctly though you want the ability to set that option without having to go into the Option Settings screen?


(Jason) #91

Correct, I want to use the wall switch to turn it off and right now when I do that it turns back on.


(Dale C) #92

Gotcha. You might be able to do that with WebCoRE? You need the ability to recognize anytime the switch is manually pressed on or off and have that turn off your auto control.


(Jason) #93

I will give that a try, thank you.


(Scott Weismann) #94

I just got a GE In-Wall Zwave fan controller (model #12730) and am using the 3 Speed Ceiling Fan Thermostat app to control it. I’m having an issue with the motion turning it off. I can walk into the room and the fan will turn off but it never turns off. Anyone out there having the same issue and know how to fix it? I’ve tried two different motion sensors - the Iris Motion Sensor and the Aeon Labs MultiSensor 6. Any help is appreciated.


(Dale C) #95

Your hardware is not the issue. The options are not turning off the automatic control for some reason. I will take a look to see what is breaking it when I get a little free time. Sorry the inconvenience. I took out my GE controller temporarily but get it back online soon to check it.


(Scott Weismann) #96

Thank you!


(Scott Shell) #97

I’m not entirely sure I understand what you are trying to do… In my installation of the app I have two different setups.

Awake fan:

This is set to turn on only when motion is detected in the room and the temperature is above the threshold. I also have it setup to turn off several minutes after the motion stops (so if I’m going in and out of the room the fan isn’t constantly turning on and off…) It this generally seems to work pretty well.

The awake fan is also limited to specific modes specifically modes that I’m likely to be walking around doing stuff (when I’m Home and it’s morning, daytime, or evening.)

Sleep Fan:

This fan is purely temperature dependent but is limited to modes when we will be in the house and sleeping (since motion sensors don’t typically pick up motion when sleeping.)

For temperature control I have a Netatmo Indoor sensor in our master bedroom which reports temperature changes every ten minutes.

I use an Iris sensor for motion and the reason I don’t use the Iris for temperature is because it will often go hours without reporting any temperatures and even now it is reporting a temperature that is 3 degrees lower than the Netatmo indoor module.