Really Bad Update (v18.21 08/10/2017)

bug
hubv2
switch

(Alan) #1

Bear with me while I describe today’s user experience, because I think it’s helpful for ST staff to understand how bad it’s been.

My story

I was in my house this morning, and noticed that one of my motion sensor automations wasn’t working. I tried to trigger the outlet manually through SmartThings Android app, and nothing happened. My first thought was maybe the outlet somehow got disassociated from the network. This was about 3 hours ago.

So I tried repairing my Z-Wave network. Did not work. Then I tried pulling reconnecting my hub from the network. Did not work.

Then, everything went haywire in my app, it said it couldn’t connect to, and I was getting a bunch of errors. I looked on another Android device. Same problem.

I then finally went on my computer to see if I could find anything on Reddit, and that’s when I learned of the firmware push.

A better situation

Why in the world did the app not clue me in to what was going on? Instead of not working and reporting mysterious errors, it could simply say an upgrade is in progress. Shouldn’t the app have notifications for this kind of thing?

My ongoing problem

Eventually, my apps were able to reconnect. But even now, 3 hours later, I can’t control any of my switches. I get updates from my sensors, by my switches stall at “Turning On” or “Turning Off”. I’ve tried rebooting my hub and repairing my Z-Wave network. Neither thing appears to help at all.

Is anybody else still having degraded service, or has something gone wrong for me?


(Not Dexter) #2

Did you get the email notification about the upgrade? I think I got 3 or 4 emails the past few days with exact times the upgrade was happening in the US and in the UK.


#3

Someone else suggested that maybe the app should provide ‘update in progress’ the issue here is that the app itself seems to be also part of the update and ST prefers to have email subscription.

Unless you subscribe http://status.smartthings.com then users are out of the loop on potential impacts.


(Alan) #4

Nope. Don’t see any emails in my inbox or spam.


(Not Dexter) #5

That sucks. As mentioned above, definitely subscribe to the ST status subscription for outage notifications. I would think firmware upgrade notifications would be mandatory communications to the email address you registered ST with.


(Ron Talley) #6

I received 2 emails and I am also active on the forums but I do agree that a push notification should be sent to your phone or device saying upgrade is in progress do not turn off blah blah blah…

I get Push Notifications from @RBoy and @yvesracine regarding updates for the Blink and Lock Manager App and Ecobee App so don’t know why SmartThings can’t push a notification as well…

Sorry for your luck.


(Tim) #7

Thanks Smartphi! Did not know about this!


(Arn B) #8

Also experiencing the turning on/off issue but my lights actually turn on or off.

Also tried running zwave repair, but it never completes or sends any status messages


(Ray) #9

Great idea and I think ST staffs should consider this for future improvement. I do get a few emails but it’s a pain since I am not the only person using the system at home and not knowing the exact time for the upgrade is not cool. This is exactly the same thing about cable companies giving you a 6 hours window to show up for any type of work. Not cool either.


(Never Trust @bamarayne) #10

Waiting for the hate brigade to show up and say good bye to you for pointing out issues…


(fightingmajor) #11

The update turned on some of my lights while I was away. I just turned them off and moved along.


(Alan) #12

Phew, SmartThings support got me all squared away, eventually. I really appreciate the service from Jason. Don’t yet know what actually went wrong, but I may hear back on that tomorrow.

I definitely still stand by the idea that the app should be a lot more explicit about what’s going on.


(Irwin) #13

Same problems here - Hub updated, GE Switches reporting status, but not responding to commands from the app or SmartApps.

Any solutions other than wait?


( I hate Mondays) #14

I also had a horrible experience after the update: it rained like it never rained before ;))


#15

same problem here - everything detected, nothing seems to be working.


#16

Everything has been showing as unavailable for me since yesterday. Tried restarting the hub v2, internet is fine, repaired zwave, etc. Cannot control anything from the app. None of my automations are working either. Opened a ticket with support last night but still haven’t heard back.


(Wookiee69) #17

Issues here too. Turns out that while my phone app still shows all the SmartApps, when I go to the API website, it says I don’t have any smartapps yet. So none of my routines (turn lights on when motion is detected, turn all lights off at night etc.) are working. Email to support, but I suspect they are shockingly inundated with people who have the same issue. SmartThings is great - when it works. But when stuff like this happens, I really want to throw it out the window. I have 50+ devices and still use Hub v1 because I’m still waiting for the migration tool that they promised 2+ years ago.


(Janet Davis) #18

I did have a notification email, something I understand not everyone received. The app on my Android device (that I had to buy because they dropped support of Windows [but that’s another gripe for another day]) says I am on firmware 18.21, and that the hub’s been online since 8/10/2017. That tallies with the update. My results - all 3 of my Zigbee bulbs (Cree) are “unavailable.” My Front Door lock (Kwikset) is “unavailable” while the Back Door (Kwikset, same model) is fine. Plugin outlets not working at all. Cannot turn on lamps, etc from the app. Plugin outlets are from different vendors, so that’s not the issue. Smart wall outlets not working either. Or at least I cannot control them from the app. None of my automations ran last night. I unplugged the hub, removed a battery, and plugged it back in just now. Now Front Door is OK and Back Door is now “unavailable.” I can control a lamp now and one of the Zigbee bulbs is now OK.
Do they not test these things before they roll them out? I am glad I am not travelling while this is happening.

Update: 10PM this evening. Mid-morning I unplugged the hub and took the batteries out to make sure it actually re-booted. Noticed after that the Front Door lock registered as “Locked” when it had been unavailable before. My husband had gone out that door to get a package, so I thought that perhaps if I started by the hub and turned on every device, then turned it off, I might get everything back working. Each one seemed slow in turning on, but after that was OK, as if the hub was relearning the path to the things connected. I have about 40 connected things so it didn’t take me too, too long. My routines worked perfectly this evening as well, and I have tested things with Alexa and that worked. I think I am over the upgrade drama.


(JohnnyFRX) #19

One of my ZCOMBO’s decided to start going off randomly which has never happened since installation 8 months ago. Related to the update…I am not sure. I may just sit tight for a few days to see if it calms down before I let aggravation to set in.


(Ray) #20

Replace the battery. It was probably very low and the first false alarm probably killed it. I tested my z combo monthly and noticed the beep will kill my weak battery after the test.