Re-added devices show as MQTT Discovery

Hi all

I noticed after moving my devices onto Edge drivers that a couple had gone offline (1 motion and 1 contact sensor) while several others of the same make all remained online.

I tried to re-pair the devices with the hub as that usually ‘discovers’ the device again with the correct name and then continues to operate as usual.

I’ve tried today with an Aqara motion and contact sensor to re-pair them to the hub but both sensors are detected as ‘MQTT Discovery’ and profile ‘mqttconfig.v1’. I’m not that familiar with MQTT devices as it’s not something I’ve ever looked into using.

For the motion sensors that work they show in the interface with the model ‘lumi.sensor_motion.aq2’ but the re-added one just shows ‘mqttdisco’ as the model even when the same Edge driver is set.

Does anyone have any ideas why these devices are no longer being picked up as the correct device anymore? I have several other Aqara sensors of the same type that work correctly using the ’ Zigbee Sensors Edge Driver [YG] 1.8.16’ driver but for whatever reason these two when re-connected just don’t show up as the correct device.


The MQTT bits seem rather similar to the @TAustin MQTT Discovery handler but if you haven’t got into MQTT I can’t see where that would come from. Even if you were into MQTT I still can’t see how that could happen. I don’t really know anything about MQTT in or out of SmartThings though.

Actually if you did have something like Todd’s driver installed for some reason and kept deleting the sentinel device it creates it would reappear every time you scanned for a new device of any type. That’s all I can think of though and I’m not sure that fits your description anyway.

1 Like

I can confirm. That’s from my driver. If you don’t need it feel free to delete that “MQTT Discovery” device, as well as any associated devices, and remove the “MQTT Handler V1” driver from your hub.

1 Like

Ah that explains why I have it as I added some drivers while debugging issues with Edge drivers.

Strangely after removing the driver and scanning for devices it still comes up with the MQTT discovery but on a second scan it now finds the original sensor by name and has re-paired them to the hub :slight_smile:

1 Like