Rachio stopped working with Smartthings?

Hello everyone.

All Rachio devices were deleted out of my system and couldn’t be added back in.

Does anyone know about this?

Is there a solution?

Thank you in advance.

When were they deleted? Were you using the Rachio Partner integration or older custom code? You stated they can not be added back… what steps are you taking to add them and is a error generated? if using the Partner linked integration… have you attempted to remove the linked service before adding them back?

It deleted itself as a linked service. I added a device and tried to link it to Rachio and it would not complete the link.



You can try clearing app cache. I can’t really think of anything off-hand. You may want to contact ST support.

1 Like

I tried clearing the app cache. That unfortunately didn’t work.

I was able to add Rachio back in. I guess it was a glitch.

1 Like

One day a few weeks back the same thing happened to me. All my rachio devices were removed and I just had to re-integrate Rachio to ST.

1 Like

Thanks for sharing this information...