SmartThings Community

Quirky Tripper Support?


#207

Your awesome, thanks @mitchp!

It would be awesome @Stanislav if you can update the OP with the link @mitchp mentioned since I actually came to this thread from Amazon since these trippers are one of the, if not thee, cheapest route to go for door/window contact sensors and from reading the product comments, it was mentioned they aren’t 100% compatible with SmartThings unless using a custom device type so I searched and arrived here.


#208

So an update after getting the devices and adding them to ST, I have the following feedback regarding these devices (and most of it is similar to issues others have had)…

  • Using the code that @mitchp provided, I was easily able to add a new Device Type
  • However when clicking the Save button, I noticed an infinite spinning loading gif next to the device type name so I opened up the Chrome dev tools and the console log indicated a JS registerType or registrationType undefined error (can’t remember the actual name sorry)
  • I then proceeded to click Publish and set the Location
  • Then clicked the My Device Types (even after warnings that it’s not saved even though it wouldn’t let me save it haha) and noticed it appeared but without a description so right away that might be a good indication it was corrupted but it existed so I proceeded to the pairing
  • Tried pairing following the instructions, and like already mentioned in a post above, nothing happened or showed up in the list so using the above advice I quit the app and reopened it
  • Then went to the Marketplace section of the app (star icon at bottom-right of the bottom toolbar) and went to Not Yet Configured and noticed, like mentioned in a post above, it showed up as Thing so I knew something was definitely wrong at this point
  • Went back to the dev site, removed both of the Thing devices, removed the device type that I added earlier from @mitchp code to refresh everything
  • Now I started from scratch again and got the same JS error but tried going back into the device following multiple actions/clicks I can’t remember haha and got it to finally save without error. Published again and set the location.
  • Followed the instructions to unpair the devices (not sure if needed) which involved opening the devices, holding a button, taking battery out, then inserting the battery, then releasing the button
  • After releasing the button which then put the device into repairing mode, I set ST to look for devices and this time it showed correctly for the device type that @mitchp provided

From there, everything worked and it’s already working for a lightbulb in my system! I didn’t try adding the device type in other browsers such as IE, Firefox, Safari, etc, etc.

Hope this helps anyone else! :smile:


(Tim Gray) #209

Those complaints are from people that refuse to buy what is needed. you can not use just the hub and the door sensors and get unlimited range. you need repeaters in the house and the only things that are repeaters are devices that have AC mains power. SmartThings wall plug wart switches, some of the zigbee lightbulbs that support ZHA completely etc…

The best repeaters are the Smartthings brand single outlet relays as they are brand agnostic and repeat everything.


#210

Ahh thanks for the update!


(Daniel C) #211

New guy here…

I saved the code, can you give me a walk thru on how to add this please?

Thank you!


(David) #212

Hi @Daniel1 - to get an unofficial device on ST the community often creates custom “device types”. That is what @mitchp posted a link to. Here is a guide on how to set it up on your system: FAQ: An Overview of Using Custom Code in SmartThings


#213

Hey @Daniel1, I don’t know if you got a chance to take a look at the troubleshooting steps I followed but I’ll provide my post below again if you didn’t already read it so that it may initially help you out. If it doesn’t and by “walk thru” you are referring to getting these tripper devices recognized by the SmartThings hub then let me know and I can provide more basic steps for you to follow 1-by-1.

If you do need that just please let me know what you have already tried though (aka what you mean by you “saved the code”) and etc as I’m assuming at this point you might have already went to the link that @dc1515 provided and took care of adding/saving/publishing the new device type in the developer graph api site and at this point you are just looking to get the trippers recognized but we won’t know unless you explain a tiny bit more what you’ve already done! :smile:


(John) #214

I was able to get 2 Quirky Trippers to “just work” by adding a new device type in the IDE using “from code”, pasting the latest code from @mitchp. Thank you!


(Daniel C) #215

Yes… Thanks for all of the help. I got them working great.

Here’s another question though;

Do these use more battery power then other devices?


(Tim Gray) #216

nope. but they have the smallest battery of all devices. so expect to replace the coin cells every 2-3 months.

Oh and the batteries that come in them new are 1/2 dead already. Quirky bought the cheapest china coin cells they could find.


(John) #217

I noticed that the batteries were way down in just 10 days. I think I read somewhere that these had good battery life… and then I remembered that was someone talking about Aeon’s devices :flushed:.


(Tim Gray) #218

If you use the batteries that come in the box, nope. Quirky put in really cheap no brand china batteries. Every single one with the battery in the box lasted from 5 days to 15 days. brand new energizer’s last what seems to be about 60 days on heavy use doors and 120 days on seldom used doors.


(Daniel C) #219

Anyone want to buy two Quirky door sensors?


(Tim Gray) #220

You wont be able to sell them for much, I just bought a ton of them for $10.00 a box. The clearance prices all over the country is dropping like a rock.

You might be able to get about $20 for them on ebay, the really low clearance prices have not hit ebay sellers yet.


#221

@mitchp I’m unable to get your code to work when attempting to copy+paste it to the myapp section on developers. I get this error : groovy.lang.MissingMethodException: No signature of method: script14551631271211035396360.metadata() is applicable for argument types: (script14551631271211035396360$_run_closure1) values: [script14551631271211035396360$_run_closure1@5a69bf0f]
Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)


(The fish is still dead.) #222

You’re trying to create a new SmartApp. You want to create a new Device Handler.


(James) #224

Well, as of today my tripper no longer connects.

I tried resetting it but it isn’t discovered anymore.

Here’s what I’m doing:

  1. Set app to discover new things.
  2. Hold down “tamper” switch.
  3. Remove battery.
  4. Replace battery.
  5. Release tamper switch.
  6. The green light comes on, then flashes three times three times.
  7. Never connects.

:frowning:


(Bernie H) #225

Did you delete the old one device it was paired as? If I don’t devices will usually not pair back up.


(James) #226

I may try that. I never had to before. I got so frustrated with it, I ended up taking it down and putting up another one instead. Will report back if I get up the will to try it again.


(Devesh Batra) #228

I have the same issue with one of my trippers

I can pair with Wink hub, but when i try to pair with ST, it does not pair…

Only thing i can think of is that the Wink hub may have upgraded the firmware on the unit making it inoperable with ST

there are no logs in the IDE

thanks