Quirky GE Tapt Switch Device Type

I have successfully connected 2 TAPT switches but they are not accurately reporting status and they are not relaying on/off commands.
I have changed device type from GE switches to Zigbee switches and nothing works.
I did see the posts about updating firmware with a wink hub but I don’t have one of those. Will that fix my issue? I so I’ll get one, just want to make sure first.


Anyone been able to get the GE Quirky Tapt switch to work with ST? I had Wink connected but recently decided to try out the ST. So far so good and i was able to connect all my devices except for the GE Quirky switch. Any advice?

So now what? The ZigBee Switch device type doesn’t work anymore at all. So I have switches that I am using the old device type with and respond flawlessly if you use the app but don’t report their state on their own even though they are instant reporting capable. Any advice here? The features I need require these things to report to ST to trigger other actions/events when pressed on the wall, so I effectively have a non-working setup with these.

Any help would be greatly appreciated as this just simply doesn’t work. Thanks!

Oh, and they are the latest firmware as well per my Wink hub.

the newest V2 update broke connection with these switches, they were fine before and fine reporting status. Now I can’t connect them. How can we fix this?

Is any support rep on this?

Can we please add back support for this device?? The custom device type workaround doesn’t perform status reporting, my house is full of these switches that worked perfectly with smartthings before the update…
Please advise

Sorry @THE_KINGDOM life has been busy haven;t had much time for home automation lately. However, over the last few weeks I’ve had some issues that required me to put some attention into it.

You should not be using my custom device type. You should use the general device type of Zigbee Switch. THis device type allows for on/off control and instant reporting. This device type isn’t recognized by default when adding a TAPT device, you have to go into the IDE and change it to that.

1 Like

@mattjfrank I really appreciate your reply as will many in the community.
It’s strange because I tried that approach you described and I still couldn’t get it to work correctly. Let me give it one more shot, but if you have time pleasetry linking one of the TAPT switches by going into the IDE,

I actually removed my TAPT device from ST about a week ago because it and a few other devices were giving me trouble. After I read your message tonight I went and readded it. Before I could readd it I had to cut the power to it for about 30 seconds. Then once added it added as an unknown device. I logged into IDE and changed it to ZIgbee Switch and it’s work as I described.

1 Like

Hi Matt… thanks for the feedback. Tried changing my switches to Zigbee Switch but they are not responding. I will try to reset one of the switches tomorrow and see if it does the trick.

By the way, I am using a device handler which I modified based on the old GE Zigbee Switch. My device handler is not reporting real-time but updates about every 10-15 minutes.

Hi Matt,

I’ve tried adding normally, then going into IDE and changed it to ZIgbee Switch and its still not working, the switches aren’t responding under ZigBee switch. Won’t operate or report. In fact it just says it’s stuck on, and says “switching off” but there’s not change, the light is actually off.

Have you tried doing a network heal?

Unplug the SmartThings hub, including taking out any batteries, and just leave it totally off power for 20 minutes while leaving all your other zigbee devices on power.

This will cause the other zigbee devices to go into “panic mode” because they can’t find the hub.

Then when the hub comes back online, each of the individual devices should rebuild their neighbor tables. This was often pick up any missing devices.

It can take a while for the tables to rebuild, so you may not see the results until the next day. But it’s one of those “can’t hurt, might help” things that could be worth trying. :sunglasses:

Should each of the Quirky TAPT switches be added as a “zigbee switch” during this “network heal” process? Because I only have one of them added at the moment.

Thanks for the quick responses

Given that other people have said that changing to the other device type handler helped them, I would probably change them all before running the heal. That way if one of them is an essential repeater, it will get picked up in the first pass.

But you can run the heal as many times as you want. It just takes time.

Which device handler? The original one made by MattJfrank?
It doesn’t allow for device reporting, and Matt has indicated that the hub with IDE change to Zigbee switch, should allow the Tapt switches to work correctly and with reporting… which they did used to by the way, before recent hub updates…

The one that Matt suggested that you change to, just “zigbee switch.”

So I’ve tried all of these suggestions cannot get these switches to connect under ZigBee switch. They’re unresponsive and have been since the last few hub updates.
They only work with the custom device handler made by Matt, But then that doesn’t allow reporting. Is there a way to modify the custom device handler to allow reporting.
Many others seem to be in the same position as me

@mattjfrank I’ve tried removing the device and cutting power, smartthings cannot naturally recognize this switch. When I change the device type to zigbee switch, the switches still fail to operate. Have you tried completely removing a switch recently after the most recent updates?

Did you update your Tapt switch with a Wink hub recently?

not recently no, was there an update very recently?