Question about standardTile UI update in SmartThings app

Hi Nathan,

FYI. I did my custom capability based on your given resources.

Thank you for your support.

1 Like

Hello Nathan,

I discovered that the Samsung developer site has a new link for those “Hub Connected Devices” (see below link)

Is that mean I need to develop a “driver” for my ZXT-600 to operate with my Hub V3 ?

Thank you for your support.

Hi Nathan,

Sorry, I found another link “Changes to the Legacy SmartThings Platform”

May I know the time frame for phase 3?

That is suggested, yes. If you have a Samsung Connect Home or a SmartThings WiFi Hub, please consider what I mentioned in this post:

You can base on:

There’s no ETA yet for that. Please, stay tuned to the Announcements and Newsletter (subscribe at the bottom of this page).

Thanks Nayelyz

Hi Nayelyz,

I followed the instruction of the link (listed below) and try to install the SmartThings CLI but was not successful.

After I downloaded the binary for MacOS, I unzipped the file and I got a filename “smartthings”. How can I install it?

According to the instruction in step2, I need to install it and rename it.

  1. Download the appropriate binary from the
    releases
    tab of the github page.
  2. Install it on your path and rename it to “smartthings”. It does not need
    administrator privileges but of course will need to be executable.
  3. Run smartthings --help to make sure it’s working.
  4. Run a specific command with smartthings <command>

Would you help to provide more information about how to install the binary?

Thank you for your support.

You don’t need to install it, only call it for execution. Once you’re inside the directory where the file is in the console/terminal, you need to add ./ (dot slash) before the binary name.

Here are more details about how it works in the case of Unix-based OS.

Hi Nayelyz,

I’m following this tutorial and installing POP OS on my Raspberry pi in success.

However, I failed to complete this command.

smartthings edge:drivers:assign

And I got this message (Please see attached screenshot)

May I know what’s going on?

Apologies, the command in the post was incorrect, the assign command belongs to the channels endpoint:

smartthings edge:channels:assign

I already updated the original post, thanks for pointing this out.

Hi Nayelyz,

OK, it works now. I can walk through all steps.

Then, I have several questions about the new implementation.

  1. For normal users, When a new Z-Wave device is included in the network, what criteria to determine the newly developed UI (lua) or UI (groovy) is loaded for the device?
  2. During the development stage, a Z-Wave device is included in the network and newly developed UI (Lua) is loaded. If there is any UI or feature is updated (or modified), how can the developer refresh the UI?

Do you mean how it’s determined which to use the DTH or Edge driver for the device?
This is the order that is followed when the discovery process is running (this means when the user taps on “scan nearby” or accesses the brand and device through the catalog in the ST app):

  1. Self-published DTH (these are the DTHs that the user saved and published in his IDE)
  2. Edge driver installed
  3. Stock DTH (DTHs officially published by the manufacturer or SmartThings)

Wherever the matching fingerprint is found first, it will become the device’s handler/driver.

It depends:

  • If you make changes to the device profile (add/remove capabilities), you might have to clear the ST app cache (Android devices).
  • If you’re using custom capabilities and you update their presentation, if you’re using a custom VID, you need to create the device-config again. (see more details here)

Note: For all options, you need to package, publish and install the driver again.

Let me know if you have any issues with the update of the device UI and we can discuss it further.

Thanks nayelyz,

Finally I did the following steps

  1. linked up with Github account for the device handler source code
  2. Created a “Product Info”
  3. Have an approved brand

Before I publish my device for public users, how can I test (walkthrough) all steps at first internally?

I would like to download the “self-assessment checklist” but the link is not worked.

Thanks

Your Publish Request is using a DTH, correct?
I’m checking with the engineering team for more details about the “self-assessment checklist”. As soon as I get their feedback, I’ll let you know. :smiley:

Hi Nayelyz,

Yes, I attached DTH for Publish request. Is that I can test it internally before open to the public?

I also search the keyword in the supporting site and I can see some link that is related to the Z-Wave device. However, this link is not working. Would you help to review this link?

https://developer-preview.smartthings.com/edge-device-drivers/search.html?q=device+Profile&check_keywords=yes&area=default#

This issue is already reported. For now, when you use the search bar and click on one of the results, you need to correct the URL. Eg.
If we click on “Z-Wave Class”, instead of:
https://developer-preview.smartthings.com/edge-device-drivers/zwave/deviceundefined?highlight=device%20profile
We need to use:
https://developer-preview.smartthings.com/edge-device-drivers/zwave/device.html

Hi Nayelyz

self-assessment checklist

Would you help to forward the checklist for our reference?

Hi, @westwoodhk. I sent you a DM with more information, please check it and let me know if you have any doubts.

Hi westwoodhk,

I have the same issue as you did - a remotec ZXT-600 that I cannot configure with Hub V3. Do you have an updated DTH?

Thank you in advance for your assistance!

Erik

Welcome to the SmartThings Community, Erik!

Are you receiving an error when you try to pair the device?
Also, you should check the new feature to integrate Hub-Connected devices - Edge Drivers.
You might be aware that Groovy is part of our legacy platform (take a look at this announcement)