Qubino and Smartthings

Good point, I’m not sure where I was going with adding temperature to that switch handler :confused: I think in most cases the temperature attachment wouldn’t be used.

I’ve made myself a task to remove it completely.

Thanks for the nudge :slight_smile:

Is there some trick to excluding this thing? I’ve hooked up a toggle switch just for include exclude, and while I was able to include the device once, it got the wrong DH initially and doesn’t pick up temp data.

I’m trying to exclude by following the directions of toggling 5 times within 3 seconds but it does nothing. Now I can’t re-include the thing either. I’ve tried factory resetting by toggling 5 times but nothing there either. I can’t do anything. Of course it provides no feedback whatsoever. AFAICT its bricked. I can’t even tell if it actually has power.

Toggle 3 times within 3 seconds, not 5. I brought my hub close during exclusion and it worked for me.

1 Like

Just a note for anyone with the Qubino Flush 1D relay. This one will not report power because it is a dry contact relay so it has no way of measuring power. The Flush 2 and the Flush 1 relay should report power however.

I’ve got my qbino installed with the erocm123 DH. Temp reporting is working well, and the on/off switch works properly, but it doesn’t report on off status correctly. It gets stucking “turning on” or “turning off” in the app never fully on or of. But again, it does seem to be switching properly, just not reporting correctly.

Is this a known issue?

Yes, several others have reported the same over in the main Qubino thread. My guess is it’s not the handler but an issue with the device and/or ST as this happens with other devices too.

I think my issue is different perhaps. I’m using the flush on/off thermostat, not the relay. I’ve switched my DH to the Goap: Qubino On Off Thermostat one, and exposed the device to smart things as a thermostat.

I don’t want to use it as a thermostat however, I want to use the temp data and the switch for separate purposes. I’m able to do this by switching the thermostat mode from “off” to “heat”. Off=on and heat=off for some reason… but whatevs. I can control it now, which is all I need. I’ve also set the heat setpoint to something that it’ll never reach, like 150F, so that it’ll never switch states automatically.

Why are you trying to modify what is a THERMOSTAT to work as an On/Off switch?
For your needs the Flush 1 Relay would be a much better choice.

So it’s only natural, and expected, that the handler from @erocm1231 won’t show on/off states correctly since it’s designed to use Switch Binary Reports as a state change message, as is defined by the Z-Wave protocol. Thermostates send Thermostat Mode Report messages to indicate potential output states AND those are only valid when the temperature measured doesn’t exceed the setpoint, since even in Heat mode the device can turn it’s output off if the temperature is higher than the setpoint.

Additionally, the use of handlers for the wrong device can only cause issues on your end.

I’m trying to make the THERMOSTAT work as on/off because I bought the wrong device. I don’t want to throw it away and buy a flush 1 relay. I don’t particularly want to climb back up in the crawlspace where its wired up either.

It was unclear to me at the time that I bought the device that the THERMOSTAT was functionally different than the flush 1 relay. I thought it was just a flush 1 relay + the thermostat sensor.

I’ve mostly faked the thermostat out to work the way I want. I’ve set the heatingSetpoint to 150F so it doesn’t interfere with operation, and I can toggle the power state using the modeSetting() command.

I still don’t understand why Set to Cool, Set to Auto, Set to Heat, and Turn off commands don’t work however. Discrete commands would be more useful to me than a simple toggle, but I can make do. These seem to me to be valid commands for a Thermostat device and it’s unclear to me why they’re unsupported.

First things first, you’r working off of an incomplete understanding of the protocol, the modes which are supported are advertised via Thermostat Mode Supported Report frames.

Seeing as you’ve used multiple different handlers for the device i can only guess why your modes aren’t working, since each handler can perform it’s own configurations. Also, seeing as you’ve modified the handler, according to your claims, without having access to the handler itself one can only speculate what the problem is.

It seems clear you didn’t read the product manual (or the handler’s settings page) since you’d see that Cool mode can be enabled via configuration parameters and a reinclusion, so this is why it’s not working.
Auto mode is not supported by the device at all since it requires the use of two setpoints, so i’m not sure how you’ve concluded that the Set to Auto command should be working?

I’ve tested my thermostat handler on the thermostat itself, using the handler installed when i’ve included the device, as is the recommended practice, since during inclusion the lifeline reporting group needs to be correctly set to enable the device to report unsolicited data to the controller.

Since you’ve mentioned that the Off/Heat modes seem to function as inverted you’ve most likely already changed some parameter(manually or via the use of incorrect handlers) BUT didn’t perform the Z-Wave protocol required reinclusion.

In order to normalize the situation i would suggest a factory reset of the device and reinclusion with the use of the proper handler.

But in order to avoid headaches in the future, i would strongly suggest informing yourself about the product you are purchasing OR contact a licensed installer.

Well dude, I don’t really know what you’re going on about here.

I don’t recall having claimed to modify the handler, and I did read the manual and do understand that changing the mode to cool requires reinclusion. I’m not looking to do that particularly. Perhaps it happened accidentally from mistakenly configuring the device with erocm123’s flush relay handler.

I am not looking to set Auto mode either. I just included those modes in my list above, because they’re available in WebCoRE for thermostat devices and sending those commands produced no effect on MY device.

Parsing around the snark in your reply, it seems that what you’re saying, without, for some reason, simply saying it, is that I should reset the device and then re-include with the correct handler? That if the device is included properly in heat mode, with the GOAP DH, sending Set to Heat and Turn Off commands to it via WebCoRE will set each mode discretely?

Great, I’ll give it a shot.

OK so I excluded the device and factory reset it. Seemed to exclude ok. I saw "unknown device’ excluded. I guess the reset wen’t ok, impossible to tell due to lack of feedback. But now it won’t re-join my network.

I can see it trying but it won’t join. Not sure what to do now. Tried to add by hand following some instructions on another thread, but it doesn’t work.

I should have just left well enough alone. Not looking forward to HOURS more of trying to make this &%# work.

Have you tried removing power from the device and then connecting again? I think that triggers the auto-join. The other option is to trigger the switch 3 times fast I believe.

OK well after about 30 attempts to join this thing, what finally seemed to work was:

move the hub to within 1ft of device
exclude device
power down hub (was this necessary? hard to say but ST support said to do it)
power up hub
toggle off breaker that the qbino device is on
toggle on breaker, factory reset qbino with 5 toggles

toggle off breaker
put ST hub into add device mode
toggle on breaker

perform the last 3 steps until Qubino joins successfully. The documents suggest that you should be able to join with 3 toggles of the switch on l1, and while I was successfully able to exclude the device that way, and it seems that factory reset with 5 toggles was successful as well, the only way of adding the device that worked for me was toggling power to the device.

At this point the device was now discovered by hub as qbino on/off thermostat, but was not providing any temp data or operating state. It seemed to be in some sort of 1/2 added state. One more toggle of the breaker and it came fully alive.

So my original issues were 2 fold:

  1. off was on and heat was off. That’s solved. Heat is now on, off is off. It seems I some how got the device set in cool mode when I had the wrong DH associated with it.

  2. The DH does not handle setThermostatMode command from WebCoRE. That’s still an issue.

Yeah I had a hard time excluding mine too. I ended up installing a dual toggle switch in the same gang bog as my Qubino so I could cut power and the other to exclude it.

1 Like

A separate toggle switch for power just to this device would have been REALLY handy.

I have had the same problem, but I was feeding my Qubino flush 2 relay with 24VDC power source, that, although the user manual says it is supported there were no way to exclude the device nor to include using this voltage.
I have to switch to 220VAC and it worked.
Same problem, the device was recognized by the classic app, but only a few power down and up after the paired was finished it starting to work, but only on the classic app.
When I switch to the new version, the new App can not communicate with the devices.
Any suggestion?

Hi,

I’m looking for a device that just reads the temprature of my hot water tank and then can activate another device (on/off of my boiler which is already connected) based on the temprature reading.

  • Which DTH and smartapp should I use ?
  • Is there a longer thermostat cable that works with Qubino ? The one in the picture looks to be like 1m. I need around 15m to reach my boiler tank from a place with zwave signal

Fab

Hi Fab,
You can use any independent termostat, and just add an automation for qubino, that would be, when the temperature reaches xx degrees (or Farenheit) on the new termostat, activate this exit from Qubino

Hi William, thanks for your reply

what do you mean independent thermostat ? I need a thermostat that can read water temprature in smartthings. I couldn’t find any yet with zwave support except the Qubinio

Fab