Push Notifications for Schlage Lock Not Working (April 2019)

@RBoy Can you tell me what is the Node_ID and how to find it just in case they do contact me with someone who can run the script. Hub ID is straight forward. But I don’t see the Node_ID on the IDE site.

It’s the device network ID of the lock. Open the IDE, Click on My Devices, scroll through the list to find your lock. Look at the column which says Device network id

1 Like

This is not going anywhere with this support person… Is there no way to contact someone more directly that can fix this issue? @Kianoosh_Karami Can you help me directly?

Hey Rubin,

Thank you for writing us back.

I apologize for the delay in response.

I kindly request you to send the below details so that we can assist you accordingly.

  • Screenshot of the error
  • Phone model
  • Mobile OS version *SmartThings App version ( Classic/ New)

Awaiting your response.

Kind regards,
Samsung SmartThings Support

@RBoy THANK YOU SO MUCH!!! I can not express how happy I am right now. I am literally shaking in happiness. This issue has bugged me for a better part of a year. It was 1 year ago around this time that it stopped working. I am sorry for any mean thing i might have said to you after trying your other methods(repeater). It is working flawlessly right now. You have made the lock the crown jewel of all smartlocks again(for childcare setting since you can’t have a deadbolt). Also thanks to Sathyendra Nath at Smartthings support. I know I had not been very patient with you and i am sorry. You at long last pulled through for me. THANK YOU ALL!!


Hey all,
So today I got notification that they had applied the fix to my other lock (they fixed one of them two days ago). I can now say that both my locks are sending notifications now. Super excited to have this fixed finally.

Is this a patch for the Hub or for the lock. How would I apply a patch for the lock?

It’s a script that only ST support can run from their side that will send some commands to your lock which will re-enable lock -> hub communications that were causing your lock to not send the notifications to your hub. This script cannot be run by you due to a bug in the hub firmware and can only be run by ST support manually (until the new hub firmware 0.31.x is released, after which it be automatically run when the lock pairs itself with the hub)

In the classic app, I am able to manage the lock just fine. status and create/delete codes. In the new app, I get status of the lock but I am not able to see or create/delete codes. Is this part of the problem that you are describing above? Thx. Just trying to get my head wrapped around the issue.

It doesn’t sound like it’s related. This issue is specific to lock initiated (unsolicited) commands for the FE599 and BE369. I.e. remote commands work fine but physical operations don’t reflect in the app.

If both these symptoms are met then you’re running into this issue:

  1. You don’t get a locked or unlocked event notification when a user locks / unlocks the lock manually (physically on the lock) or via a user code on the lock keypad
  2. You are able to successfully program codes remotely, you can lock/unlock the lock remotely and it shows the correct status when operating it remotely

If you are seeing both of the above then your FE599/BE369 is affected by this bug (basically if you paired your FE599/BE369 with the hub after April 2019).

If you’re having issues with programming the lock or intermittent user notifications you may want to read this topic. If you can program codes with the Classic app but not the new one it most likely an ST app issue. You can try an alternative app which works on both the Classic app and the new app like LUM.

I just migrated from Wink to ST hub v3.

ST does not show lock/unlock push notification of my BE469. I thought this bug ONLY affected FE599 and BE369?

  1. I can see ALL the activities (manually un/lock or remotely un/lock) in Classic ST under “Recently” tab.

  2. The only way I get notification is when I use the Smart Lock Guest Access app in the new ST app. But I ONLY get notification when guest codes are used and not when manually lock/unlocked. ALL activities are shown under History tab.


You can create a notification with an automation. If the door is unlocked send me a notification


Welcome to the community! You’re correct, this issue is specifically for the FE599/BE359 due to the way they need to be setup while pairing with the hub (and will be resolved with the upcoming 0.31.x hub firmware or by having support run the “script” patch)

In SmartThings you need an app or automation to act on events, eg to push a notification, send a text message or create an action. Since you’re seeing all events in your lock history your lock is working fine, you simply need to create an automation as Jody mentioned (using the new ST app click + Automation) or add an app which acts on these events. (Check out the How to migrate from Wink to SmartThings Wiki for a quick overview of how SmartThings works)

The Smart Lock app sends notifications when any user unlocks a door. You can create an automation using new ST app which sends you a notification when the door is unlocked but that will send notifications for all unlocks, manual or user unlock, as it cannot differentiate between them. If you also have Guest Access installed, you’ll get two notifications, once from the Automation and one from the Guest Access app.

If you want to customize the notifications then check out the Lock User Management (LUM) app which can selectively enable Manual lock, Manual Unlock, also selectively enable notifications for individual users, even pick a hub mode condition for manual locks/unlock notifications and much more.

Thanks, guys! Got it. I thought ST would automatically send out push notification like Wink App does.

I just did exactly what you said: set up an automation on lock/unlock for all door lock notification as well as Guest Access notification to get notification on specific user actions.

Will definitely look into the Rboy apps as I learn and add more smart devices to ST.

ST is so much faster and reliable than Wink!

1 Like

@Kianoosh_Karami - or anyone at Smart Things

I reached out to ST using all of the language above, added links to this specific thread on the forum and referenced them both toRBoy and to Kianoosh Karami. As usual, any information relayed gets ignored and we get the following response. I responded again with the links and descriptions. Hoping that posting in the main thread might help get me routed to an ST TIer 1 person who is either familiar with the issue or can direct me to someone who is. He is the fourth ST rep we have been going back and forth with.

Vani Jupalli (SmartThings)

May 23, 2020, 1:51:22 PM MST

Hi Nancy,

Thank you for taking the time and writing back.

Please accept my sincere apologies for the delay in response.

In order to resolve your issue, I request you to please remove and readd the locks to SmartThings application and check the status of the notifications.

After that please make sure that you turn on the notifications option. To do so follow the steps provided below:

Open Settings

Select Apps

Scroll to SmartThings

Then click on Notifications

After clicking on Notifications toggle the ON option. below you are able to see SmartThings notifications should be ON and General notifications should be ON and also App icon badges ON

Once you follow the above troubleshooting steps and check the status.

Apparently @clifster @TomSBos and @Rubin_Chen had a similar experience being bounced around for some time before getting to the right team, maybe they can share how finally they got support to run the scripts to fix their issues.

So i think them getting it right the first time is impossible. You have to reply to that email stating politely but firmly that you have the “ie. fe599” and that you are having issues due to auto encapsulation. Link the thread the staff member posted and also them you need this escalated to their technicians to have the patch applied. Don’t forget yo tell their you hub id your device id etc.

It took me 2 weeks and 6 emails to get through. Hope you have better luck. Also it might be good to use the same email you use for the account to contact them.

Once its fixed though its been working flawlessly. I would even go as far to say that its working better than before the notifications broke. I can get very up to date info on who opened the door from the code they used. Its been so consistent i already worked it into my automations

No secret words, just persistence. Ask, ask, ask, then ask again.


Anyone here found an option that allows for automations to trigger when someone locks up or leaves? While RLA has the capability of triggering custom actions when users manually lock the controls, it does not appear to trigger when a user pushes the physical lock button on the inside of the lock which, as far as I know, is the only way to manually lock this particular smart lock.

Is there another way that you guys are using to trigger actions or situations where the manual lock or keypad lock options would come into play?

It is encouraging to hear that some users are having success. I am not. No matter how many times I ask and put a description (last time I even copied and pasted what somebody said worked for them) I get the same response. Honestly I think they just see the word notifications and hit some button that puts an automatic reply in the email. It’s too bad they aren’t rewarded for actually solving a problem. It has already been a year for this problem. I will keep trying and maybe one day I will get a support person who will actually read my email.

Thank you to all who have contributed to this thread - I had a success.

Am a Wink refugee and signed up to Lock User Management from RBoys. Frustratedly accepting the upcoming firmware explanation for the fix, but with time on my hands lately, I threw all the jargon at ST as had nothing to lose.

Yes, initially the responses were hugely annoying as the ST support guys didn’t understand the jargon I was using anymore than I did! Here’s a summary of what I emailed:

I have a Schlage FE599 lock. So far I have really enjoyed ST.

I’ve become aware via the ST Community of an auto encapsulation issue with notifications/updates and would like to request the association workaround identified in ticket 899130.

Please would you send the association workaround script to my lock:

*Hub ID *

Node ID

Cue this response…

Just to confirm, are you facing any issues in receiving the updates and notifications for your Schlage lock?( LOL)

Could you please elaborate the issue you are facing and what exactly you mean by association workaround script? So that we can help you further.

Please feel free to contact us for further assistance, we will be glad to help you.

And then this…

I am really sorry, I am unable to review the ticket #899130. You can also send us a screenshot/picture from that ticket , so that we help you further.

As you have mentioned that you are not receiving the notifications from the lock, I would suggest you to please click on the below link and follow the steps to set up notifications. (LOL)


Please elaborate more about the issue you are facing, so that we can check and help you.

At which point I politely explained that I didn’t have access to THEIR support ticket (LOL) and I was unable to elaborate more owing to the fact that I didn’t fully understand what I was asking for either!

I then requested it be escalated to Tier 2.

To do this they requested:

  • Mobile model
  • Mobile version(IOS/Android)
  • App version (screenshot taken within classic app)

3 days later I suddenly started getting per-user push notifications and manual lock/unlock notifications and happy days! And they sent me this:

We have gone ahead and sent some commands to this Lock that should help it report its status and generate notifications.

Once again thank you to all who contributed to this fix.

I’ve found setting up an SMS for the lock/unlock to cover the inadvertent manual unlock situation has been reassuring so far. I use a suitable emoji/symbol so I know its status is locked in my texts.

A couple of remaining FE599 issues of my own…I had leaky duracell optimums so I replaced with lithiums…these report 100% battery which is clearly not the case, and I read elsewhere that the lock is not calibrated for lithium, only alkaline, so I’ll be replacing with alternative alkalines.

I wanted to share that I went back to the new ST app after the above fix and deleted the classic app, have not noticed any issue as far as my needs go.