SmartThings Community

Purpose of custom "SmartThings" Arlo mode?

@Dan_Fox36m Crussell
How did you get Arlo to record locally?

Saw this in a different thread so I am responding here. I hear so many people experiencing lags with their Arlo Cameras and I do not know what the problem is. From the time I enter the zone and trigger motion my cameras start recording in less than a second. Now, if you are hoping to view live video, that is not the way arlo works. You must first for the cameras to finish recording, sent the videos to the cloud and back to Arlo and Smartthings.

Some people are also having this problem and have not been able to resolve it so in this regards I am lucky I guess. I have the cameras turned off in Arlo and in Smartthings I turn the cameras on/off with routines. Arlo sends the videos to both Arlo and to Smartthings. After the recording has finished, I can view them in both places.

Digging this back up…

I have had the Arlo’s for a week now and am still unclear as to the purpose of the custom SmartThings mode created on the Arlo system when the integration is activated.

In the SmartThings mode, I cannot add rules to have the Arlo’s record locally, but can create rules in SHM to trigger the cameras to record. The motion detectors work. I can view the cameras live in the ST mobile app. Lag is increased however by 2-4 seconds. I am unable to disable push notifications in the Arlo app for the SmartThings mode.

I can run the Arlo system in Armed mode under which the cameras will record locally based on whatever rules I create in the Arlo app. I still can, however, use the cameras as motion sensors in SmartThings. I can view the cameras in the ST mobile app. I can also still have SHM rules trigger recordings which I can view in the ST app albeit with some added lag on start time.

So after all of that testing, I am genuinely confused as to the true purpose of the SmartThings mode in the Arlo system. It would seem that not using SmartThings to trigger recording whenever possible not only reduces lag, but also enables recording locally is the better choice. The only thing I seem to lose is the ability to selectively control when the cameras record based on SmartThings modes.

What am I not seeing?

@SteveWhite,
It has been awhile since I have had to play with my Arlo system and I am sure a lot has changed since then. I am also assuming that you purchased the new Arlo Pro system which I am not familiar with.

In my case since I have a monitored alarm system and use ST as a backup, (and a few different functions), by integrating Arlo with ST just saved me one step - I only had to arm/disarm two systems instead of three when I left my home or arrived back. The second reason is that I wanted individual control over each camera depending on the state of ST.

As for the lag that so many people are complaining about, I fiddled around with all the settings in both Arlo and ST for almost a week until I got everything working just the way I wanted. My lag time in ST is about a second.

1 Like

…and…you fiddled around with WHICH settings in both Arlo and ST until you got the lag time in ST to around a second?

1 Like

@Charles_Praigg,
Hi Charles, Maybe I am just lucky. In Arlo, in the Smartthings Mode, for each device, I have the rule set to “Record Video.” I have the “Detect Motion” set to 100%. I have the cameras normally set to off.
In Smartthings, since my cameras are outside, I want individual control of each camera, so I wrote a custom rule for each camera for notifications and trigger the cameras with the routines. I treat each camera as a motion detector, not as a camera.

Thus, when Smartthings is armed, any motion will act just like a ST motion detector, fire the custom rule which turns on the camera and Arlo starts recording.

I don’t have the time right now to list every setting, but hopefully you understand how my cameras are set up.

So…this is my first post on this forum, in fact first post on any forum in a while,

but I have been reading up on this Arlo ST integration and relationship quite a bit and I might have stumbled upon some helpful settings…so here it goes:

Using the settings below, renders these desired results:

1 - The motion sensors on my three Arlo cameras seem to stay inactive and not use battery.

Confirmed from a refreshed current state panel in the developers panel. In fact when they do go active for SHM or a custom rule, the red lights for night vision mode come on and stay on for the duration selected (30 sec, 1 min, or 2 min) but the motion sensor returns to inactive within seconds, confirmed with a repeatedly, quickly refreshed browser.

2 - The cameras remain active and available to be turned on via SHM or custom rules with no lag.

3 - The cameras send the same duration clip to ST mobile app (visible in intrusion alert and in history) AND to Arlo (even though “do nothing” rather than “record video” is selected in ST mode within Arlo settings) In fact, the duration of the clip saved to Arlo matches the duration selected in ST, 30 sec, 1 min or 2 min, huh.

Settings: (I got lucky, wouldn’t have tripped over it w/o all the feedback above and on other posts, thanks!)

Within Arlo:

1 - Click on SmartThings Custom Mode
2 - click edit next to first camera
3 - Make sure to select the same camera under “then do the following” as is selected under "if the following"
4 - Select do nothing
5 - Select push notification
6 - Click Save
7 - repeat steps 2-6 above for each camera

Now the motion sensors are not active and do not cause any recording to happen via arlo until ST tells it to do so, via either SHM or a custom rule.

So now use SMH or custom rules to setup when to use each camera for recording.

I currently have mine set to record when glass break sensors or door open/close sensors trigger when “Armed (Home)” and set to record whenever any sensor goes off when “Armed (Away)”.

This is only my third day with the ST system, and I have yet to set a custom rule except for testing. I hope to set up the cameras to record only when their own motion sensors trigger (or adjacent glass break), rather than all three cameras recording when any door or glass triggers when home, or when any sensor triggers when away.

Turn off notifications for the Arlo App on your mobile device, or simply do not install it. For me, the clips on the ST mobile app, and the backup copy on Arlo is sufficient. Since I do not use the Arlo app, just STs mobile app, I never see or hear the notifications from Arlo. So the notification remains out of sight and outta mind:) Weird thing is that Arlo would not let me save my settings unless either the notifications or the email alert box was selected. I def don’t need any more email, ha, and in this case an invisible notification is perfect!

I do like having the double copy on Arlo, it is easy to see all the clips at once and navigate through bases on timeline; and can view on a larger screen if needed.

More weird things are that the duration settings within arlo will always default back to 10s no matter what you do or how many times you try to save them. Don’t worry about this, use the duration settings within SHM or custom rules and Arlo will follow suit. Another weird thing is that the “motion is detected” box in the “if the following” settings is clicked on by default and cannot be deselected. This does not affect this scenario, but is any additional observation.

Any feedback is appreciated, I just hope this helps someone with their scenario.

Best,

sjinx

3 Likes

Hey all, first time poster.
I’ve just got my ST, and a set of Arlo cameras (2 currently).
I’ve gone through in ST app and setup SHM, and that has created the custom mode in the Arlo app.
However even though I have SHM in disarmed mode (i.e. everything disabled) my Arlo cameras are still detecting motion.
I’ve tried altering the custom mode in the Arlo app, no dice. I’ve then deleted it and recreated it, no luck.
I can see Arlo in the SHM and ST parts of the app, can call up the different camera feeds, etc. It seems however that SHM isn’t setting the mode correctly in Arlo.
In ST app if I go into a particular camera and look at ‘Recent’ I can see it activating and deactivating the camera, generally with the same time stamp for both activating and inactivating…
Am I missing something obvious here?
Help
Paul

Actually, I think I’ve worked it out…
It is actually working, but what I was getting confused about is the notifications I am getting from Arlo to my phone when SHM is in disabled mode…it isn’t recording at that time, just saying it’s detected motion.
I think this is a bug in the Arlo app, as you can’t deselect all notifications options…it’s an e-mail and/or a push notification. To get around this I’ve added a bogus e-mail to the e-mail notification area in the Arlo app, so at least it won’t keep buzzing my phone when we’re home.
FIxed…I think…
:smile:

2 Likes

Yes it’s a bug for sure! Same issue!

Looks like a way to fix this is change it to email notification save, get out, come back in and NOW you can unselect email to have zero notifications. :slight_smile:

Hi, thanks for sharing your experience.
May I ask you to further clarify if, when ST set the camera off (via mode or rule), if still uses its motion sensor ?

Thanks in advance

Matteo

Setup a arlo q. Everything is working great other than receiving motion detection notifications from arlo no matter what mode I have smart things set as.

Any suggestions?

Click on the pencil to edit smart things mode. go to each camera rule and turn off the push notification

I have tried doing that but in the arlo app under smart things it will not
let me turn off both email and push notifications. It makes me select one
before saving.

yeah seeing that now too. I would say your options are to turn off push notifications for the arlo app on your device OR send emails to a “smart mailbox” in your actual email or send the notice to a dummy email. I just tried to edit the email and it will allow you to send to an email other than your Arlo account email.

Yeah I was going to do the email route, just hoping there was a actual
solution. Seems like a common sense thing to be able to disable. Oh well.
Thanks for the suggestions

1 Like

Has Arlo fixed the delay issue that people have spoke of in the past?

sorry to res this! How are you viewing the footage in the ST app?

Ugh, this is a mess.
I have two Arlo Qs.
I am using Smartthings presence detection to Arm and Disarm. This is working. When I leave the system “Arms”, when I come back the system “Disarms”, however the cameras keep recording and push-notifying.

I would assume since I’m letting SmartThings app determine when to arm and disarm, there should be a settings based on each mode.
I expect I should be able to fine-tune alert behavior in SmartThings for both Armed and Disarmed separately.
Am I dense? Am I missing something?

Depending on how you have this setup it should work as this is how I use mine also. I don’t think you’re able to do it in SHM so I setup routines that are based off presence. When all the presence sensors leave it arms SHM, turns off lights and turns on the cameras. When I arrive a different routine disables SHM and turns off the cameras. I have 2 other routines which arm and disarm the system based on time schedules ie at bedtime and right before I wake. These too turn on the camera only the outside ones as I don’t need video of me in my boxers getting a glass of water :). I then have SHM set to record the specific cameras based on motion when it’s armed. This setup seems to be working OK, other than the settings getting reverted back to default on the sensitivity by ST everyday.