Problems Setting Autolock with Z-Wave Lock PH Edge Driver

Hi @Puzzling

Not at all… I may have got lost in the thread a bit :wink:

I tried some A/B Tests… operating from the Android App vs from SmartThings Advanced.

In SmartThings Advanced
Auto Lock was Off

In Android App
Auto Lock was Off
Toggled to On
“circled” for 25± seconds, resulted in pop up: “A network or server error occurred. Try again later.
Toggle remained Off (after refreshing card)
SmartThings Advanced Remained Off (after refreshing web page)

In SmartThings Advanced
Auto Lock was Off
Clicked “autolock” command button & refresh command button
Auto Lock was set to “autolock” in SmartThings Advanced
AND to “On” in Android App Device Card

Repeated “In Android App” steps above again, trying to turn OFF from Android App.
Same result… “network error…”
Android App Device Card Toggle remained On (after refreshing card)
SmartThings Advanced Remained autolock (after refreshing web page)

In SmartThings Advanced
Auto Lock was autolock
Clicked autolock “off” command button & refresh command button
Auto Lock was set to “Off” in SmartThings Advanced
AND to “Off” in Android App Device Card

Summary:

  1. The Android App Auto Lock Toggle does NOT work.
  2. All OTHER Commands sent from the Android App DO work.
  3. Sending AutoLock (and other commands) from SmartThings Advance DOES work.
  4. In my case, changes made on SmartThings Advance ARE reflected on the Android App Device Card

@philh30 Hope you’re doing well !!! Can you review my prior post on the “one” out of eight Schlage Locks not updating the AutoLock Status on the Device Card? I wonder if that, along with the behavior I outlined above and what @Puzzling is experiencing, might point to some kind of coding issue specifically related the AutoLock field ??? :thinking:

2 Likes