Problem with power outlet routine

Hi i bought a hub at the weekend and tried to set up a routine to turn a lamp on at a certain time using the smart things outlet.

I’ve selected the correct outlet and under additional settings selected the time at which the outlet should turn on. But it doesn’t trigger at the correct time.

Am i missing something? Is there a way to check that the timezone is definitely on london time?

I know that the outlet and lamp are working correctly as i can manually turn the switch on and off through the app.

Any help appreciated.

To check your timezone > locations

Thanks - i wasn’t sure how to log in through a web browser.
I’ve checked the time zone is Europe / London
I’ve done a print screen of the routine ./ event - could you please telll me if there is anything i should change to get this to work properly?

From what I see on the page there are no scheduled jobs or subscriptions, so I see nothing to trigger an on event. You prob should contact support.

You should delete that Routine and put it in again. See if that works.

Thanks for everyone’s advice.
I deleted the routine and then added it again using the timed option - and still the routine didn’t activate.

So i changed the routine from a timed trigger to instead perform when a motion sensor was active. This resulted in me receiving push notifications that the routine was performing because things have started happening. But the power outlet still doesn’t actually turn on.

To reiterate i can manually turn the outlet on / off through the smartthings app. I just can’t get it to work with a routine.

I’ve also tried uninstalling and reinstalling the power outlet.

I’ve now contacted Smartthings Support and i will update with any info they offer.


Hi Claire

rather than creating/using a Routine could you use the ‘Smart Lights’ App. seems to have all the settings you require


Hi Alec thanks for the suggestion. I tried deleting the routine and using the smart lights app instead and still no joy.

Hi Claire. I just tried it myself and it worked fine. seemed exactly in sync with my phone clock, on and off.

I’ll post a clip of my setting in the smart lights app

Thanks for your help Alec - i turned my iphone off and back on again and miraculously the Lighting app then worked correctly and the settings now match yours in your screengrab. Lesson learned - try the most obvious thing first.

1 Like

Hi Claire I’m not sure why you can see your device on the link posted above, that link is for US devices.
Your device should appear on this link

I am having exactly the same problems as you. I was using Smart Lights app to turn lights on before sunrise and after sun rise, then on at 5:20pm and off at 10:30pm. It worked fine, but then with the dark mornings and evenings drawing in I had to change them to time based.

I set my lamp to turn on at 6:30am but it came on at 5:30am.

I switched from Smart Lights to using the routines to turn the lights on and they also don’t seem to know what time it it.

My goodnight routine isn’t turning my light off. Good morning seemed to work this morning. I think there might also be a problem if a routine is the same mode as a previously actioned routine then it just doesn’t work.

I’m doing some more testing before I contact support but if it can’t even turn a light on and off at the correct time then I might as well get a refund and got back to using a plug timer!

Hi Adrian - I gave up on routines and am using the “smart lighting app” instead - I have it set to come on at sunset and then a second installation of the app turns it off at 11 pm and this has been working fine for some weeks now.

Thanks I might give smart lighting another try.

I’m having exactly the same problem. The outlet used to work absolutely fine with the smart like app and all routines. Now I can only turn it on and off using the manual app button.

It is a bit bizarre, as it has been working fine. I’ve deleted and re-added the outlet, I’ve redone the routine settings, and I’ve rebooted the hub. Nothing works so far.

Given my starter kit only comes with one outlet, my minor smartthings network is not very smart anymore. In fact. It’s a hassle. So any help would be appreciated.

Have you tried rebooting your phone ? That’s what worked for me. My routines have been working fine since i had the problem a couple of months ago

Thanks Claire. The problem, like yours, seems to be rectified.

I have since rebooted my phone. But I have also done a number of other things and completely ignored smartthings for a bit.

Rather inconclusive what eventually fixed it!