Problem with Jasco ZW3004 (45742) dimmer switch


#1

Installed a new Jasco toggle style dimmer switch. It installed fine and was working great both locally and with SmartThings. I even added a “Big Switch” app to get it to control two other Zwave modules.

Then ran into a problem. When I flip the toggle (operate it locally) it turns on/off and dims the circuit just fine, but SmartThings does not recognize that anything happened (status does not change and, of course the BigSwitch app doesn’t fire). BUT when I control the dimmer from SmartThings, the dimmer works fine (an of course BigSwitch app works).

So… I attempted to uninstall (thinking a reinstall would help) BUT, when I try to uninstall, SmartThings spins and spins, not recognizing the dimmer. I could “force delete” but it warns that I would not be able to re-install the dimmer…
Thoughts, recommendations?


(Patrick Musselman) #2

When you say force delete do meaning just trying to remove the switch without using the exclude method? If you use the exclude method you should be able to add it back in without issue. As far a ST not seeing the status of the switch I am not sure why that is. It could be that the switch is too far from the hub maybe? But that does not sound like the case if you were able to use ST to control the switch. Personally I tried the Big Switch app and had nothing but problems after installing it. Reach out to tech support they should be able to provide some assistance.


#3

Update:
Talked to ST support - they deleted the dimmer from their end. I still needed to “exclude” it. Tried numerous times in ST with no luck. I remembered that another controller could do a factory reset, so used a GE remote (from my pre-ST days) to factory reset the dimmer. I was then able to re-include it in ST z-wave network. It kinda, sorta works:
I can turn on/off/dim the light via ST dashboard. When I do the BigSwitch App works.
I can turn on/off/dim the light locally (manually toggling the switch), but ST does not recognize the change in state unless I open the dimmer in the ST dashboard and hit the “refresh” button. When I do, it changes state of the dimmer in ST and fires BigSwitch.

So… for some reason ST is not automatically updating/refreshing the state of the dimmer