Privacy policy / Legal Information agreement fails (Network error)

Any chance the app can be fixed. Not only do I have to go past the annoying Bluetooth bubble I now get presented with the Legal Information screen every single time I open the app. Nine times out of Ten it says there is a network error and the up is completely unusable. Please fix both issues!

Hi AverageJoe90,

I’m not sure if your situation is similar to mine, but I’ve just had and fixed (fingers crossed) an almost identical issue.

I’m running the latest SmartThings app on a iOS 14.0.

  1. A random time period after opening the app (Version 1.6.51-435), this can be anything from 1 to 60 seconds, I am presented with a grey screen entitled “Legal Information”. If I manage to click on a menu or a button before this page appears it seems to delay the “Legal Information” screen being shown, but only temporarily.
  2. There is some text and a link to view the “Privacy Policy”, which opens another page and a button in the top right labelled ‘Done’. The ‘Done’ button appears to be the only way to exit the “Legal Information” page, but pressing it just causes a dialog box to appear. The dialog states there has been a network error, “A network or server error has occurred. Try again later” and just an Ok button to dismiss the dialog.
  3. Pressing the Ok button just takes me back to the “Privacy Policy” page.
  4. Restarting the app is the only way to get out of this.

I’ve attempted the following to resolve the issue:

  • Signed out and signed back in.
  • Rebooted the phone.
  • Uninstalled and re-installed the app.
  • Turned off WiFi connection and attempted all the above on 4G connection.
    None of these actions have resulted in the issue being resolved.

At this point the app is effectively useless.

However I remembered that yesterday I enabled GitHub integration within the SmartThings IDE to allow me to add some custom Device Handlers. So I’ve went back and deactivated the integration:

  1. From main page of the IDE, goto settings,
  2. Click the link entitled disconnect, just under “Default Namespace”.
  3. Follow the instructions
  4. Restarted the app and the problem is resolved, no instances of grey / legal information screen since.

Hopefully this will help someone else.

1 Like

In my case I have not made any new or changed any GitHub connections lately.


Same here - now i can’t even agree to the legal terms bc it just says network error

1 Like

SmartThings app on iphone iOS 13.6.1 opens to Legal Information Agreement - when you tick the “I Agree” box and tap Done it gives the error: Network Error "A network or server error occurred. Try again later. I’m assuming this is due to the rollout and changes made.
when are they going to just open up a local network administration method by IP or something - this is ridiculous… I was happy for a second bc the email clearly states that’s what this update was for

1 Like

Which email was that?

1 Like

Some people reported they were seeing this message if they were linked to GitHub, but if they unlinked from GitHub the message went away.


1 Like

Just started getting this myself. Not sure it’s hub FW related as my hub has not updated yet.

But yeah, my ST app on my iPhone and iPad is now useless.

@Brad_ST @blake.arnold @Kianoosh_Karami - I think this needs some priority attention.

UPDATE: A restart of the apps on my devices appears to have cleared this, for now.

Seriously, this is a real mess lately. I just cannot rely on it at all right now.


Not linked to Github

1 Like

What a mess. :scream:

1 Like

Online / offline status for Hub Connected devices will be monitored and generated locally. I’m assuming this means we can monitor it ourselves locally? If not - what does it really matter? lol

It might matter a great deal because there have been continual problems with device health since it was first introduced, most specifically devices being marked “off-line“ which actually weren’t. This in turn could limit the automations that would use that device.

There has long been speculation that much of this was probably due to cloud latency.

So the hope is that if device status is moved to the hub where possible, it will become much more reliable, and that in turn will improve the reliability of automations that trigger off of device status. :sunglasses:

I never had any GitHub integration setup in the first place.

I’ve done a restart of the ST app on the iPhone, a soft reboot of the phone, a hard reboot of the phone, a test using cellular data only - no response, restarted the main hub, restarted all 3 hubs and the modem, reinstalled ST, made sure it wasn’t running on any other mobile device, and checked to make sure nothing was linked with GitHub … i’m dead in the water

** UPDATE ** - The app is randomly working now - without going through any of those steps again.

1 Like

Posts were moved from Hub Firmware Release Notes - 0.32.7 as there is no connection between the hub firmware update and this issue.

There appears to be degraded performance from the service that handles content such as the privacy policy. The responsible teams are aware and looking into it.


Thank you.


It would appear to have resolved itself now. Still get the bluetooth everytime, still very annoying

This same issue is now back again. When opening the ST app this morning, I get the legal information screen after some seconds. Tapping the “agree” button results in the error message that is mentioned earlier. Tried everything to get rid of this. Even installed the app on another phone to check, and after logging in with a brand new created Samsung account the same thing happened. So app is useless for the moment. Very annoying. Luckily I have Google home to control everything while this is hopefully getting fixed asap

same thing here, following

I’m also getting this, UK based on EU01 West shard if it matters!