Preview | SmartThings-managed Edge Device Drivers

I also in the EU server

2 Likes

Thank you Eric but i was asking when adding the device from the smartthings app. How will we know if a device from a specific brand if its integration has been updated to use the new drivers before adding our device. Will you add a small lua or edge icon to the device or brand?

During the beta, the list of devices in the app doesn’t list driver-based integrations. For Zigbee and ZWave devices, if you opt into a channel & install a driver those will have a higher priority in fingerprinting. For LAN devices you can only currently discover those via the ‘Scan-Nearby’ option. Unfortunately, for now, you’ll get two devices for any LAN device that is available normally in the SmartThings platform because we don’t have any way to de-duplicate those devices. This will be improving before the end of the beta, but I can’t say specifically how.

2 Likes

Ok then. But since you said LAN devices, and as far i know the only current LAN integration is the Hue one, does that mean that Wi-Fi devices will be able to be added locally without the cloud integration? E.g. Tuya?

Yep. :smiley: That was the major motivator for going with lua on the hub rather than trying to do something declarative like Rules. There’s so many standards in LAN devices that there’s effectively no standard. Instead, there’s a full socket API available: Tutorial | Writing an RPC Client Edge Device Driver

4 Likes

That is indeed great!! Does this also mean that lan cameras will be able to be added? E.g onvif ??

@smartthings @blake.arnold @psbarrett Guys please fix the reply to specific post/comment button as i end up needing to tag you everytime i post a reply.

We didn’t really design drivers for lots of throughput (like video) and I’m not aware of plans for supporting getting video through the rest of the platform. But if you had a camera with an API that can report motion or something like that you could integrate that as a sensor.

2 Likes

That is not so great, sorry. Lets hope that at least more camera integrations will pop up then.

2 Likes

When I go to the site and enroll my hub, it shows the Water Valve as ZWave,. Which is correct? This list or the site?

@Andremain can you give this another try. We think we have a fix in place. If it is still not working using the normal url you can also give this one a shot. You may also need to clear your browser cache

2 Likes

No permissions
image

2 Likes

It does the same.
also clearing the cache

Hey Jimmy,

It looks like our formatting got messed up in the original post. That link you clicked was meant to just be an example of what the urls look like, and wasn’t meant to be a hyperlink. We have corrected the original post.

To try out the beta channel you can use the url mentioned further down the post.

https://api.smartthings.com/invitation-web/accept?id=450930c1-02a6-43d8-adaa-4cbc51027956

2 Likes

Nope tried both links and none works. Even cleared the cache again.

We’ll continue to look into this. Thanks for checking

1 Like

Any time. Keep me up to date and i will check it for you.

Got it working. Kinda strange the SmartThings/Aeotec/Samjin water sensor isn’t part of the Edge zigbee water sensor driver

Hi all - I’ve been privileged to participate in the Alpha for this and have been working on some LAN-based device integrations that I will be making available shortly to the community.

The first is a fully-functional UPnP control point driver that you can use to discover and integrate all the UPnP-enabled devices on your home LAN. This one is just about ready.

The second is a bit more niche, but may be of interest to anyone with a DSC security system. It is a driver for the Envisalink interface, which can replace your current alarmserver package - so no more need for running it on a Raspberry Pi, and everything is strictly local and running on the hub. This one is about a week or so away.

Happy to share my experiences and learnings coding with the new Edge platform.

The SmartThings Edge team has been great and I congratulate them on the Beta announcement!

8 Likes

This sounds exiting!

2 Likes

We just pushed some additional fixes if you have a chance to give this one more try. We have also now seen some of the issues persist even through clearing the browser cache. The only thing that seems to work is creating an “incognito” tab and trying the link again from there.

1 Like