Presence sensors: Just stopped working [Platform issue now fixed!]

I did the same and it worked for me.

1 Like

Well I’m not impressed to say that despite moving the hub as far away from my router as the supplied ethernet cable would permit, both sensors have stopped working again.:frowning:

If this keeps happening, the system is unusable for me…

Have you tried a soft reset by (gently) removing and readding the battery? Also, can you try tapping the button on the circuit board (rather than a full press/hold to reset)?

I’ve had the same problem… Softreset the sensor and also pressed the button once to reset - It then updates, but a day later its stopped again. I’ve had to do this 2 days in a row now… :frowning:

Big problems trying to pair the presence sensor

Thought it had done it yesterday, but never returned a battery status (I have tested with a meter , its 2.95 volts) and said ‘present’ regardless of whether I was or not.

The web API report no status or data, and the iOS app doesn’t show any battery voltage either.

I deleted, and rebooted and took the battery out then it did finally appear to pair as per instructions, I went through the ‘next’ options and then the iOS app crashed leaving a half complete device.

Deleted this and its - its currently stuck at ‘identifying a device’.

Am hoping its the coin battery, so out to buy a new one - but 2.95v seems fairly healthy to me.

Any clues not his one ?

S

No, I haven’t. I’ll try that if it happens again. However, I’m having other problems with the setup now and I’m starting to lose patience to be honest. I’ve bought £250 worth of hassle at the moment as NONE of my installed smartapps are working correctly now. It was all working fine until the presence sensors started to fail…

2 Likes

Update - new battery makes no difference.

Tried in another part of the house, away from the wifi router and no difference.

All the other things in the starter pack seem to be okay, feeding back temp, motion etc…

Looks like a software fault to me…

Im beginning to wonder if its a software or platform fault too. Neither of my sensors are working now - they’re both showing as present all the time, even when I’m away.

Mine stopped functioning again on Friday. Reset and re paired but always shows present and no battery reading either.

Can’t be a coincidence.
Maybe a duff batch given to some on the insiders trial.

Exactly the same for me - mine came from Currys, so presumably a production run - points to s/w

Hmmm…Looked at mine and you’re right, no battery reading on my two either.
Anyone from SmartThings Support able to comment on this and help resolve what looks like a platform issue??

Just put in another ticket, let’s see if there is a definitive resolution. At the moment it is more bother than it is worth.

I’ll add my name to this one, new to ST and my sensor was working for a few days but sometime over the last week it is always present. Tried all the resets as above but still get nothing. Similar that I do not get a battery reading from it either.

Annoying thing is I could get away with it except due to another SmartThings bug I cannot use a second iPhone as a presence sensor :frowning:

Just to add, tried removing the battery and it made no difference. Deleted the tag, removed the battery, re-paired and again, no difference. It detects the tags but its effectively dead - doesn’t register any events (always shows present regardless) and no battery reading either.
Seems to be quite a widespread problem but the silence is deafening :frowning:

Can confirm I am affected by the same thing… Quiet annoying.

Support regularly receives presence tag pairing failure reports from customers, but the are a couple things going on:

  1. The presence sensors did not get the same hardware level refresh as the other devices, and are a bit more sensitive to timing, etc during the pairing process. Additionally, they are super subject to range and interference. If they have an incomplete pairing out of the box, while near the Hub, gently remove the battery>put it back in>tap the button once - this should reconfigure it.
  2. As part of our QA process, we test a lot of inbound devices that customers report are not working. We definitely come across issues with devices (and the customer is almost, always, usually right), but the presence sensors often seem to work when they hit our workbench. Therefore, we want to be super sure before replacing the sensors.
  3. There seems to be a regression in the app where tags are pairing in the background. Usually the tag will implement a correct handshake shortly thereafter
  4. Confirm you are getting the same error when pairing using Marketplace>Connect New Device and Marketplace>Coming and Going>Presence Tag>Connect Now

If you are stillllllll having issues, check in with support@smartthings.co.uk as they may have an update for your Hub or some other troubleshooting tips before replacing.

@Aaron

Zigbee Presence Sensors Work By Checking In every Minute or So

A presence sensor which was always “away” or one which kept bouncing between being “away” and “present” could easily represent any of the issues you describe with range, interference, or an incomplete pairing.

And if presence is based on GPS, as with a mobile phone, reporting can come from the wrong location sometimes.

However, a zigbee presence sensor which is always reported as “present” is something else again. That would typically represent a failure on the cloud side, not the device. It’s not based on “where I saw you last” reporting as GPS is. It’s a direct connection to the ST Hub at the home.

A zigbee connection can be lost due to interference, just as turning on the microwave might cause Netflix to buffer. But it can’t be falsely maintained through any of the factors you listed. The arrival sensor doesn’t check out when it leaves. Instead, the cloud account notes repeated failures to check in locally as the sign that the device is “away.”

There’s No “Check Out” Signal to be Lost in the First Place

So either the hub isn’t passing along the check-in information to the cloud or the cloud isn’t recording/processing it correctly, but honestly I don’t see how the sensor itself could contribute to a sustained false positive. Sustained false negative, sure–if the sensor can’t maintain enough power to check in regularly, it eventually gets marked as “away” when it’s really home.

"Teleportation’ between “away” and “home,” sure–the device isn’t checking in properly or there’s interference.

But sustained false positive for hours or days? There’s nothing the Zigbee sensor itself can do to cause that. (A GPS based device can, but not the Zigbee device.)

Resetting the battery in this cases is likely forcing the cloud account to resynch as well.

If It’s Really a Sustained False Positive on the Zigbee Presence Sensor, That’s Very Odd

Make sure the engineers know that what’s being reported in this thread is nothing to do with GPS devices or bounce or false away statuses.

It’s a zigbee presence sensor being falsely reported as present for hours at a time. And multiple people reporting that things were OK and then the error started happening. And some reports of two in one home failing at the same time.

This just doesn’t fit “the usual suspects” for a presence detection error. If these were mobile phones, sure–GPS-based devices can do that. But the Zigbee device just doesn’t have a local protocol that should fail in that particular way. It really sounds like something else is going on.

Submitted with respect.

2 Likes

Just to +1 this, I have exactly the same problem. Removing and re-pairing makes no difference. The pairing process seems to go smoothly, but the presence is absolutely always “Present” regardless of where the sensor is.

Since I bought the starter kit and other devices the presence sensor has failed to work. I can pair it and it reports as present the first time. However, as soon as it goes out of the hub’s range and gives not present, that is where it stays. If I try and delete it from the app, clear out any routines that use it and reset the sensor, it always seems to re-pair without any further intervention. That suggests it hasn’t been completely deleted from the hub. I have given up on it and I’m not far of giving up on ST. It’s so unreliable, I can’t believe it.

Does Life360 work in the UK? Or is there an Oath issue for that as well? If it works, I would use that for a presence sensor.