Presence sensor from Classic App to new app

I have not yet migrated to the new app.

I have multiple automations using phones as presence sensors.

I notice when I log in to the new app, in my automations, the presence sensors are there in the automations themselves. They must have already transferred over. However I do not see the individual presence sensors under things.

Will the automations using presence sensors run without issue after the Classic app is gone? Anything I need to do?

Yup, and it drives me crazy not being able to see these. I have no idea why ST did that.

So far mine have been fine, and I manually migrated many months ago. I have several automations based on mobile presence devices.

The only thing I’d recommend you do is just test, test, and do more testing.

1 Like

So I’m assuming that I need to select “Get your location from this phone” under settings in the new app and this translates to allowing location usage for the presence sensors that are already setup but we can no longer see? Lol

Yeah, weird I know. Sorry for the delayed reply. To be safe, and I don’t know if this is possible after being migrated automatically vs. the way I did it; I’d remove your mobile presence devices from Classic and then enable that setting in the new app. ST’s migration process may have done that, but I can’t confirm. @jkp, do you recall or know if the automated migration process handles mobile presence properly?

Sorry, I do not know the answer.

Yea, I noticed I couldn’t find my phone as a presence sensor for either my phone or my wife’s. I enabled “get location from phone” and noticed it did create a new device (verified on the dev site)

1 Like

So, does the new app indicate presence? Or do I have to keep opening Classic to check it?

I have , finally after help ( wear a mask) here got my wife’s iphone up and running. If you use life360 it shows as a device. She doesnt like to use that app. So as a phone (which now works because she had locations off) they DO NOT SHOW which also drive me crazy because I really want to see if it’s working correctly or not. It’s in the old app so youd think Samsung should fix this next update

I set up an automation to turn on some Arlo cameras when both people leave the house and turn off the cameras when both people arrive. The problem is that the automation acts like an “OR” rather than an “AND.” When one person leaves, the notification says that both people have left and the same when one person arrives. I constantly have to go to the Classic app to view who is present and who is away.
This is crazy.

1 Like

I use virtual switches for each of our phones and trigger them using automations.
For example:

Virutal Switch Name: SoandsoIsHome

Soandso Away Automation
IF This member isn’t at Home (Soandso’s Phone)
THEN SoandsoIsHome = Off

Soandso Home Automation
IF This member is at Home (Soandso’s Phone)
THEN SoandsoIsHome = On

My icons light up when Home and are grayed out when Away, just like a regular switch, so I can see rather quickly what the status of our presence is.

I actually use Life360 also and have integrated both it and our phones into virtual switches using the “All conditions” and “Any condition” of the IF statements of the automations… I use these virtual switches in my Leaving and Arriving automations instead of the actual presence sensors. Been doing this for a few months now with 100% reliability.

1 Like

How do you setup virtual switch for phone presence sensor in new app ?
also hopefully someone can help me here, couple weeks ago I ended up having 2 presence sensors but they belong to 1 physical pixel4 phone . one has my full name followed by pixel4 and the 2nd one just my first name followed by pixel4 .

Through the IDE… https://account.smartthings.com/login
Check this thread… FAQ: Creating a virtual Device
The thread strays a little off topic, but I think you’ll find the 2nd post most helpful.

There is also a SmartApp called Virtual Device Creator, but I honestly cannot remember if I set that up in the classic app or the new app one. You can check if it’s available in the new ST app by touching the 3 bars at the top left corner, touching SmartApps and touching the plus symbol at the top. There you will find a list of available SmartApps that you can set up.

Edit: There is an option in the IDE to use Simulated Presence Sensor as the type. I don’t know if this works or not… I just use the Virtual Switch type because it gives me the option to control the switch (by turning it off and on in the ST app) if my actual presence devices are not updating fast enough. I haven’t had to do that yet, but I can if I need to. I’m not sure if a Simulated Presence Sensor has that capability.

The full name followed by phone is your new app presence sensor. The first name followed by phone is the Classic app presence sensor. To avoid confusion, you may want to remove the Classic presence sensor. :slight_smile:

1 Like

You can use a simulated presence sensor to mimic the real new app presence sensor, and it will show up in the new app.

1 Like

If I have multiple users using the Classic app for the same hub (each user had a different log on), do they each need to migrate to the new app?

Can I just delete their presence sensor from the old app and then have them log in to the new app and start using or do they need to “migrate”?

Currently, there is only a migrate banner on my Classic app log in.

I just realized that. Thank you . it was driving me crazy

I agree about not seeing the presence sensor. I have been trying to find out if we can see them some how. I kept the classic app just for that.