Preferences - hidden / hideable not working for me


(Nick) #1

I’m a bit embarrassed I can’t get this to work, but I can’t seem to get the hideable / hidden section preferences to work. Here is my code

preferences {
    section("Sensors") {
        input(name: "switches", title: "Lights/Switches to turn on & off", type: "capability.switch", required: "false", multiple: "true")
        input(name: "motions_occupied", title: "Occupied Motion Sensors", type: "capability.motionSensor", required: "false", multiple: "true")
        input(name: "motions_edge", title: "Edge Motion Sensors", type: "capability.motionSensor", required: "false", multiple: "true")
	}
    section("Preferences") {
        input(name: "no_trigger_lights", title: "Disable lights/switches being triggered?", type: "bool" )
    }
    section(title: "Advanced", hideable: true, hidden: true) {
	input(name: "occupy_min_seconds", title: "How many seconds to wait for an occupy sensor to trigger before turning off lights? (Default 30)", type: "number", required: "false")
	input(name: "unoccupy_min_seconds", title: "How many seconds to wait for an occupy sensor to trigger before turning off lights? (Default 30)", type: "number", required: "false")
	input(name: "can_not_be_occupied", title: "Can't be occupied?  (on for hallways, stairs, etc..)", type: "bool" )      
    }
}

Yet I don’t see what I think I should in the actual preferences, seen below.

Any insights into what I’m doing wrong? Thanks! = )


(sidjohn1) #2

Your doing it right, but that looks to be a bug in the android version. i just tested it on IOS and android and it works on IOS and not on android with the latest clients.


(Nick) #3

Whew! Makes me feel much better. = )

Thanks!
-Nick


(Martin Verbeek) #4

Are these options now working for Android? i still see the same issue…