Post Requests for Edge Drivers Here (community-created)

Double the vote here. I have 4 Haiku fans I’ve been wanting integrated in my house for over 5 years.

Edge is not for SmartApps. In a smartthings, context, edge is for things that run on the hub, which means edge drivers that are replacements for the old DTHs and some of the official smartthings features for automations. But no method is provided To allow you to run custom app code on the hub.

So, as others have said, a big part of the issue is that you have to find your own way to host that app code, whether it’s on a local server like a laptop or a raspberry pi or whether it’s at a hosting service like Amazon Web services. And even if you do set that up, it’s not necessarily going to be easy to share with other people.

It can definitely be done, @taustin did it for his MQTT project, but it’s way more work and potentially more cost than the old smartapps, which were hosted for free in the Samsung Groovy cloud.

@Rafael_M also recently created a new endpoint smartapp as a replacement for a now obsolete, groovy smartapp. His GitHub has an excellent discussion of what he had to do to make it all work, and it’s not simple. But it’s a very good example of what can be done.

So there are no “edge smartapps.” There are “endpoint SmartApps” which communicate with the smartthings cloud through the REST API, but you still have to have your own place to host and run the code that decides when to communicate with smartthings, and what messages to send.

Some other platforms, including homeseer and hubitat, do let customers upload app code to that hub. But smartthings does not.

So I think that’s why you are not seeing a lot of people creating new endpoint smartapps right now. There are some, and sharptools is a very good thirdparty example, but most of the device manufacturers just don’t see the point in having to develop for yet another third-party system. They’d rather adopt matter and have one integration method that works with many different platforms.

2 Likes

Hi @csstup , is there an update on the Remotec ZFM-80 driver?

@JDRoberts this might need a little update. Now we have automations working local

It’s complicated, because Samsung has never been very consistent with its Terminology, but that “automation” label is referring to the category of automations that includes endpoint smartapps and webhook smartapps, which is what those two icons are for. And neither of those run locally.

You’re absolutely right that there are other automations that do run on the hub if you count routines, and some of the official feature smart apps, like the new smartlighting , but those just aren’t shown on the diagram.

It’s an official diagram, so I don’t want to change it, but it would be good if it was updated eventually.

1 Like

@Kraftwerx – stumbled upon this while trying to solve my path – it might be useful to check out this thread as well -
AEON Power Strip Binding just stopped working (presumably because groovy)

In the end, I was able to get things working with the default ST Edge driver, combined with (vEdge Creator and the new Smart Lighting App),

1 Like

Hey Everyone! There used to be a smartapp for Ambient Weather - Personal Weather Stations. Wondering if we can get an Edge Driver that will support AW.
On their website it looks like they might be looking for someone to work with to create it.
Thanks!

https://ambientweather.com/faqs/question/view/id/1884/

2 Likes

Edge on a hub is sandboxed to only allow network connections to devices on the local LAN. It can’t talk to an API on the internet (aka the cloud). You’d need an intermediary device/machine to do the communication to the ambientweather API and then get that data back into an Edge driver using various methods. You could do it via proxy, or some other protocol (http, mqtt, etc).

Or you could write a new SmartApp to do something similar, hosted on a local machine or cloud based engine (aws, some other cloud resource capable of running the SmartApp in the language/environment you chose to use).

My personal solution would be to run the AW stuff on Hubitat and use one of the replication tools
HubiThings Replica or Mira to reflect weather data back into ST. But I run both environments…

2 Likes

A tomada com medição de consumo não está reconhecendo nenhuma driver. no driver recognizes. @Mariano_Colmenarejo . segue dados

Hi, any recommended Edge driver for First Alert Smoke and CO detectors like one of mine below? TIA.

Data * networkSecurityLevel: ZWAVE_S2_FAILED

Raw Description zw:S type:0701 mfr:0138 prod:0001 model:0003 ver:11.00 zwv:6.07 lib:06 cc:5E,85,8E,59,55,86,72,5A,73,80,9F,71,84,70,6C

Current States
battery: 85 %
healthStatus:
DeviceWatch-Enroll:
checkInterval: 7320 s
DeviceWatch-DeviceStatus:
smoke: clear
carbonMonoxide: clear

It looks like you got it paired. Is the device working? If it works I would not worry about S2 failed.

Has anyone looked into making an edge driver for a DLNA device, like the Fabriq speaker? There was an app in the past Media Renderer Events that let me use TTS to announce things like contact status changes.

2 Likes

I have 3 of these smoke detectors. Two of them are still currently working and have been for the past few years but the 3rd one failed in past few weeks. I have tried deleting that 3rd unit but now can’t add it as new device in the app. Thinking it maybe an older signature issue. Is there a live logging like in the old days to find that raw description of that unit to see if I can manually add it in IDE?

Did you exclude it? These are Z-Wave devices and they need to be excluded before they can be paired.

In mobile app - open hub tile - 3 dots - settings - Z-Wave utilities - Z-Wave exclusion. Then follow manufacturer’s exclusion procedure for your device.

2 Likes

The IDE is being shut down along with the old architecture. You can no longer use it for anything except some read only options to get information. But you cannot manually add devices or smartapps through the IDE anymore.

Life after the IDE: Questions and Answers

No, I didn’t exclude the 3rd smoke detector when deleting it. Odd, I don’t have any “hub” tile in my mobile app or at least I can’t find it. I can see the hub and execute Z-Wave exclusion in IDE for “My Hubs”.

Look for the hub in no room assigned.

IDE might still work but is being shut down so you should learn how to do it in the app.

Look in All Devices

1 Like

Hello, you were able to solve the problem with this device, I couldn’t use the virtual device anymore to manage the two lights independently. I’ve searched everywhere and can’t find a way to fix it. Thanks.

Thanks for letting me know I can’t manually re-add deleted devices via IDE. Oh well, I guess 2 of 3 smoke detectors still working post Groovy migrations is better than nothing unless I can somehow get that 3rd unit back online for monitoring. All 3 detectors still work together as they are wirelessly connected to each other except I won’t get any automation via ST.

1 Like