Post Requests for Edge Drivers Here (community-created)

This device requires HAIL support for the hub to see changes made to the switch at the device, which the stock Edge drivers no longer support. Using HAIL was Leviton’s Zwave (non plus) workaround for the Lutron patent that is now expired. You could also get around the patent by hubs polling the device, which also sucked for other reasons.

I don’t know why the on/off feature isn’t working as it should just be a regular binary zwave update. But the hail issue makes it not worth figuring out.

My suggestion is to replace it with a newer zwave plus device. You’ll get much better performance than trying to work around zwave 300 series implementation issues.

1 Like

Thanks for the suggestion, will look into this
Cheers!

1 Like

Thanks for the explanation. Part of the issue is that I utilize the dimmer with a magnetic low voltage dimmer appliance, and a lot of the Z wave dimmers available are triac dimmers that are not compatible. It looks like the Eaton RF9640-NDW works with magnetic low voltage dimmers so I’ll give that a shot.

1 Like

Has anyone had any luck getting the Smarter Ikettle 3.0 working?
Their customer support said they would look into it years ago. It seem now however they have no interest in smartthings

I currently use Alexa Iftt and virtual switches but direct SmartThings would be great

Thanks

1 Like

I have the Hampton Bays Fan Controler (King of Fans Zigbee Fan Controller). They stopped responding although both appear online in both google home and smartthings. I see several requests for an edge driver, but couldn’t find that it has been handled. Sorry if this is a duplicate request for something resolved, but I would appreciate being pointed in the right direction. Thanks!

2 Likes

I was looking to see if someone with experience can update this groovy app for twinkly smart Christmas lights to the new edge drivers. Attached is the link to the form , and one of the last entries was a GitHub update for the current work. I did a message on that form but have not received any updates since October, and it’s finally Christmas time, and I wanted to see if I could get it updated. Thanks in advance for the help. Twinkly Christmas Lights

2 Likes

Will your driver also work with “Asus Z-Wave Smoke Detector SHRM10000”?
It’s AFAIK a rebranded “Heiman HS1SA-Z Smoke Sensor”.
Works in ST Hub with “Z-Wave Smoke Alarm” generic driver (had to choose manually in IDE).
Raw description is:
zw:Ss2 type:0701 mfr:0403 prod:0002 model:0003 ver:3.01 zwv:5.03 lib:06 cc:5E,6C,55,9F sec:86,85,8E,59,72,5A,73,80,71,84

Hi @LLinke

Added to this driver version
Try if it works

─────────────────────────────────────────────────── 
 Name         Z-Wave Smoke Alarm-Mc
 Version      2022-11-26T15:55:09.731420425        
───────────────────────────────────────────────────
  - id: 0403/0002/0003
    deviceLabel: Asus Smoke SHRM10000
    manufacturerId: 0x0403
    productType: 0x0002
    productId: 0x0003
    deviceProfileName: smoke-battery
1 Like

I have a Fibaro FGK-101 (product type 0x0700), which I use with an external temperature probe (I don’t use the open/close function). I have tried the various edge drivers, and can’t seem to find any that work correctly for the temperature function of the probe. Maybe I’m missing somethings?
thanks

Hi @makrisn

If you install this driver it could works
Z-Wave Sensor and Child Thermostat Mc

This is the driver channel

Hi @Mariano_Colmenarejo
thank you for the suggestion!
sadly, it doesn’t seem to work either (no temperature reading, and the contact sensor doesn’t register on/off status, also getting connecting error). When I then immediately switch back to the z-wave sensor (ST beta), the contact sensor is again functional, but obviously there is no option of a temperature reading, and no connecting error
I did try to take a picture of the error message, maybe that could provide a clue, hoping it’s a bug that can be fixed?

thanks again

@makrisn

I don’t know how the device was paired with the driver.
If it was done with a driver change from the stock driver it is normal that it does not work.

To get it to work with the temperature profile you have to drop and re-pair directly with this driver.

In Zwave drivers, the configuration is not sent when changing from one driver to another driver to respect the custom configuration that could have been done with another driver. (zwave device config Mc, for example)

This has its advantages and disadvantages.

Try to exclude it and make it pair directly with this driver, there are other users who use it and it worked for them, that’s why there is this temperature option in the driver.
You may need to remove the stock driver from your hub.

These are things to polish in the new edge architecture.

Hi @5spot
Added preference and profile to show temperature in the tile in this driver version. Default option is open/close sensor
You need clear app memory cache the first time you change the profile

───────────────────────────────────────────────────
 Name         Z-Wave Sensor Mc
 Version      2022-10-29T19:03:15.341030072
───────────────────────────────────────────────────

@makrisn You can try this driver that Mariano created. I use this with my Fibaro FGK-101 sensors with external temperature probes. I believe he has added prod code 0700 and 0701 to the driver.

Hi @Mariano_Colmenarejo : first, I really appreciate all the good work !

I was able to exclude it (and also did a reset of the fibaro FGK-101 to clean the EPROM memory for good measure.
It repaired to the Z -Wave Sensor and Child Thermostat Mc directly, but… no luck, same issue

I see it has worked for some users. When reading thru the community posts, my issues seem very similar to what @alefavara experienced. maybe it’s tied to product 0700?

thanks again

JD and friends first of all thx for the great work you are doing in this community. I also have a request and that is for an edge driver for the EVR_AD1472 which is also known as the nexa AD147-2 dimmer switch. I know this has been sold widely so a lot of people will be looking for an edge driver. Up to know I have been using the DTH: [ smartthings : Dimmer Switch Nexa
https://graph-eu01-euwest1.api.smartthings.com/ide/device/editor/453d20e9-e0f0-4869-990f-c9fa1f9c57ed

fingerprint mfr: “0060”, prod: “0003”, model: “0003”, deviceJoinName: “Nexa Dimmer Switch”

Could anyone tell me if there is a matching device driver or could it be added to an existing one?

Thx in advance

Fred

Hi @makrisn

The firmware version may be older and the parameters are different.
I made some changes in this version if you want to try

────────────────────────────────────────────────────
 Name         Z-Wave Sensor and Child Thermostat Mc
 Version      2022-11-27T18:02:33.964999331
────────────────────────────────────────────────────
1 Like

thanks @Mariano_Colmenarejo. It seems we are moving in the right direction with this version… however, still no temperature readings or contact readings.
On the flip side, the connection problem message is now gone, and the settings are starting to work a bit better (I can create the virtual thermostat device for example, which never worked before)

Let me know if I should just give up on this older hardware; like you said, it’s probably on older firmware.
thanks again
cheers

Hi @makrisn

I have made a version that manages the temperature manually for fibaro open/close devices.

It would be necessary to obtain the pairing logs of the device with the driver, to see what response it sends to the configuration parameters sent.

This is a tutorial on how to install the CLI and get the logs in windows.

────────────────────────────────────────────────────
 Name         Z-Wave Sensor and Child Thermostat Mc 
 Version      2022-11-29T11:56:36.797070423
────────────────────────────────────────────────────

Hi @makrisn

In these logs it can be seen that the sensor is interrogated to send the temperature and there is no response from the device.

It would be necessary to uninstall the device.

Open a window with the CLI ready to capture the driver logs

Install device and capture device pairing logs