Please Help! Z-wave devices stop working after a few minutes

I’ve been in contact with support through e-mail, but I figured maybe you guys have some more ideas. I was a bit disappointed that I didn’t hear from them today. Any help would be appreciated.

The problem:
I have no control over Z-wave devices. If i reboot the hub, i can toggle them for a few minutes, then they stop responding again. The devices do not fall off the network, and still report status if i use physical toggles on them (like locks or duplex outlets). Zigbee devices work perfectly as they always have.

What i’ve tried:
1 rebooting the hub (physical battery and power cut)
2 reinstalling the smartthings app on my phone
3 repairing the z-wave network

Special notes:
When I do a live log in the IDE and try to toggle the z-wave devices via the smartapp once they stop responding, there are no event entries for them. Zigbee devices show event entries as normal. It’s as if no commands are being sent by the hub for z-wave. Reinstalling the app didn’t alleviate this, but even if it was an app problem, z-wave devices should have triggered based on time and motion (smartlighting app).

The only non-official apps I have installed are webCoRE and CoRE, trendsetter, and action tiles.

I’m really stuck, and it sucks rebooting my hub just to gain control of several devices for a few minutes. :frowning:

Thank you

Are you on version 18.18? If so, it’s a mess.

Same problem here. I’m not on 18.18 though. Do you by chance have CT100 thermostats? I noticed the device handler for those was updated when all the craziness started:

I wonder if a change to that device has caused problems for other zwave devices on the network. I’m going to try rolling back the device handler for my thermostats to the previous version to override their upstream changes and see if that makes a difference. I contacted support this morning and got the typical “Delete your thermostat and add it back” suggestion, despite the fact the problem effects all of my zwave devices. I never heard back after that. I pointed them at the device change in their github in the hopes that my problem would be directed to someone more in the know.


1 Like

I do have that thermostat!

I’m not on 18.18 either.

I only use it for heat, and we’re mid summer, so I’ll try just disconnecting this sucker to see if everything pops back to normal.

about 25 minutes later and we’re still good!

I’ll report back before i go to sleep. If z-wave remains functional that long, I think i’m in the clear.


Unfortunately, z-wave stopped functioning again :frowning:

Did you just disconnect the device or did you remove the device from SmartThings? I asked because I just tried making a custom device handler using the previous version of the CT100 code from here:

and then I changed my thermostats to use that instead and that seems to have solved the problem for me. My thermostats are back to working properly as are my other zwave devices. If you just disconnected it but left the device in SmartThings it may still be introducing bad mojo onto the network.


Note: I also power cycled my hub at one point because it wasn’t responding to the reboot command from the website. I’m not sure if that’s necessary after changing the device types to bring the zwave network back into better shape. I don’t think it matters, but I’m just throwing that out there since I did that as well.

Robert, you were right. I needed to changed the device handler, too.

I’ve had this going since last night and everything still worked in the morning! I was able to turn on my coffee before getting out of bed.

Thanks for solving my issue.

My CT100 has been unreliable for some time (setting desired temperature with WebCore not working consistently, etc). When I came across your post, I realized it’s probably been since I noticed the interface change for the device in the SmartThings app. I setup a device handler with the code here that @flemming posted (I named it CT100 Thermostat_Orig, went into and swapped the CT100 handler to this one and it’s working again. Thanks!