Platform Update - Release Notes - 10/20/2015


  • Fix Web UI showing inaccurate alarm system status for locations
  • Fix multi attribute tiles for IDE


  • Allow sending of push messages from SmartApp installed/updated/uninstalled method


  • Fix setting custom icons on multi-attribute tiles

Any update with regards to adding multiple accounts? This is a still a significant shortfall with v2 hub. Most of the routines and logics for me rely on presence status and it’s been really frustrating to not have this capability and it’s been almost two months now without any clear updates from ST. I’ve been in constant communication with ST support about this issue but haven’t received any concrete timelines on when this will be fixed. Thx.


What was the problem with multiAttribute tiles? I was hoping the issue with SECONDARY_CONTROL on Android would be fixed, but nope.
See Migration to V2 - Hurdles and Best Practices
and Migration to V2 - Hurdles and Best Practices.

Oh, and let’s not forget about the total stability of the Android App… I don’t worry about it consuming resources cause I’m going to be killing it within a couple of minutes anyway.

New feature introduced in this version?

I am now seeing this in Live Logging for the groovestream smartapp now.

error OK @ line 134

Anyone else seeing this?

I second this inquiry.

You guys also fixed the “gentle wake” smartapp or whatever it was causing it to completely fail on V2 hubs.

As of this morning Gentle wake worked for the first time since the V2 hub came out.


@Timgray I’ve had the gentle wakeup smartapp going since I received the V2 hub, and it failed for me yesterday and today for the first time lol.

I went in and made a few fake changes to see if it would reset something, and my hope is that it works (the test works again, so thats a start)

Mine failed for the first time yesterday. I did the same thing. I did find some of my routines were corrupted and had to be rebuilt…

It was nothing major but I had nothing working yesterday. I fixed the routines and rebooted the entire system.

My problem came from the upgrade.

All is working good now.

1 Like

That’s nuts as mine has not worked since I upgraded to a V2 hub, and have had tech support working on it for 2 weeks. that it was working for you tells me that the whole platform is unstable and they cant figure out why it works for some and not others.

Here’s to hoping they fix all the random failures that even their tech support cant nail down.

1 Like

That is really weird.
Will you post a screen shot of one of your routines that isn’t working?

Did the repair Z network function get removed? I can not longer access it from the App or web…also, as of right now I cannot add new devices - I am testing but I have been adding devices daily and today is the first time that I am having problems…

I am seeing something along those lines as well… I have a SmartApp that posts energy readings to PlotWatt… Or Rather I should say I did… Since the “Upgrade” it no longer works. Every HTTP post fails with an Unauthorized exception… Nothing I have tried seems to fix the problems… It’s like the HTTP functionality is broken. I have bounced my hub, reinstalled the app, nothing…

I also had to reinitialize almost every app I had as they where not functioning properly. Most are working again, but it seems all of the applications that need to talk HTTP are broken or misbehaving… WEMO, Broken… Harmony, Broken… Etc… Though it seems to be contained to SmartApps, my integration to NEST is working, but that is a custom device.

FYI… I figured out the issue around HTTP Posts… Clearly something changed as the method I was using prior to the upgrade worked just fine… PlotWatt uses an API key for authentication, which is really just an HTTP Basic authorization with no password…

I was using the following to pass they key
def uri = "http://${apiKey}"

Since the upgrade this apparently no longer works… I had to make the following change

def headers = [:] 
def userpassascii = "${apiKey}:"
def userpass = "Basic " + userpassascii.encodeAsBase64().toString()
headers.put("Authorization", user pass)

Thought I would share in case anyone else is having the same issue…

1 Like

Not sure how or why…but all of a sudden the device was picked up…and the repair tool has re-appeared.

1 Like

ZigBee device pairing, no beueno…
@slagle @Tyler

generated during a call to enrollResponse
groovy.lang.GroovyRuntimeException: Ambiguous method overloading for method java.math.BigInteger#.
Cannot resolve which method to invoke for [null, class java.lang.Integer] due to overlapping prototypes between:
[class [I, int]
[class [B, int]
[class java.lang.String, int] @ line 309

device will not finish pairing, obviously…

what were you trying to pair? Looking into this…

1 Like

I had issues pairing the new Centralite motion sensors Lowe’s is selling under their Iris brand. I had to pair them and let them show up as "Thing"s, go into the IDE to change them to SmartSense Motion/Temperature, then rediscover them after a battery pull/button press reset to get them to work.

I depend on text to speech software, so I can’t read the code to tell if these are the same errors were different ones, but Multiple forum reports of different device type errors in previously working device types since the platform update

  1. hue bulb (official type)
  1. motion detector

  2. keypad

  1. harmony hub add failing
  1. plus the post errors reported above

  2. And my switch that showed as neither on nor off

Also, multiple reports of problems running zwave repairs

Regarding #1, I do not see any such exception after update. I migrated 23-24 bulbs with zero issues from old hue bridge to the newer HomeKit enabled one. The time it took was 15 minutes too. Hue connect showed 2 hue bridges. I deleted the old bridge identifying by the IP and made a DHCP reservation for the new one so that it doesn’t change across router reboots. Nothing else had to be changed and works as a champ.