Platform Update - Release Notes - 04/18/16


(Tim Slagle) #1

Short one again today. This push was purely backend improvements to help with our stability and reliability efforts.

Backend improvements

  • Fix NPE when trying to retrieve label from tile definition
  • Limit event name size to prevent Event index issues
  • This one doesn’t affect any event reads as this table is used internally and not for development related event subscription or event reads
  • This should help Cassandra

(Beckwith) #2

Was this yesterday as the title says?


(Tim Slagle) #3

It sure was.


#4

Keep up the momentum its much appreciated!!!


(Av8rdude) #5

I lost control of all z-wave devices this morning…reboot, zwave repair no luck. Coincidence?


(Carson Dallum) #6

I too lost control of about a third of my z-wave light switches this morning. When I run a network repair, I receive a ‘failed to update mesh info’ error for the affected switches. This includes a switch that is within a few feet of the hub, so range is not the issue.

I’ve submitted a ticket to support.


(Tim Slagle) #7

This was yesterday at 9am, so its just a coincidence. :slight_smile:


(Av8rdude) #8

Well, I am a kickstarter original with a rock solid system for several years. It stops working with no changes on my end? Coincidence…I think not. Either this is a hub failure at my house or a cloud issue.
After working with support to remove a z-wave device that was unplugged and not being used for 6 months my z-wave worked for a few minutes. Now it is dead again.
SmartHouse to DumbHouse for several days?


(Stuart Buchanan) #9

@av8rdude I have found that ST’s zwave implementation just doesn’t cope well if you unplug a repeating device. I have had similar issues where zwave stops working when a device is unplugged. Last time it happened. My son unplugged a device and it broke my setup completely and I didn’t make the connection that it was an off device. I would check that all your repeating devices are plugged in an operational. Make sure one hasn’t failed by manually actuating etc…

I have also learnt the hard way you cannot have any temporary zwave switches for Christmas lights etc… otherwise you need to leave the switches plugged in. I now use zigbee for temporary plugs.

This absolutely should not be there case as the zwave controller for the mesh network should mark the device as failed and the routing should change to circumvent the failed device… But I’m my experience this never happens on ST even when the device is down for three days.

I’ve also had completed zwave failures of my network when over polling Sonos or DNLA devices. The zwave network just grinds to a halt but everything else works. But last month this happened without over polling the network until i removed my sonos and DNLA devices even though i hadn’t changed anthing beforehand.


(John Miele) #10

I also lost control of a few ZWave devices. This is an ongoing issue. I takes a complete power down of my house, removal of all batteries in devices and hub to get it fixed. I havn’t had to remove any devices the last few times. I am trying to isolate what device is causing it and think it may be a CT-30 thermostat but havn’t confirmed it.


#11

I too have been having issue with a few devices would seems like lost control but really are just super laggy. I would take more than 15 seconds for lights to come on and off. I’ve since figured out that it was the ZWAVE module in my CT-30 that is messing up the network. Each time that happened, I would go and pull the ZWAVE module out and re-insert it. That fixed the problems every time. So now, i regularly pull the ZWAVE card out to try and prevent the issue :). Can you try to pull your CT-300 module next time to confirm?


(Av8rdude) #12

So what is the easiest way to troubleshoot this. I have a CT30 Z-wave module in my thermostat that is not part of my network and two instances of VLC thing using big talker. I suspect the VLCthing devices are the culprit because they were very intermittent always.
Should I remove those items, reboot the hub, rub some chicken bones together and hope it works?
I just hope the answer is not to exclude all my Z-wave stuff and rebuild…that is a huge task.


(Stuart Buchanan) #13

When i removed all my Music players i didnt even have to reboot. i just ran a Zwave repair and it worked for the first time in ages. but be warned i have also cleaned up my Zwave network which had a lot of orphaned devices (12 -13 total) by using a USB stick joined to ST as a secondary controller. this gave me a lot more visibility than is possible with the ST hub. they really really need better zwave troubleshooting tools…


(Carson Dallum) #14

What were you able to see with a z-wave USB stick? Curious what I could do to clean up my network since I’ve had some devices drop recently.


(Av8rdude) #15

Stuart,
I took your advice and removed my 2 VLC Things and DLNA device. I left my hub unplugged for 30 minutes. Then when I powered it back up everything worked. I’m not sure if the long reboot or the device removal fixed the z-wave network? I have been working with support and they suggested the long reboot and removal of some specific z-wave outlets. I did not remove the outlets instead wanting to try removal of the audio devices.
Thanks for all the detailed help. I plan to add back one of my VLC Thing (Raspberry Pi +BIg Talker) devices to see what happens.
Cheers,
Scott


(Av8rdude) #16

Stuart,
I spoke too soon. After working perfectly for a short period of time my z-wave network completely failed again. I have no ghost devices but I’ll start eliminating stuff to troubleshoot…frustrating after several years of stability.


(Stuart Buchanan) #17

@cdallum what you are able to see with a zwave usb stick are zwave devices that are no longer shown in ST but are actually still part of the zwave mesh network. It seems during zwabe device removal if the process of removal takes longer than 20 seconds to complete the ST platform kills the long running thread which leaves an orphaned zwave device. In my experience this is a pretty common occurance.

@av8rdude one thing you didn’t say In your reply was if you ran a zwave repair, did you do one? Did it complete without error? Can I ask how you are aware there are no orphaned zwave devices? Is it because support told you so? The devices don’t mark themselves as failed, and depending how many devices you have support won’t see them. I had 9 extra zwave devices on my mesh than in ST when first dealing with support and they didn’t see the issue at all!


#18

I cant do anything from app nothing is working. App not loading it is crashing. Cant turn on security lights or anything

It happened since 15 min.


(Alex Hart) #19

I also can’t use app or graph.api.smartthings.com from computer or phone on broadband or 4G starting sometime this evening (well after scheduled maintenance)

Update: started working within 30 minutes after posting.


#20

They did good job. I am getting the issues which i got few weeks back unable to arm shm. It keeps on spinning but nothing changes . It always shows disarm. But from smart tile it shows armed. I tested to see if motion detects but does not.


Android 2.1.3