Ping a local device

I’m wondering if anybody has got this working?

I have amended the code slightly to make it a switch. However the issue I have is that parse() is never called (I knwo this because the log.debug statement in it is never displayed in the log).

I am calling a Chromecast on port 8008. I’m wanting to detect if the TV is on and when it is the Chromecast is also on. If you connect to the Chromecast on port 8008 you get a 404 error. That’s absolutely fine. I don’t care about the result only that they are returned. I have also tried to connect to http://:8008/ssdp/device-desc.xml (by amending path in the HubAction) whcih responds with a page of info on the Chromecast. Again, no difference.

It seems that no matter what is returned by the HubAction parse() is simply not being called.

The device network ID is correct (IP and port in hex).

I recognise this code is quite old. But I also know the Smarthub should be able to do this so I don’t want to start using any other machines to do this (ie. Host Pinger).

Anybody help?

I’m trying to do this with an arduino, I can send GET requests to the arduino without problems but im not able to receive the response of the arduino. Does anyone have any idea how to do this?

Here you go…

I’ve got a radio link which keeps hanging, trying to use the http ping to power cycle a Smarthings outlet on the radio power line.
I’ve installed ping and set ip, I can see ping times in the logs but the contact sensor never shows open/ close- I was hoping to use this to just use a Smart Lighting rule or similar to turn off the outlet when ping fails, then turn it back on again after a minute.

Anyone have similar working? It’s so simple I don’t really want to mess about with Arduinos/ PI, etc

Hey Paul (Pauby), did you get this working? I am seeing the same problem you note here.

1 Like

Hello everyone,

Has anyone managed to make this device handler work?
It’s a very important function and I really need it … like many others I suppose.

thank you in advance

This DH works except for one tile…

    standardTile("ttl", "device.ttl", inactiveLabel: false, decoration: "flat") {
        state "ttl", label:'${ttl}'

Is showing a NULL value. I have tried everything to resolve this but so far I haven’t been successful. Help?



Tried that.