Phillips Hue New Hub - Echo Not Finding Anything

Anyone have the new Phillips Hue hub, my Amazon Echo is not discovering any of the bulbs. The echos worked perfectly with the older hub, but they can’t find anything on the new one.

I know this isn’t ST related but i figured someone might have fun into this on this forum.

Did you clear your connected home settings in Echo then rediscover after migrating?

Yea. I cleared my connect home settings in Echo a few times, and rebooted everything and still no go.

It detects SmartThings great, but not the new Hue Hub.

I believe thats the expected behavior with the new hub for the time being. Its designed for Homekit, not SmartThings. I recall seeing this posted somewhere on Philips documentation but I can’t recall exactly where i read it

Not so.

Insteon is designing separate hubs for each protocol, so they have a HomeKit specific model, etc.

In very sharp contrast, The new Phillips hub is truly multiprotocol. It will work with HomeKit, it will work with smart things, it will work with staples connect, it’s thread capable ( although that isn’t turned on yet) , it will work with harmony, and it will work via cloud to cloud with Many things.

What you may be thinking about is the integration in the other direction. If you use HomeKit with a Phillips hue bridge, you will only be able to control Hue brand bulbs with a Siri command. Not GE links or Crees. That was an Apple requirement.

So you cannot use the Hue bridge 2.0 to get homekit control of non-Hue devices. But you can still use non-HomeKit partner services to get control of the hue bulbs attached to the single hue bridge.

There is a completely separate issue right now that some echo customers are reporting that if they previously had a Phillips bridge Associated with their echo, and they get the new 2.0 HomeKit enabled Phillips bridge, echo is having some discovery problems.

Both Amazon and Philip have acknowledged this as a bug, and both say they’re working on it and expect a fix soon.

@JDRoberts Where did you find Amazon and Philips has acknowledged this ? I looked at both sites and couldn’t find where they had acknowledged it.

Support emails to a friend, so I can’t publish them. The weird thing is it doesn’t seem to affect everybody.

There are posts in the Amazon forums where people say Amazon support told them the same thing:

Nope…I had the same issue. I called Amazon’s Echo tech support, and they said they know it’s not working. They hadn’t been able to get an early version of the bridge to test, but they know now it needs to be fixed before anything will work. They have a “couple of engineers looking at now.” No ETA at this point when it’ll be fixed - at least according to the contact I spoke with last night.

@JDRoberts Thanks, I was looking but I wasn’t able to find anything. At least, I know that Amazon and Phillips are working on it.

I tried to discovery like 20 times, and thought I was losing my mind.

1 Like

Thats good to know. I thought they were releasing extended support down the road, almost like they were just trying to get it out the door ASAP.

I have an existing hue bridge, but seldom find myself needing to change the colors directly. I started out with several Hue bulbs, then decided the markup wasn’t worth it, so now I use dumb LED bulbs and smart switches where possible. My Hues are only for areas where I need granular control of lights.

Who would i email about this Amazon or Phillips?

I would start with Amazon since it’s their app that’s giving you the error message.

I’m having the same problem. The new Philips Hue bridge that’s Homekit Compatible doesn’t seem to support Echo. For that matter, I can’t seem to get it to work with Smarthings (v1 hub) either

SmartThings recognized the new Hue Bridge ONCE, but it failed to save the list of selected bulbs when pressing “Done”

Interestingly, the Hue Connect SmartApp was listed in the list of installed SmartApps on Graph.Api.Smartthings.com but it didn’t list any of the bulbs… But it wasn’t showing up on the iOS device at all.

I deleted it from the list of installed SmartApps on the web site, and now it won’t recognize the hub at all…
All attempts are futile.

-d

FWIW, you actually can use GE Link bulbs with HomeKit: you just have to delete them from your new Hue Hub and then re-add them. I’m running that setup now.

I also recommend the Home - Home Automation with HomeKit app by Matthias Hochgatterer: it’s a blatant $15 grab for money by writing the app that Apple should have, but it thus far has been rock solid and valuable in getting my HomeKit setup running. “Hey Siri, turn the Downstairs lights off” - I can do that now, no thanks to Apple or the Hue app devs. While on the one hand, it hurts me in my emotions to pay $15 for an app, when I think about how much money I’ve spent on home automation… total drop in the bucket.

I’m also completely unable to get my new Hub to respond to Smartthings, sadly, and given HomeKit’s glaring hardware shortcomings (no motion sensor, really?), that remains a bummer. But at least I don’t have to replace my el cheapo GE Link bulbs for basic voice control!

1 Like

Did you replace your new hub with the same IP address as the old hub. SmartThings has been working great with my hub.

No, it assigned itself a new IP address and I haven’t monkeyed with that. It does work, but it won’t rescan for new or moved bulbs.

The SmartThings integration only allows for one Hue hub to be connected per location. It probably thinks the old IP address is still that one.

If you write to support@smartthings.com they can help get rid of the “ghost.”

Nah, the smartapp found both the old and new hubs, and let me switch to the new one. The problem comes when I change bulb configuration: moving a colored bulb to my front porch for spooky Halloween effects, swapping out an old Lux bulb. The app detects the new bulb, but won’t save on the final page.

I can still control all the other lights: I just can’t change anything.