Philips hue running locally?

Hi !
I am struggling to get my Philips Hue to run on the SmartThings Hub.
I have a Hue Hub and i works perfectly, and I wanted to add as “connect to smartThings Hub” to get it to run locally.

Either way, it only gives me “cloud” version…

I have removed 2 lights and 1 sensor from the hue hub and installed it in SmartThings Hub only, all 3 goes into the hub, but the sensor say execution cloud, so if i have no internet it will not work… The lights work fine without internet.

Any suggestion?

more info:
what is the device type assigned to the sensor when connected directly to the ST hub?

With the bulbs/ights, the recommendation is to use the Hue bridge and connect to ST because they do not make for good repeaters.

1 Like

My first priority was to connect “hub to hub”, but it will not work… it connect the cloud way :frowning:

When I add the sensor to smartthings only I had to add a device handler:

In the device list i chose the device Hue Motion Sensor.

Do you remember if you clicked on the “Connect to SmartThings hub” button or the “Link Account” button. If you clicked on the latter, it would be Cloud execution as it would be using the cloud-to-cloud integration to Hue. Clicking on Connect to SmartThings hub would give you the local execution. I find the Add Screen for Philips hue to be slightly confusing at first.

For the sensor, you are using custom code for the Device Handler and that will always be cloud. It does not get loaded onto the hub.

There is an Edge Driver for the sensors you can try. Remove the sensor and then remove that custom code. Install the Edge driver and add your sensor back.

more info on Edge below:

1 Like

I clicked “connect to smarthings hub”. … but it gives me the cloud connect no matter what i click… I have tried both…

Edge Driver: I have never done that, I will try… but the best would be the connect via the hub to hub to work… I have MANY devices…

The Edge driver I pointed you to is for the sensor(s). Right now the motion sensors are not supported in the current Philips Hue integration.

For your Hue lights, I would recommend putting those back on the Hue bridge and connect it to the ST hub. Once done, provide the device type you are seeing in IDE for the lights/bulbs. It should, unless a change has taken place that I am not aware of, be showing “LAN HUE” at the beginning of the Device Type with Local execution.

Yes… I want them in the hue bridge… but my problem is that it will not connect “hub to hub”, even I click on it to do that…

I have sent a message to Philips Customer service… I hope they can help…

Thx for the help!

sorry, I did not get that from your earlier posts… my bad. Any error messages? First thing I would try is rebooting your router, give it a few minutes and try to Link the hue bridge to ST hub to see if that resolves the issue.

How are you determining your hue bulbs are running in the cloud? And are you getting some kind of error when trying to connect hub to hub?

Sorry about not getting back to you…

I got help from SmartThings customer service, and it fixed a lot of my problem:

Philips Hue can connect to SmartThings in two ways: Local Area Network (Philips Hue with SmartThings Hub) or Cloud-to-Cloud (Philips Hue without SmartThings Hub).

If you have a SmartThings Hub, we recommend connecting Philips Hue using the LAN integration (Philips Hue with SmartThings Hub). This connection will enable local processing for Philips Hue devices.

If the user does not have a SmartThings Hub, they will not have local processing but will gain the added benefit of being able to set up without purchasing additional equipment.

If connecting using a SmartThings Hub, confirm the Hue Bridge and SmartThings Hub are online and connected to the same network
For SmartThings Wifi: Plug the Hue Bridge directly into the SmartThings Wifi or Sub Hub
For SmartThings Hub: Connect the Hue Bridge and the SmartThings Hub directly to the same router – if the Hue Bridge is connected to the network through a switch, firewall, powerline adapter, etc., this may prevent the Hub and the Bridge from communicating
2. Check to make sure that all of the Philips Hue devices work in the Philips Hue app
3. Confirm the Hue Bridge firmware is up to date
In the Philips Hue app, navigate to Settings > Software Update
4. Reboot the Hue Bridge while the Hub is searching
After rebooting the Hue Bridge, wait until all the LEDs are lit then press the button on the Hue Bridge
5. Reboot the Hub and the Hue Bridge at the same time
After rebooting the Hue Bridge and the Hub, wait until the Hub is connected again and all the LEDs are lit, then press the button on the Hue Bridge.

After 4. all my lights got into the smartthings hub.

BUT: my sensors did not… Any suggestions??
I added philips hue on a cloud connection also, so no I have all light duplicated (one hub en one cloud version of each, and only 1 cloud version of my sensors). But the problem now is that I have another hub on another philips hue account; I have added hub to hub with no problem, but I can’t add another philips account… … or rather I don’t know how to do it…

1 Like

The sensors were added to the Hue cloud-to-cloud integration a couple of months ago. They are not available in the direct connection between your Hue bridge and ST hub on the Local Area Network.

1 Like


Any suggestion how to add another “philips hue cloud account”? I have 2 bridges, 1 account for each hub… the hub to hub worked with both, but the cloud connection to the second I am having problems with…

Sorry, I don’t have an answer on that.

If the sensors are on one Hue bridge, you can select that one in the cloud-to-cloud integration to get the sensors. If the sensors are on both bridges, I am back to i don’t know how to get two Hue bridges connected by the cloud-to-cloud integration. I have only used the local connection for multiple bridges.

I am confused about my Hue connections.
I guess I originally, years ago, linked accounts.
Then quite some months ago duplicates of (most?) Devices appeared, now including the Motion Sensor.
When I look in API browser+
1 the originals are shown as type VIPER and Manuf as Signify…
2 the more recent ones are shown as type “DTH” and ParentName as “Smartthings Hub” and Type Name of “LAN Hue Color Temperature” and Local Exectution as “Yes”.
However even simple routines (local st button [edge] turns on Hue “local” lamp) are not showing as local.
Additional question - how is a DTH connected lamp listed as local?

There have been some devices using DTHs that ran local since well before Edge Drivers were released.

That included a number of zwave and Zigbee devices using stock DTHs, but also a very few LAN devices with stock DTHs. That has always included the Philips Hue bridge and its connected smart bulbs. :sunglasses: :bulb: :bulb:.

However, in order for that to happen, you had to have both a hue bridge and a SmartThings/Aeotec hub. And the vast majority of SmartThings customers don’t have an ST hub. (They have a Samsung smart appliance or television.)

In order to allow hubless customs to use Hue, there also had to be a cloud to cloud integration. That’s the one now called “linked services.”

The features of the two integrations have sometimes varied. The cloud to cloud version included the motion sensor for a few months when the local LAN didn’t.

The local LAN integration only added the motion sensor a few months ago, so that’s probably when you started seeing it duplicated. :last_quarter_moon_with_face: :first_quarter_moon_with_face:

The system does allow you to use both integration versions if you want. Doing so doesn’t affect functionality, but it does create duplicate device entries for each device included in both integrations.

As far as what happens with the routines, that’s a separate question. :thinking: can you post a screenshot of the routine?

Did the LAN version add the motion sensor? The new Edge driver in Beta doesn’t have it and I wouldn’t think they updated the Groovy version with it retiring soon.

I think so, maybe I’m misremembering. :thinking:

There is a custom LAN edge driver for the hue bridge which has hue motion sensors in beta:

1 Like

One problem with being in Australia is that all replies to my queries come while I’m asleep!
Thanks for the detailed response.
Being a little more thorough, it appears that the Hue motion sensor is only on the Linked Service in my case (so that is why the routine is not local).
Will check out the Beta Hue LAN thread otherwise await ST’s edge version.

1 Like

Is it possible to connect hue bulbs direct to ST hub without going via the hue hub? I really only need basic on/off and dimming.

Technically possible, but not recommended by either company. It turns out that hue bulbs are not good Zigbee repeaters when connected to the smartthings hub, and they can damage the reliability of your Zigbee network.

The following FAQ is old, but still applies:

FAQ: Do I need the Hue Bridge/Hub to Use a Hue Bulb with SmartThings?