Philips hue running locally?

So I’m using Philips hue bridge and there I have Philips and IKEA bulbs and the Philips hub is added to Smartthings and it’s executed via cloud. So is there anyway to change it to locally? I know that I can add the bulbs to Smartthings without hub and then it will be locally but I’m using the Phillips Hue app.

Do you own a smartthings hub?

Yes, I do have a smartthings hub.

are you referring to the devices not appearing as Local in IDE under Local execution? Or Routines that use those devices not running as Local?

I believe you meant “with”

Yes, sorry my bad. And yes the devices are listed as cloud and I think that the routines are also running on cloud. There is some delay when a local motion sensor triggers a Philips cloud bulb.

I will ask one more question…

do you remember if you selected “Connect to SmartThings Hub” or “Link account” when setting up the hue bridge?

How funny: while typing this I receive an email from Hue on savings.

1 Like

Philips offers two different methods for integrating with SmartThings.

  1. Local LAN operation. This requires a smartthings hub. Follow the following directions:

  2. Cloud to cloud integration. This does not require a smartthings hub.

When you added the Philips hue bridge to your SmartThings account, you should have been given a choice, either “with a smartthings hub“ or “without a smartthings hub.”

If you want to switch to the other method, you have to remove the integration and then re-add the device.

Here are the official instructions for both methods:

this has changed :slight_smile:

Now: "Connect to SmartThings Hub” or “Link account”

1 Like

Oh, that’s clear…not. :face_with_raised_eyebrow:

agreed! took a few looks trying to figure it out with one in blue and the other gray.

1 Like

If you did set up a cloud cloud integration by mistake, you probably have to remove it from “linked services“, which I think is still under smartthings settings, but @jkp will know better than me.

Also, we should say that even if the device integration is local, that doesn’t automatically mean that a routine will be local, there are some routine options that can require the cloud as well.

1 Like

I don’t remember, but I think that I’ve added it by “connect to Smartthings” but without a hub, but I’m not sure because it was a couple of years ago…

sorry… one more question… in IDE, does the device type start with “LAN Hue”?

I don’t see “Lan Hue” only “placeholder”…

yep… that is a cloud-to-cloud connection. You will hate me but I believe you will need to remove the integration under Linked services (as mentioned by @JDRoberts above) for Hue and add it back as “Connect to SmartThings Hub” when adding Hue. Hate me because I have no clue how many devices and routines you may have. take screenshots of any routines or scenes before removing the intergration to make it easier to recreate them.

1 Like

Alright, thank you!!! Does that mean I will have to redo every routine again?

any routine or scene that contain those devices. take screenshots before removing

1 Like

Well… It needs to be done so I guess I will do this tomorrow. Thanks for the help!

1 Like

This is one way, of backing up routines. I have started using virtual devices as place holder for devices that I need to remove for switching from Groovy DTH to Edge drivers.
Create virtual device “Hue placeholder” with same capabilities and place it instead of real Hue device in Routines and Automations. You can even set all values, like level, color, etc.

Later just swap them back.

This post was flagged by the community and is temporarily hidden.