Peanut Plug with Smartthings? (DTH in post 35)

Ok, after further research, this is what I found out:

  1. I can put the Peanuts in pairing mode by pressing the pairing button for 10 seconds. The unit LED will blink red once. Then press the pairing button again and the unit will continuously blink red.

  2. In the ST Classic App, as soon as you try to Add a new Device, the Peanut LED will stop blinking.

  3. If I look in Hub Event list on the developer website, I see the following zbjoin event which tells me the Hub see the Peanut:

zbjoin: {“dni”:“713B”,“d”:“000D6F000534880B”,“capabilities”:“8E”,“endpoints”:[{“simple”:“01 0104 0000 00 08 0000 0001 0003 0004 0005 0006 0B04 0B05 09 0000 0001 0003 0004 0005 0006 0019 0B04 0B05”,“manufacturer”:“Securifi Ltd.”…

  1. However, I never see the device added. About 10-15 seconds later, I will see a catchall event. However, the Device Network ID looked to have changed.

catchall: 0104 0006 01 01 0000 00 C1D3 00 00 0000 0B 00 0BC1

  1. If I reset the unit again and try to pair it, I will see another zbjoin with the same Zigbee EUID but a different Device Network ID. I’m assuming this is because the device didn’t pair correctly.

  2. Look at the zbjoin data, the fingerprint data matches up with the DTH.

So, what going on here? BTW: I have a v2 Hub.


Success, at last.

I added , manufacturer: “Securifi Ltd.” to the fingerprint profile so now it reads:

fingerprint profileId: “0104”, inClusters: “0000, 0001, 0003, 0004, 0005, 0006, 0B04, 0B05”, outClusters: “0000, 0001, 0003, 0004, 0005, 0006, 0019, 0B04, 0B05”, manufacturer: “Securifi Ltd.”

Peanut was paired almost immediately. I hope that helps.

pakmanwg- You may want to update your code. Thank you for your work.



Excellent detective work! Will give it a try tomorrow, assuming I can edit the DTH correctly. Never done that before.

EDIT: Tried it tonight and it worked! Thank you, thank you! How did you figure out that is what you needed to do? Also, are you getting power monitoring? I am not, thought I was at first, but doesn’t look like it.

1 Like

Ahhh man, I been fighting this thing for so long tonight. I would have never figured that out if it wasn’t for you Doug. Thanks so much for posting that. It was driving me crazy.

No, I’m not getting power monitoring data so I assume we have the old version. Maybe someone will figure out how to updates these units without the Almond Hub. FYI: I bought them just to use them as repeaters.

As for figuring it out, I almost returned them but wanted to know if these units were even in pairing mode. The instructions do not tell you how they are supposed to act (LED). I was then tempted to buy a Zigbee USB stick to sniff the packets to see what was going on (I use Wireshark for my work at times). It wasn’t until I start watching the logs in the Smartthing developer website that I saw the zbjoin event. From there, I started Googling and learned some basic stuff about Smartthing and Zigbee pairing process. At this point, I was about to throw in the towel again since it all looked correct. As a last ditch effort, I added the extra “manufacturer” bit to the fingerprint profileID and whola, it worked. Sometimes, you get lucky. The good news is now i can use the same technique to add/troubleshoot other devices.

If this can help others, it was worth the effort, I know I was pulling my hair out.



Yes, if someone can figure out how to get power monitoring via either 1) update the peanut firmware without an Almond or 2) parse it out of the data stream some other way that would be awesome!

Right now, the only reliable plugs with power monitoring (that I have found) are the Centralite ones but they are 20-30$ each.

I’m back with another question… I recently bought a few more plugs and I bought an Almond+ router to update firmware. Power monitoring works fine in the ST app.

However, I’m trying to write a WebCoRE piston which ties power usage to a notification (end of cycle notification for Washing Machine and Dishwasher). WebCoRE can’t read the power info, apparently because the DTH uses a variable “powerValues”, and WebCoRE is only giving me their stock “power” attribute to poll.

Has anyone been able to get power monitoring to work with these plugs in WebCoRE? I know I’m talking to a small group since these plugs are still shipping with old firmware and most don’t have an almond router, but I know at least a few of you guys have updated them.

Any help?

Also, just as an FYI if you’re interested. I picked up a used Almond+ off Amazon for $50 and updated all of my plugs (up to 8 of them now). Updating was simple, and surprisingly, when I re-paired to ST, my plugs were recognized with the names I gave them in ST, and automatically reattached to the correct rooms and to any automations they were included in. Updating was REALLY easy. If anyone’s in the Salt Lake City area and wants to update plugs, I’d be happy to do it for you (or if you want to send them to me and pay for the postage).

I think this is the same issue I’m having with my Peanuts and laundry monitoring. I haven’t had the time to sit down and troubleshoot.

I had the same experience when I updated mine with an Almond+, I just got lucky and only paid ~$35 for it.

I saw a few on Ebay at about $35. I just figured rather than roll the dice on an ebay one, I’d get the Amazon return policy…

EDIT: Apparently I simply messed up my webcore code somehow. I created a new piston and it’s working fine. Comparing the two pistons, I don’t really see what I did wrong, but obviously there was something.

I have several of these (old firmware, Classic ST) and have had no trouble pairing or using them. They do not show energy usage.

They also report strangely to ST. They “flicker” off and on in the app, but IRL they stay on. Annoying, but better than an actual off/on flicker.

I updated my 2 peanuts to new firmware so I could monitor charging of my vehicles (120 v only). One of my Webcore routines checks if the car is plugged in when electric rates drop at night (and therefore the plug is scheduled to turn on). So just after it turns on, one if my pistons includes a condition: “If plugs power stays less than 1W for 15 seconds” then send me a notification that the car is going to bed hungry. Works fine.

Hi can you please post your Piston code. I am trying to do the same thing but cannot get mine to work.

Any news on if these can be updated without an almond plug?

Bump for any info if no almond router if can update for power monitor, even the new ones on amazon don’t ship with new firmware just bought recently (oct 2019).

Also, if we have one that is updated will it update the other plugs through Z-Wave? For some reason I have an option “update firmware” in smartthings IDE but it doesn’t seem to update it if available.

Many Thanks!

The Peanut plug is Zigbee not Z-Wave.

Ah got it, can Zigbee devices update each other?

No, it doesn’t work like that.

Sorry, haven’t logged onto ST forum for a minute, so I just saw your message. You can import my code using the import code 5ttv.

Bought a Peanut today after researching this device on this thread. Out of the box, the Peanut isn’t discoverable in the “Add a Thing” section (old app ftw). I even moved the device next to the ST v3 hub and tried to pair it, but nothing. I also tried to reset the pairing on the peanut, and also added the device handler to see if that made a different… but nothing.

Any advice anyone?

Update: I have the V3 Hub for SmartThings.

I have one Peanut Plug.

I have a vague recollection of having minor trouble getting it into pairing mode. But nothing troublesome enough to recall details. It’s using the stock Smart Power Outlet DTH.

Still having issues. Can not pair this peanut…

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.