Pairing Zfm-80 to smartthings

I have hooked up a zfm-80 wireless switch module to my gas fireplace. It works to turn the fireplace on and off. But I can’t get smartthings to see it and pair with it. I am guessing I am just not hitting the correct button press sequence. What do I need to be doing?

Try to exclude it first.

This is the process. Did you follow this?

Z-Wave Remote Control
Include or exclude the Fixture Switch Module from the existing ZWave
home control network with your primary controller.

  • Refer to your primary controller instructions to process the
    inclusion / exclusion setup procedure.
  • When prompted by your primary controller, click once on the
    PROG button or external switch.
  • The primary controller should indicate that the action was
    successful. If the controller indicates the action was
    unsuccessful, please repeat the procedure.
  • Once the Fixture Switch Module is part of the network, the
    same basic procedure is used to add the Fixture Switch
    Module to groups or scenes. Refer to the primary controller’s
    instructions for details.

I guess that’s what I am asking. What is the sequence to exclude it and then to include it?

I read those instructions from the manual but it seems like a lot of jargon. Primary controller? Does that mean the smartthings hub?
Here is what I have done:
Plugged in the zfm-80 after connecting all the wires.
Opened the smartthings app.
Tapped on “add things”.
When it is searching, I hit the button on the zfm-80 unit. It blinks for two seconds then stays lit up. My fireplace turns on. But I don’t get anything in the app.

I figured it out myself. I went into the smartthings app and in setting, then hub, z-wave utilities, general device exclusion. Once the hub was in exclusion mode, and the zfm-80 is off, I hit the button quickly 3 times then pressed and held the button for 5 seconds and released. The unit should be off now. I exited out of the exclusion mode then went into the app and tried to add the device like normal. Once it was searching, I hit the button once and it showed up in the app and I was able to add it. It works great now.

1 Like

Hey Jeremy, thanks for your explanation. I’ve just connected zfm-80 to the hub using your manual. Only one thing - it was enough to hit prog button on the relay one time and I got notification from the smartthings app that device was excluded

Worked for me - Thanks Jeremy!