Pairing a jiawen zigbee rgbw bulb to smartthings

I have a EU smartthings hub, but would suppose zigbee would be region independent. But, I have bought 2 jiawen zigbee rgbw bulbs (production name: k2 wireless bulb) and supposedly they should be recognized as Philips hue. No such luck. I have tried resetting them also. Anyone that have had success with these bulbs and smartthings, and if so, how did you get them to work? I tried the usual step of turning on the bulb and keeping it a few cm off the smartthings hub. These are the ones : http://s.aliexpress.com/zAriuQzM

Have you tried to pair them to the SmartThings hub or just Hue?

I don’t have a hue hub, because I thought it should be possible to pair
directly.

Being able to work with hue bridge (there is no “hue hub,” so I assume you meant the bridge device) is not the same thing as being “recognized as a hue bulb.”

The hue bridge uses the ZLL profile.

The SmartThings hub uses the ZHA profile.

Certified ZLL Devices are supposed to fall back to a ZHA profile, sometimes on a different endpoint, when joined to a ZHA coordinator. This is what a hue bulb will do.

However, non-certified devices may not have that capability, or may not implement a full set of command clusters.

So this is why there are some devices which can work with a hue bridge but will not work directly with the SmartThings hub.

Did the device pair as a thing? Or did it not join at all?

If it did pair as a thing, did you try changing the device type to a generic zigbee dimmer just to see if you can get on/off/dim control?

Thank you. The smartthings does not recognize it as a Thing. I also reset
the bulb (5 on/off), but it didn’t help.

What is the official distinction between a Hub and a Bridge? Is it the logic that they can execute or the hardware or some other things?

Warning: super technical network engineering explanation follows. But the short answer is just that it’s a bridge by definition. :sunglasses:

The longer answer:

A bridge (or gateway) converts requests in one protocol to that of another. The hue bridge is a Wi-Fi/ZLL Bridge. The bridge does not, however, “establish” the network. That is it does not assign network IDs to other devices that join to it or control which devices join.

Instead, because the hue bridge is a ZLL device, there is no establishing coordinator on its network.

IMG_4091

A ZigBee Light Link network has no ZigBee network coordinator, even a bridge device merely acts as a router {repeater}

So it’s a bridge per the definition of bridge in the ZLL specification.

The end devices don’t need the bridge in order to function as a network. And they don’t need the bridge’s permission to join. This is why you can use a Hue dimmer switch with Hue bulbs without ever having to have a bridge at all. :sunglasses:

A hub, in contrast, “establishes” a network in network engineering terms. It gives permission for each new node to join and in many protocols assigns a network ID. It owns the security keys.

No hub, no network for networks which are established by a hub.
If you have a Z wave smart bulb, and a Z wave button Device, The button device can’t talk to the Z wave smart bulb unless you also have a hub to create a network that both the bulb and the button device will join. Once both have joined the network you may be able to set up direct communication between them (Z wave direct Association) but you had to have the hub to set up the network in the first place and hand out the network addresses to each device.

I know, boring. :stuck_out_tongue_winking_eye: Which is why no one cares about this but me and some of the other network engineering people who are community members.

But the reason the Hue device says “bridge” on the box is because by definition it is a bridge. It’s not a hub.

2 Likes

Thorough and informative as always. I remember in the pre-home network days, that these terms were much more prevalent. Hub, switch, router, etc. Now, that stuff is all bundled up in to the “router” we all just plug into our cable modem. In some cases, the modem is even bundled up into one Frankendevice too.
The HA stuff still seems to be a bit more fragmented still. Thanks for the refresher.

1 Like

If it’s not recognized as a thing, you won’t be able to use it directly with SmartThings. :disappointed_relieved:

Since the product description says that it will work with hue bridge, you could try to find a generation one hue bridge ( just because it should be less expensive than the current generation) and see if it will work with that. If it does, then you could use the official SmartThings/hue bridge integration and get control of the bulbs that way.

Thanks again. It seems that a 1 gen bridge :wink:is the way to go.

1 Like

So you got the Hue bridge to recognize these bulbs? How do you like them? They are quite a bit cheaper than Hue or most other RGBW bulbs. If they work well, that’s a nice score.

1 Like

I’m trying to get hold of a bridge, and will report back once I know more.
Must have them up an running before Halloween…

1 Like

These bulbs do work fine with the Hue hub (I have a gen 1 hub) but I cannot get them to pair directly to SmartThings. The Bulb has some printing on it which says “Compliance with Zigbee Light Link ZHA1.2”

Looking at the stored data in the Hue hub:

“modelid”:"FB56-ZCW08KU1.1"
“manufacturername”:"Feibit Inc co. "
“uniqueid”:“00:12:4b:00:11:e8:18:4a-0b”
“swversion”:“1.0.2”

My second bulb is:
“uniqueid”:“00:12:4b:00:14:af:97:cc-0b”

Looking up the model ID, I found another thread talking about these bulbs:

Seems there is just no way to get them to talk to the ST directly. Requires Hue Integration … This sucks. I’m trying to eliminate my Hue Hub really to reduce the number of possible issues I have controlling things, etc… plus the slowness from the extra hub.

Hi, it seems it’s been a while since anyone’s been active in this thread.
Anyway a few days ago I bought the very same bulb, yet it actually pairs fine with an ST v2 hub. It even identifies as a standard ‘ZigBee RGBW Bulb’ when added. This is the bulb

In the ST IDE the bulbs identifiy as:

  • application: 01
  • endpointId: 0B
  • manufacturer: Feibit Inc co.
  • model: FB56-ZCW08KU1.1

However I’m experiencing something weird. It seems that the bulb somehow forgets how to turn off. I am not quite sure what triggers the behavior, yet after it occurs, once you try to turn off the bulb from the SmartThings Classic app, it only dips in light level. Only way to restore it to normal operation is to cut the power from the bulb at the wall switch. Also, I think this bulb is supposed to dim yet that command seems to have no effect. Let me just repeat. I have two bulbs and they behave exactly the same at the same time, which leads me to think it’s not defective hardware but rather a software issue.

Anyone seen similar behavior with this bulb, or better yet tweaked a DHT to make it behave?

Thanks,
Max

The 2 I have identify as a thing and then I have to change the type to zigbee rgbw bulb. I’ve found that changing the brightness has no effect other than that is what will then prevent them from turning off. The 2 I have work until you try to change the brightness (which for some reason defaults to 88%). Soon as you do that they’re on until you physically turn them off. My guess is that they need a device handler but thats beyond my skillset.

I have two of these paired and they work fine. But, they are paired via the Philips hue bridge. In smartthings IDE they are identified as LAN Hue Extended Color. I was unable to pair them directly to the smartthings hub and bought a cheap generation 1 Philips hue bridge. Now dimming and colour works fine.