Outlet (UK) connects, but plugged in device not working

After a frustrating period of pairing the plug, I finally got it working! (Turns out I had to press the button on the OTHER side of the plug!)

So, I can now remote control it, but devices plugged into it are not getting any power… any tips?

I’ve tried a kettle and a Christmas tree…

I had the same issue. Some plugs dont make a good connection. Try wiggling the plug that goes into the socket. Sounds weird but thats bets i could figure it out.

Jeez… I had to wiggle both outlet and plugged in device and barely managed to get it to work!

Unbelievable… at least it sort of works, but pretty shoddy quality…

I know right, I think the problem is the quality of the plug going in. I had the issue with extension leads, so the cheap ones are an issue but my expensive ones are no problem.

You mean what you were plugging the outlet into? I’ve tried an extension cord first, but when raising this it was plugged directly into the wall and still had to wiggle it carefully…

I’m hoping to…

  • plug Outlet into wall
  • plug 2-way socket cube into it
  • plug 2x Christmas tree lights into that

Do you think that would work? Can we plug an extension lead / splitter into the outlet?

I plug and extension lead/splitter into my outlet. This then turn off my TV/Audio/Sky/FireTV all in one hit.

1 Like