Outlet Switch keeps losing connection


(d) #1

Hi, I started with a basic Smart Things set, the hub and one plug-in outlet switch. Set up was a breeze, as was integrating with Amazon Alexa. I have the outlet switch hooked up to a lamp and I can issue verbal commands to alexa to turn the lamp on/off. But the problem is that the wall switch keeps getting disconnected from wifi. I tell Alexa to tun it on and she states that she is unable to connect to the device. IF I unplug the outlet switch and then plug it back in it starts working again, and continues to work for a time. But usually when I try again the next day the same thing happens. I don’t think it is a router problem, no other wifi clients seem to experience the issue. The switch is on the far side of the house from the router, but laptops work at this distance. IF the distance was causing a disconnect, then why does it immediately work again once I unplug/plug back in?
Anyone else experience this?
Router is Archer c7 router. Thanks


#2

I’m sure that’s very frustrating. First, as far as troubleshooting the connection, that plug uses zigbee, not WiFi.

In fact, strong WiFi can drown out zigbee, so often the stronger your Wi-Fi, the worse your zigbee connection will be.

How far is it from your hub?

How far is it from the nearest Wi-Fi router or access point?

How far is the hub from your Wi-Fi router?

Ideally you would like your smartthings hub at least 10 feet from your Wi-Fi router, and The plug even a little further, 12 to 15 feet.

Support can also help you check the channels on your Wi-Fi and your smart things zigbee coordinator to see if they might be overlapping.

We were just discussing exactly the same issue last week in an Alexa thread, at least you’re not alone.


(d) #3

The hub sits right next to the router. but the switch is on the other side of the house, well past 20 feet away. So moving the hub father from the router (and closer to the switch) might help?


#4

Yes, moving the hub away from the router might indeed help. It’s certainly worth a try. :sunglasses:


#5

For what it’s worth, I’ve done quite a bit of experimenting. I’ve changed the position of things several times including moving the SmartThings hub as far as 30 feet away from the router (but very close to the Zigbee device). In each case, I tried accessing the switch (through Alexa) several time over a two or three day period. On August 15th, there was a hub update that was supposed to resolve some Zigbee issues, so I tried various placements again. The update made no difference. From what I can see, the probability of accessing the Zigbee switch through Alexa has no apparent correlation to the positioning of the hub and the router.


(Tim Johnson) #6

I am also having the exact same issue. I actually have two of these plugs. one never has a problem and the other has the problem every day. Like previous poster said. If you go into smartthings app and use it once it will continue to work for a while. Next day, it simple will not work with Alexa.


(Lee Higley) #7

Wow, I’ve been having this exact same issue since early/mid august. I use Alexa to turn off the smartthings outlet and every couple of days it says that the device is disconnect. resetting the outlet allows it to work for a day or two.


(Lauren “Milla”) #8

I’m also having the issue with two of my outlets, one cost to my hub, one across the house. Both were connected initially close range, like directed, and while I only need to press the reset button to turn them back on, not unplug and replug, it’s been frustrating that my automations won’t work due to being disconnected. The distance thing the above poster sounds like a crock though, they provide an Ethernet that’s maybe two feet at best, if they really wanted you to put the hub so far from the router, they’d have given a longer cable.
I’m hoping there’s a firmware update, can’t seem to find any answers as to possible causes


(Ray) #9

Maybe so but just in case you are not aware. Zigbee and WiFi are on the same frequency and if you don’t check. They could also be on the same channel. If you live in an apartment then you would know WiFi interference with same channel is real. It’s the reason why we want to use the 5ghz or change to the least used channel. As for the short cable. Most company ships out short cable. Pretty sure they could give you a 100 feet roll but yeah… That would be crazy and make little sense. I spent weeks with zigbee issue and I have close to 150 zigbee devices now so I can tell you WiFi or smart bulbs are brutal with zigbee mesh.


#10

Wow you go from 2 feet to 100 feet roll. We are talking about a longer distance from the router as recommended. I assume if they recommend at least 10 feet then they should send a 10 feet cable or not send it at all and advise you to get one. It’s just stupid to recommend 10f but they send you 2f, why? because the first step to troubleshoot the issue they tell you to make sure your ST is at least 10 or more feet. Just dumb


#11

It’s 2018 and the issue is still happening! But the problem is not SmartThings hub, it’s Alexa. If you do it from ST app or Leviton app it always responds. Just Alexa fails to reach it, even from the Alexa app you can’t control it.
Did you find any solution?
PS: it’s weird because Alexa doesn’t have any problem with any other brand of switches.


(Michael A) #12

Same problem … But with only one of three switches in thecsame room so placement ruled out by default. Fan controller fine, dimmer fine, light switch fails. ST hub sees and controls, Alexa integration is the problem. Works for a while, and works after turn on and off manually,or wirh ST app, but then Alexa stops working wirh it on the next try. Ready to rip all this so called smart crap out and send back to amazon as defective. Clearly the smart things industry is not smart yet and oversellind falsely as ready for prime time. Give it 5 more years and it might become more useful than frustrating.

Update. I just work with it some more, and the St communication as screwed up as well. that makes more sense cuz Samsung can’t even get its own devices to talk to each other right. ripping it all out and sending it back