Outlet not turning off

I may be doing this wrong… I am a new user!

I have 2 routines.

  1. Turn on outlet at 15:40hrs.
  2. Turn off outlet at 22:05hrs.

Both set to run Mon - Sun with no other triggers.

Routine 1 works ok.
2 not!

It seems to work about 50% of the time.

Any ideas?

What kind of outlet is it (make, model)? Are you consistently able to turn on/off the outlet via the ST App on your mobile phone?

The first Levinton outlet I installed would always turn on (via Mobile app or otherwise) but often fail to turn off. When I moved my hub right near the outlet all was well all the time. When I placed the hub back to its original laoction I had problems. Solution: In between the hub and outlet I installled a z-wave repeater (actually it was a leviton plugin socket which acts as a repeater). No problems since.

1 Like

Hi its the one that came in the kit.
The hub is on the floor above. I guess it could be a network issue… but it always turns on ok.
It turns on and off via the app just fine all the time.

Ok so looking back at the logs the days it does not work is when I have turned it on early myself.

Any ideas on why that would stop it turning off at the correct time?

So and update - it did not turn on today either…
I did not touch it all day.
I am guessing its down to network issue now so I moved a PIR into that room too to try and boost the mesh… will report back.

You could try a zwave network repair as you add devices.

Thanks just done that. Will see if it turns off at 2205!

Nope. Still not working. Will just turn it on and off in the app for now and will look at better way to do it once I move to my bigger set up (just trial at the moment)

First, it’s a zigbee device so if you think it’s having connection issues you can unplug your hub and take out the batteries for 15 minutes. This should make your zigbee devices remake the mesh when you start it back up.

Also, how far away from the hub is the outlet? Are you able to control it through the app directly?

Ok thanks - didn’t know that.

Yes it works perfect from the app.

Its around 5m away from the hub horizontal and 3m vertical. The house is a modern UK house with light timber frame and plasterboard walls so no stone walls etc. Is there any way to see the RSSI at the device?

If it works near instantly within the app then you shouldn’t have range issues. When you look under the ‘Recently’ tab for the outlet does it show any commands coming from the SmartApp at the requested times?

No. It was reporting some power usage (21W ish) but it only does that from time to time.

The last time it worked for the “off” routine was Friday night. The “on” routine worked ok until a couple of days ago.

ok so I just found something strange.
The “goodnight” routine was set to run at 2145 Mon, Tue, Wed, Thur and turn off the outlet.
I also had my own routine set to run at 22:05 all days.

I wonder if it was some kind of conflict.

So I removed my own routines that I made and just use the ST stock routines of “I’m back” and “goodnight”.

Will report back!

Well it turned off ok!!
So happy with that - will keep my eye on it!

1 Like

Turned on ok today too - chalking this one up as a win :smile:

1 Like

glad to hear it ended up working out for you :slight_smile:

1 Like

Just wanted to come back with a final update. The routines stopped working again.
Spent a couple of days faffing about with it and in the end deleted all the routines and installed the smart lighting app and it worked perfect from that moment. I now have hue also and its running that just fine also.

So for anyone new like myself if you have any issues with routines for lighting just use the smart lighting app instead because its way better. Cheers.